cupsBackChannelRead() fails on Ubuntu 11.10

Bug #961207 reported by Phil Ineichen on 2012-03-21
6
This bug affects 1 person
Affects Status Importance Assigned to Milestone
cups (Ubuntu)
Undecided
Unassigned

Bug Description

The following code runs fine on Ubuntu 11.04 (CUPS 1.4.6)

byte buf[16];
ssize_t bytesRead = cupsBackChannelRead((char*)buf, sizeof(buf), 2.5);
if(bytesRead == -1)
{
   fprintf(stderr, "DEBUG: cupsBackChannelRead failed, errno=%d\n", errno);
}
else if(bytesRead == 0)
{
   fprintf(stderr, "DEBUG: cupsBackChannelRead no data\n");
}
else
{
   fprintf(stderr, "DEBUG: cupsBackChannelRead has read %i bytes\n", bytesRead);
}

But cupsBackChannelRead() returns -1 and errno 11 on Ubuntu 11.10 (CUPS 1.5.0)!

I am not sure what is causing this behavior (CUPS, driver or Ubuntu).

Thank you!

Phil Ineichen (pineichen) wrote :

It is not a CUPS 1.5.0 issue since it is working with other Linux distributions with CUPS 1.5.0.

It looks like an Ubuntu 11.10 bug.

Till Kamppeter (till-kamppeter) wrote :

Is your printer connected via USB? If so, the problem is that the "usb" backend of CUPS in Oneiric has no backchannel support. This problem is fixed in Precise (12.04).

Changed in cups (Ubuntu):
status: New → Incomplete
Phil Ineichen (pineichen) wrote :

Yes, the printer is connected via USB. Then I'll be looking for 12.04.
Thank you

Till Kamppeter (till-kamppeter) wrote :

Please tell us whether it works on 12.04. Boot a 12.04 live CD and do all updates in the live session, then try again. Does it work now?

Phil Ineichen (pineichen) wrote :

Ubuntu 12.04 beta does not run in my VMware. I guess I'll try as soon as 12.04 has been released.

Till Kamppeter (till-kamppeter) wrote :

I am grateful if you could do the live CD test. It should work with any computer with USB port or optical drive and does not modify any thin on the computer.

Phil Ineichen (pineichen) wrote :

It is working with Ubuntu 12.04 beta.

Till Kamppeter (till-kamppeter) wrote :

OK, thank you. So I will close this bug as fixed ...

Changed in cups (Ubuntu):
status: Incomplete → Fix Released
To post a comment you must log in.
This report contains Public information  Edit
Everyone can see this information.

Other bug subscribers

Related questions