Update of a printer driver package does not update the PPD files of the existing queues for this driver

Bug #932882 reported by Marcin Juszkiewicz on 2012-02-15
72
This bug affects 11 people
Affects Status Importance Assigned to Milestone
cups (Ubuntu)
High
Unassigned
Nominated for Bionic by Marcin Juszkiewicz
Nominated for Trusty by Marcin Juszkiewicz
Precise
Undecided
Unassigned
Quantal
High
Unassigned
gutenprint (Ubuntu)
High
Till Kamppeter
Nominated for Bionic by Marcin Juszkiewicz
Nominated for Trusty by Marcin Juszkiewicz
Precise
High
Unassigned
Quantal
Medium
Till Kamppeter

Bug Description

I needed to print few tickets for travel. But as they did not appeared on my printer I took a look at http://localhost:631/ and discovered this:

"The PPD version (5.2.7) is not compatible with Gutenprint 5.2.8-pre1."

Had to print to PDF and do printing from MS Windows laptop...

[Impact] Printers used with Gutenprint do not work for all users who update from an older Ubuntu version to Precise.

[Test Case] To reproduce: Upgrade from Gutenprint 5.2.7 to 5.2.8~pre1-0ubuntu2 does not update the PPD files of existing queues. To test, create a Gutenprint-based print queue on a system with 5.2.7 then run

grep -i gutenprint /etc/cups/ppd/*.ppd

and see that the PPD files are of Gutenprint version 5.2.7. Update to 5.2.8~pre1-0ubuntu2 and run

grep -i gutenprint /etc/cups/ppd/*.ppd

The PPDs are still not upgraded. Update from 5.2.7 or 5.2.8~pre1-0ubuntu2 to 5.2.8~pre1-0ubuntu2.1 and your PPD files get updated to 5.2.8pre1.

[Regression Potential] Only change is the timestamp of one file. So regressions should not be possible.

Till Kamppeter (till-kamppeter) wrote :

Can you run

sudo apt-get install --reinstall printer-driver-gutenprint

and post the screen output here?

Can you also attach your PPD file(s) from /etc/cups/ppd/

Changed in cups (Ubuntu):
status: New → Incomplete
affects: cups (Ubuntu) → gutenprint (Ubuntu)
Marcin Juszkiewicz (hrw) wrote :

18:16 root@puchatek:~# LC_ALL=C sudo apt-get install --reinstall printer-driver-gutenprint
Reading package lists... Done
Building dependency tree
Reading state information... Done
The following package was automatically installed and is no longer required:
  libreoffice-report-builder-bin
Use 'apt-get autoremove' to remove them.
0 upgraded, 0 newly installed, 1 reinstalled, 0 to remove and 0 not upgraded.
Need to get 383 kB of archives.
After this operation, 0 B of additional disk space will be used.
Get:1 http://de.archive.ubuntu.com/ubuntu/ precise/main printer-driver-gutenprint amd64 5.2.8~pre1-0ubuntu1 [383 kB]
Fetched 383 kB in 0s (5600 kB/s)
(Reading database ... 282030 files and directories currently installed.)
Preparing to replace printer-driver-gutenprint 5.2.8~pre1-0ubuntu1 (using .../printer-driver-gutenprint_5.2.8~pre1-0ubuntu1_amd64.deb) ...
Unpacking replacement printer-driver-gutenprint ...
Processing triggers for man-db ...
Processing triggers for cups ...
Updating PPD files for cups-filters ...
Setting up printer-driver-gutenprint (5.2.8~pre1-0ubuntu1) ...
localepurge: Disk space freed in /usr/share/locale: 0 KiB
localepurge: Disk space freed in /usr/share/man: 0 KiB
localepurge: Disk space freed in /usr/share/gnome/help: 0 KiB
localepurge: Disk space freed in /usr/share/omf: 0 KiB
localepurge: Disk space freed in /usr/share/doc/kde/HTML: 0 KiB

Total disk space freed by localepurge: 0 KiB

18:16 root@puchatek:~#

Marcin Juszkiewicz (hrw) wrote :
Marcin Juszkiewicz (hrw) wrote :

Since I installed Ubuntu on this machine I upgraded 5.2.5 -> 5.2.6 -> 5.2.7 -> 5.2.8-pre1 and only last update failed.

Changed in gutenprint (Ubuntu):
status: Incomplete → Opinion
Marcin Juszkiewicz (hrw) wrote :

I reconfigured printer using web interface

Marcin Juszkiewicz (hrw) wrote :

printer works after reconfiguring - but this should not have to be required

Till Kamppeter (till-kamppeter) wrote :

The problem is that if the packages printer-driver-gutenprint and cups are updated in the same update run, the updating of the PPD files of existing queues does not happen, as the triggers for cups are not executed while cups is not configured. To reproduce, run

sudo apt-get install --reinstall cups printer-driver-gutenprint

What should happen is that during the process

Processing triggers for cups ...

should appear on the screen, which never happens. If only printer-driver-gutenprint gets updated, the PPD update via the cups trigger works.

Changed in gutenprint (Ubuntu):
status: Opinion → Confirmed
importance: Undecided → High
summary: - The PPD version (5.2.7) is not compatible with Gutenprint 5.2.8-pre1.
+ Update of a printer driver package does not update the PPD files of the
+ existing queues for this driver
Changed in gutenprint (Ubuntu):
status: Confirmed → Fix Committed
affects: gutenprint (Ubuntu) → cups (Ubuntu)
Changed in cups (Ubuntu):
milestone: none → ubuntu-12.04-beta-2
Till Kamppeter (till-kamppeter) wrote :

Problem solved. Now we do a PPD update during configuration of the "cups" package, to update the PPDs for all printer driver packages where we missed the triggers due to the fact that we also update "cups" at the same time.

See also http://www.seanius.net/blog/2009/09/dpkg-triggers-howto/, section "How triggers work in a nutshell":

Note that if a consumer is going to be normally configured (i.e. it is also being updated), then no triggering may occur and thus the standard control flow of the maintainer scripts should still take care to handle this.

The consumer in our case is the "cups" package and the producers are the printer driver packages.

The fix is in the upcoming CUPS 1.5.2-6 package which is currently in Debian's BZR repository and will soon get uploaded to Precise.

Till Kamppeter (till-kamppeter) wrote :

To get printing back working for you run the commands:

sudo cups-genppdupdate
sudo restart cups

Launchpad Janitor (janitor) wrote :

This bug was fixed in the package cups - 1.5.2-5bzr1

---------------
cups (1.5.2-5bzr1) precise; urgency=low

  Upload current Debian packaging bzr, as it's not appropriate to upload to
  Debian sid at the moment.

  [ Till Kamppeter ]
  * debian/cups.postinst: Run "triggered" code porion of cups postinstall
    script also when configuring cups ("configure") so that when cups
    and a printer driver package (which triggers cups to update the PPD files
    of existing print queues) get updated together the PPD update for sure
    happens also if the driver's trigger action is not executed due to cups
    also being updated (LP: #932882).

  [ Martin Pitt ]
  * debian/control: Wrap dependencies.
  * debian/control, debian/rules: Move from hardening-wrapper to using
    dpkg-buildflags. Bump dpkg-dev build dependency to (>= 1.16.1~) for this.
  * Add tests-ignore-colord-warnings.patch: Ignore warnings from colord in the
    tests, as they change the expected number of warnings.
  * debian/rules: Have package fail to build on test failures again.
  * debian/copyright: Convert to copyright format 1.0, and update to current
    license/copyrights.
  * debian/control: Bump Standards-Version to 3.9.3.
 -- Martin Pitt <email address hidden> Fri, 02 Mar 2012 17:18:15 +0100

Changed in cups (Ubuntu):
status: Fix Committed → Fix Released

To assure that the PPD updating also works when upgrading from an older Ubuntu to Precise, we add some additional measure to Gutenprint (using the old upgrade method whn updating from Gutenprint older than 5.2.8).

Changed in gutenprint (Ubuntu):
importance: Undecided → High
milestone: none → ubuntu-12.04-beta-2
status: New → In Progress
Launchpad Janitor (janitor) wrote :

This bug was fixed in the package gutenprint - 5.2.8~pre1-0ubuntu2

---------------
gutenprint (5.2.8~pre1-0ubuntu2) precise; urgency=low

  * debian/printer-driver-gutenprint.postinst: Use old method to update the
    PPDs of existing print queues on the transition from Gutenprint 5.2.7 to
    5.2.8 (LP: #932882, LP: #960496).
  * debian/printer-driver-gutenprint.ppd-updater: Improvement of NickName
    matching rules.
 -- Till Kamppeter <email address hidden> Thu, 22 Mar 2012 15:00:00 +0100

Changed in gutenprint (Ubuntu):
status: In Progress → Fix Released

So what is one supposed to do now if he's been hit by the bug and his Precise Beta says the PPD is not compatible with Gutenprint ?

Will applying further new updates be enough ?

What happened is that the PPD file of your printer did not get automatically updated with the last update of Gutenprint (the printer driver). The problem should get solved by the next update whichg should be available in a few hours.

papukaija (papukaija) wrote :

I have installed my printer to a Precise machine. However, the printing over the network from a Oneiric machine failed. I didn't get any errors to my Oneiric machine (though it was quite slow to find the shared printer) but on the Precise machine I got the above mentioned message. Does this mean that Oneiric's cups needs a fix too or should I open a new bug? Thanks.

papukaija (papukaija) wrote :

Please ignore the above question. I checked the ppd file and it was using 5.2.7 as file version even when I upgraded my system to Precise on Thursday. Doesn't this fix apply if the ppd has been manually edited (to enable more printing resolutions)?

I needed to print an application form, and after a few seconds the process "stopped". I checked the printer log and found the
message "The PPD version (5.2.7) simplified is not compatible with Gutenprint 5.2.8-pre1". I have tried to update the PPDs.
but the command I was told to use failed "permission denied"

Changed in gutenprint (Ubuntu):
assignee: nobody → Angela Rowlands (rowlandsangela)
papukaija (papukaija) wrote :

@Angela: This bug is fixed. Please open a new bug for your issue. Thanks.

Changed in gutenprint (Ubuntu):
assignee: Angela Rowlands (rowlandsangela) → nobody

Angela, the problem was still present and caused by a bug in Gutenprint. Reopening ...

New fix is on its way ...

Changed in gutenprint (Ubuntu):
status: Fix Released → In Progress
status: In Progress → Fix Committed
Changed in cups (Ubuntu Precise):
status: New → Invalid
Changed in gutenprint (Ubuntu Precise):
importance: Undecided → High
status: New → Triaged
milestone: none → ubuntu-12.04.1
Launchpad Janitor (janitor) wrote :

This bug was fixed in the package gutenprint - 5.2.8-0ubuntu1

---------------
gutenprint (5.2.8-0ubuntu1) quantal; urgency=low

  * New upstream release
     - Added support for Canon PIXMA DS700, DS810, 50i, 80i, 450i, 455i, 470PD,
       475PD, 550i, 560i, 850i, 860i, 865R, 900PD, 950i, 960i, 990i, 6100i,
       6500i, 9100i, 9900i, i450X, i455X, i475D, i550X, i560X, i905D, i965,
       i990, i9950, iP90, iP90v, iP100, iP6320D, MP260, MX320, MX370, MX430,
       MX510, MX710, MX890, E500, E600, PIXUS iP2700, iP3100, iP4100,
       EPSON Stylus NX420, SX420, TX420
     - CD printing on many Canon printers.
     - Non-working Canon's removed.
     - More Japanese models supported.
     - Printer modes for most printer models are now determined by the
       media, based on information from the corresponding Windows
       driver. If an incompatible mode is selected by the user, a
       suitable mode is substituted, based on the other active
       parameters and quality setting. Modes are also substituted
       based on cartridge selection and duplex selection. Inktype is
       then automatically adjusted.
     - Added support for 8-bit inks to Canon backend, and modes using
       them.
     - Adjusted margins and page sizes of Canon printers.
     - Added borderless functionality to most Canon printers.
     - A problem whereby printing did not work at all on some Linux
       distributions has been fixed.
     - Printing on the Epson Stylus NX200, SX200, and SX205 is believed
       to be corrected.
  * debian/patches/0002-genppd-don-t-write-color-profile-information-with-br.patch,
    debian/patches/0003-upgrade-getopt.patch,
    debian/patches/0004-no-data-dumper-needed.patch,
    debian/patches/0005-use-dnointerpolate-in-ghostscript-command-lines.patch:
    Removed, change applied upstream.
  * debian/rules: Touch ppd-updater file(s) so that they have the time stamp
    of the build of this package The time stamp of the ppd-updater files tells
    CUPS' trigger script whether they come from different package versions or
    not (LP: #932882).
 -- Till Kamppeter <email address hidden> Tue, 19 Jun 2012 17:12:48 +0200

Changed in gutenprint (Ubuntu):
status: Fix Committed → Fix Released
Changed in gutenprint (Ubuntu Precise):
status: Triaged → Fix Committed

Uploaded a fixed gutenprint package for Precise to -proposed. As soon as the package gets approved we post instructions for installing and testing it here. Please do the test and give us feedback as this is required to make the package an official update for Precise.

To SRU team: debdiff attached.

To reproduce: Upgrade from Gutenprint 5.2.7 to 5.2.8~pre1-0ubuntu2 does not update the PPD files of existing queues. To test, create a Gutenprint-based print queue on a system with 5.2.7 then run

grep -i gutenprint /etc/cups/ppd/*.ppd

and see that the PPD files are of Gutenprint version 5.2.7. Update to 5.2.8~pre1-0ubuntu2 and run

grep -i gutenprint /etc/cups/ppd/*.ppd

The PPDs are still not upgraded. Update from 5.2.7 or 5.2.8~pre1-0ubuntu2 to 5.2.8~pre1-0ubuntu2.1 and your PPD files get updated to 5.2.8pre1.

Download full text (4.5 KiB)

Am Dienstag, den 19.06.2012, 18:55 +0000 schrieb Till Kamppeter:

> Uploaded a fixed gutenprint package for Precise to -proposed. As soon as
> the package gets approved we post instructions for installing and
> testing it here. Please do the test and give us feedback as this is
> required to make the package an official update for Precise.
>
> To SRU team: debdiff attached.
>
> To reproduce: Upgrade from Gutenprint 5.2.7 to 5.2.8~pre1-0ubuntu2 does
> not update the PPD files of existing queues. To test, create a
> Gutenprint-based print queue on a system with 5.2.7 then run
>
> grep -i gutenprint /etc/cups/ppd/*.ppd
>
> and see that the PPD files are of Gutenprint version 5.2.7. Update to
> 5.2.8~pre1-0ubuntu2 and run
>
> grep -i gutenprint /etc/cups/ppd/*.ppd
>
> The PPDs are still not upgraded. Update from 5.2.7 or
> 5.2.8~pre1-0ubuntu2 to 5.2.8~pre1-0ubuntu2.1 and your PPD files get
> updated to 5.2.8pre1.
>
>
> ** Patch added: "gutenprint_5.2.8~pre1-0ubuntu2_5.2.8~pre1-0ubuntu2.1.debdiff"
> https://bugs.launchpad.net/ubuntu/+source/cups/+bug/932882/+attachment/3196394/+files/gutenprint_5.2.8%7Epre1-0ubuntu2_5.2.8%7Epre1-0ubuntu2.1.debdiff

dies ist das Ergebnis:

> christoph@christoph-desktop:~$ diff -Nru gutenprint-5.2.8~pre1/debian/changelog gutenprint-5.2.8~pre1/debian/changelog

diff: gutenprint-5.2.8~pre1/debian/changelog: Datei oder Verzeichnis
nicht gefunden
diff: gutenprint-5.2.8~pre1/debian/changelog: Datei oder Verzeichnis
nicht gefunden
christoph@christoph-desktop:~$ ---
gutenprint-5.2.8~pre1/debian/changelog2012-03-22 15:01:04.000000000
+0100
---: command not found
christoph@christoph-desktop:~$ +++
gutenprint-5.2.8~pre1/debian/changelog2012-06-19 20:33:13.000000000
+0200
No command '+++' found, did you mean:
 Command 'c++' from package 'clang' (universe)
 Command 'c++' from package 'g++' (main)
 Command 'c++' from package 'pentium-builder' (universe)
 Command 'g++' from package 'g++' (main)
 Command 'g++' from package 'pentium-builder' (universe)
+++: command not found
christoph@christoph-desktop:~$ @@ -1,3 +1,12 @@
@@: command not found
christoph@christoph-desktop:~$ +gutenprint (5.2.8~pre1-0ubuntu2.1)
precise-proposed; urgency=low
bash: Syntaxfehler beim unerwarteten Wort `5.2.8~pre1-0ubuntu2.1'
christoph@christoph-desktop:~$ +
+: command not found
christoph@christoph-desktop:~$ + * debian/rules: Touch ppd-updater
file(s) so that they have the time stamp
bash: Syntaxfehler beim unerwarteten Wort `('
christoph@christoph-desktop:~$ + of the build of this package The
time stamp of the ppd-updater files tells
+: command not found
christoph@christoph-desktop:~$ + CUPS' trigger script whether they
come from different package versions or
> + not (LP: #932882).
> +
> + -- Till Kamppeter <email address hidden> Tue, 19 Jun 2012
20:32:48 +0200
> +
> gutenprint (5.2.8~pre1-0ubuntu2) precise; urgency=low
>
> * debian/printer-driver-gutenprint.postinst: Use old method to
update the
> diff -Nru gutenprint-5.2.8~pre1/debian/rules
gutenprint-5.2.8~pre1/debian/rules
> --- gutenprint-5.2.8~pre1/debian/rules2012-02-14 21:48:48.000000000
+0100
> +++ gutenprint-5.2.8~pre1/debian/rules2012-06-19 20:32:06.000000...

Read more...

Christoph, the debdiff file is not supposed to be executed at the command line. The debdiff file is a data file showing in human-readable format what has changed between the source package of the current Gutenprint package and the source package of the Gutenprint package which I propose as an update. It mainly serves for the SRU release team to decide on approving my proposed update. Who know about Debian source packages and how to build them can also use the debdiff to generate the proposed package to test it out. The file is not intended for end user consumption.

As soon as the package is approved, we will post instructions here on how to test the package.

Scott Kitterman (kitterman) wrote :

The diff looks reasonable, but before the package can be accepted, it needs a test case and regression potential in the bug. See https://wiki.ubuntu.com/StableReleaseUpdates for details.

Changed in gutenprint (Ubuntu Precise):
status: Fix Committed → In Progress
description: updated
Changed in gutenprint (Ubuntu Precise):
status: In Progress → Fix Committed
description: updated

Hello Marcin, or anyone else affected,

Accepted gutenprint into precise-proposed. The package will build now and be available at http://launchpad.net/ubuntu/+source/gutenprint/5.2.8~pre1-0ubuntu2.1 in a few hours and then in the -proposed repository. Please help us by testing this new package. See https://wiki.ubuntu.com/Testing/EnableProposed for documentation how to enable and use -proposed. Your feedback will aid us getting this update out to other Ubuntu users.

If this package fixes the bug for you please change the bug tag from verification-needed to verification-done. If it does not, change the tag to verification-failed. In either case details of your testing will help us make a better decision. Further information regarding the verification process can be found at https://wiki.ubuntu.com/QATeam/PerformingSRUVerification . Thank you in advance!

tags: added: verification-needed

Marcin, Christoph, Angela, papakaija, can you please test the fixed Precise packages in -proposed as described in comment #25 and comment #23? We NEED your feedback to make an official update for Precise.

Marcin Juszkiewicz (hrw) wrote :

I am on quantal with all machines now. And those which were affected got it fixed either by package or by hand. So rather can not help testing ;(

Marcin, can you do the following test:

Boot a live CD (or USB stick) of Precise on a machine where your printer is connected to. Set up the printer in the live session (if it does not get set up automatically) and run

grep -i gutenprint /etc/cups/ppd/*.ppd

This should show the version number 5.2.8-pre1 in the output.

Now follow the instructions of comment #25 in the live session so that your gutenprint gets updated to the proposed package.

Run

grep -i gutenprint /etc/cups/ppd/*.ppd

again and the version numbers in the output should have changed to 5.2.8, without pre1.

With this the fix would be verified.

Marcin Juszkiewicz (hrw) wrote :

root@ubuntu:/etc/apt# grep -i gutenprint /etc/cups/ppd/*
*% PPD file for CUPS/Gutenprint.
*NickName: "Epson Stylus DX4050 - CUPS+Gutenprint v5.2.8-pre1"
*cupsFilter: "application/vnd.cups-raster 100 rastertogutenprint.5.2"
*StpPPDLocation: "/usr/share/cups/model/gutenprint/5.2/C/ppd/stp-escp2-dx4050.5.2.ppd"
root@ubuntu:/etc/apt# apt-get install printer-driver-gutenprint
Czytanie list pakietów... Gotowe
Budowanie drzewa zależności
Odczyt informacji o stanie... Gotowe
Sugerowane pakiety:
  gutenprint-doc gutenprint-locales
Następujące pakiety zostaną zaktualizowane:
  printer-driver-gutenprint
1 aktualizowanych, 0 nowo instalowanych, 0 usuwanych i 320 nieaktualizowanych.
Konieczne pobranie 386 kB archiwów.
Po tej operacji zostanie dodatkowo użyte 1024 B miejsca na dysku.
Pobieranie:1 http://archive.ubuntu.com/ubuntu/ precise-proposed/main printer-driver-gutenprint amd64 5.2.8~pre1-0ubuntu2.1 [386 kB]
Pobrano 386 kB w 0s (1377 kB/s)
(Odczytywanie bazy danych ... 147516 files and directories currently installed.)
Przygotowanie do zastąpienia printer-driver-gutenprint 5.2.8~pre1-0ubuntu2 (wykorzystując .../printer-driver-gutenprint_5.2.8~pre1-0ubuntu2.1_amd64.deb) ...
Rozpakowanie pakietu zastępującego printer-driver-gutenprint ...
Przetwarzanie wyzwalaczy dla cups...
Updating PPD files for cups-filters ...
Updating PPD files for foomatic-db-compressed-ppds ...
Updating PPD files for foomatic-db-engine ...
Updating PPD files for ghostscript-cups ...
Updating PPD files for openprinting-ppds ...
Updating PPD files for c2esp ...
Updating PPD files for foo2zjs ...
Updating PPD files for gutenprint ...
PPD for printer Epson-Stylus-DX4050 updated
Updating PPD files for hpcups ...
Updating PPD files for hpijs ...
Updating PPD files for ptouch ...
Updating PPD files for pxljr ...
Updating PPD files for sag-gdi ...
Updating PPD files for splix ...
Przetwarzanie wyzwalaczy dla man-db...
Konfigurowanie printer-driver-gutenprint (5.2.8~pre1-0ubuntu2.1) ...
root@ubuntu:/etc/apt# grep -i gutenprint /etc/cups/ppd/*
*% PPD file for CUPS/Gutenprint.
*NickName: "Epson Stylus DX4050 - CUPS+Gutenprint v5.2.8-pre1"
*cupsFilter: "application/vnd.cups-raster 100 rastertogutenprint.5.2"
*StpPPDLocation: "/usr/share/cups/model/gutenprint/5.2/C/ppd/stp-escp2-dx4050.5.2.ppd"

Marcin Juszkiewicz (hrw) wrote :

That was Ubuntu booted in VirtualBox with my USB printer.

Marcin, thank you. The update is OK. I forgot that in the SRU I did not update the upstream source from 5,2,8pre1 to 5.2.8. The PPD updating works now as the output of the update process says

Updating PPD files for gutenprint ...
PPD for printer Epson-Stylus-DX4050 updated

Fix is verified.

tags: added: verification-done
removed: verification-needed
Launchpad Janitor (janitor) wrote :

This bug was fixed in the package gutenprint - 5.2.8~pre1-0ubuntu2.1

---------------
gutenprint (5.2.8~pre1-0ubuntu2.1) precise-proposed; urgency=low

  * debian/rules: Touch ppd-updater file(s) so that they have the time stamp
    of the build of this package The time stamp of the ppd-updater files tells
    CUPS' trigger script whether they come from different package versions or
    not (LP: #932882).
 -- Till Kamppeter <email address hidden> Tue, 19 Jun 2012 20:32:48 +0200

Changed in gutenprint (Ubuntu Precise):
status: Fix Committed → Fix Released
Marcin Juszkiewicz (hrw) wrote :

"The PPD version (5.2.8) is not compatible with Gutenprint 5.2.9." is what I just got under quantal ;(

Changed in gutenprint (Ubuntu):
status: Fix Released → In Progress
Marcin Juszkiewicz (hrw) wrote :

10:34 root@puchatek:~# grep -i gutenprint /etc/cups/ppd/*
*% PPD file for CUPS/Gutenprint.
*NickName: "Epson Stylus DX3850 - CUPS+Gutenprint v5.2.8"
*cupsFilter: "application/vnd.cups-raster 100 rastertogutenprint.5.2"
*StpPPDLocation: "/usr/share/cups/model/gutenprint/5.2/C/ppd/stp-escp2-dx3850.5.2.ppd"
10:34 root@puchatek:~# dpkg-reconfigure cups
cups stop/waiting
cups start/running, process 1678
Updating PPD files for cups ...
10:35 root@puchatek:~# grep -i gutenprint /etc/cups/ppd/*
*% PPD file for CUPS/Gutenprint.
*NickName: "Epson Stylus DX3850 - CUPS+Gutenprint v5.2.8"
*cupsFilter: "application/vnd.cups-raster 100 rastertogutenprint.5.2"
*StpPPDLocation: "/usr/share/cups/model/gutenprint/5.2/C/ppd/stp-escp2-dx3850.5.2.ppd"

Marcin Juszkiewicz (hrw) wrote :

10:38 root@puchatek:~# cd /usr/share/cups/ppd-updaters/
10:38 root@puchatek:ppd-updaters# ll
razem 24
-rw-r--r-- 1 root root 81 maj 18 14:58 cups-filters.ppd-updater
-rw-r--r-- 1 root root 108 lip 7 10:28 foomatic-db-compressed-ppds
-rw-r--r-- 1 root root 49 lip 7 10:25 foomatic-db-engine
-rw-r--r-- 1 root root 55 lip 12 06:40 ghostscript-cups
-rw-r--r-- 1 root root 137 lip 7 10:28 openprinting-ppds
-rw-r--r-- 1 root root 220 lip 11 14:30 printer-driver-gutenprint.ppd-updater
10:38 root@puchatek:ppd-updaters# touch printer-driver-gutenprint.ppd-updater
10:38 root@puchatek:ppd-updaters# dpkg-reconfigure cups
cups stop/waiting
cups start/running, process 11455
Updating PPD files for cups ...
Updating PPD files for gutenprint ...
PPD for printer Stylus-DX4000 updated
10:39 root@puchatek:ppd-updaters# grep -i gutenprint /etc/cups/ppd/*
*% PPD file for CUPS/Gutenprint.
*NickName: "Epson Stylus DX3850 - CUPS+Gutenprint v5.2.9"
*cupsFilter: "application/vnd.cups-raster 100 rastertogutenprint.5.2"
*StpPPDLocation: "/usr/share/cups/model/gutenprint/5.2/C/ppd/stp-escp2-dx3850.5.2.ppd"
10:39 root@puchatek:ppd-updaters#

Didier Roche (didrocks) wrote :

Till, see the above comment, can you please work on it?

Changed in gutenprint (Ubuntu Quantal):
assignee: nobody → Till Kamppeter (till-kamppeter)

I cannot reproduce it. So I set it to "Incomplete" now. Needed are exact steps for reproducing the bug.

Changed in gutenprint (Ubuntu Quantal):
importance: High → Medium
status: In Progress → Incomplete
Sebastien Bacher (seb128) wrote :

no reply, closing the bug

Changed in gutenprint (Ubuntu Quantal):
milestone: ubuntu-12.04-beta-2 → none
status: Incomplete → Invalid
Thorsten Hirsch (t-hirsch) wrote :

This bug re-occured when upgrading from 12.04 to 12.10. There's only a difference in the version numbers in the error message:

"The PPD version (5.2.8-pre1) is not compatible with Gutenprint 5.2.9."

I had to "sudo cups-genppdupdate" manually to resolve the issue. Why is this command not being called automatically when upgrading the cups package?

papukaija (papukaija) wrote :

Reopening as per comment 39.

Changed in gutenprint (Ubuntu Quantal):
status: Invalid → New

Confirming. Got it as well.

Changed in gutenprint (Ubuntu Quantal):
status: New → Confirmed
Paul Abrahams (abrahams) wrote :

I ran into a PPD problem after an update of Kubuntu 12.04. Before the update, my LaserJet 5 normally printed in single-page mode. After the update it printed in duplex mode and I couldn't get it to print in single-page mode. The problem was an incorrect version of the PPD, which I verified by reinstalling the printer and asking for the "old" ppd.

I had this problem once before, where my printer suddenly starting printing in duplex mode all the time. Again, the problem was an update that installed an incorrect ppd.

László Monda (mondalaci) wrote :

Got it after upgrading to Linux Mint 14 Nadia (based on Ubuntu 12.10 Quantal Quetzal).

After executing "sudo apt-get install --reinstall printer-driver-gutenprint" and reconfiguring my printer now I get "stopped, Filter failed" upon every one of my print attempts. Currently I cannot print.

Please mark this bug at least of High importance as it completely breaks printing upon system upgrades. This is exactly the kind of bug that drives newcomer Linux users away for life (and rightly so).

carloslp (carloslp) wrote :

Confirmed.

* Printer was working on Ubuntu 11.04
* After a double upgrade to 12.04 (11.04 -> 11.10 ->12.04) printer stopped working. The same error and same problem.

Running the following fixed the issue:

sudo apt-get install --reinstall printer-driver-gutenprint
sudo cups-genppdupdate
sudo restart cups

Sumeet Grover (sgrover) wrote :

Thanks a tonne guys - you saved me a big hassle. My printer's working now after following these instructions.

Cheers.

Marcin Juszkiewicz (hrw) wrote :

Another machine. Raring -> Saucy -> Trusty done on one day.

"The PPD version (5.2.9) is not compatible with Gutenprint 5.2.10-pre2."

Will it get fixed finally???

Changed in gutenprint (Ubuntu):
importance: Medium → High
Changed in cups (Ubuntu):
status: Fix Released → In Progress
Rolf Leggewie (r0lf) wrote :

quantal has seen the end of its life and is no longer receiving any updates. Marking the quantal task for this ticket as "Won't Fix".

Changed in gutenprint (Ubuntu Quantal):
status: Confirmed → Won't Fix
AnrDaemon (anrdaemon) wrote :

The PPD version (5.2.5 Simplified) is not compatible with Gutenprint 5.2.8-pre1.

The machine was over the years upgraded from Hardy Heron (8.04).

fabtagon (fabtagon) wrote :

Same when upgrading to from previous LTS to Bionic.

fabtagon (fabtagon) wrote :
Marcin Juszkiewicz (hrw) wrote :

I no longer own Epson printer nor use Ubuntu. Still have fun reading comments in this bug every time new LTS gets released.

Six years. Few LTS releases and bug is still present. Amazing.

To post a comment you must log in.
This report contains Public information  Edit
Everyone can see this information.

Duplicates of this bug

Other bug subscribers

Related questions