laser printer only prints first job correct

Bug #872483 reported by Guido Do on 2011-10-11
76
This bug affects 13 people
Affects Status Importance Assigned to Milestone
cups (Ubuntu)
Medium
Unassigned
Oneiric
Medium
Unassigned
Precise
Medium
Unassigned

Bug Description

please also refer to this bug - this seems to be exactly my issue and does not seem to be solved.
https://bugs.launchpad.net/ubuntu/+source/foomatic-db/+bug/855412

ProblemType: Bug
DistroRelease: Ubuntu 11.10 - all updates as of today applied.

I followed https://wiki.ubuntu.com/DebuggingPrintingProblems according to https://bugs.launchpad.net/ubuntu/+source/foomatic-db/+bug/855412/comments/20

I printed two copies of the same document, since this forces the error easily.

The content under /var/spool/cups/d... look fine - see attached files.

after cupsenable <PRINTER> the first copy comes out fine - the second as random character - I stopped after some pages.

The test is with Samsung ML-2250 Series (SPL II) - which worked fine under all previous versions of Ubuntu
Samsung ML-2250 Foomatic/pxlmono (recommended) generates basically the same result.

Guido Do (guido-dornbusch) wrote :
Guido Do (guido-dornbusch) wrote :
Guido Do (guido-dornbusch) wrote :

d00903-001 and d00904-001 are the two copies of the same document printed from LibreOffice Writer.

I scanned the whole output - the first page is the first copy followed by the rubbish.

Guido Do (guido-dornbusch) wrote :

Scanned document - I had trouble to save pdf - so jpg files attached

affects: ubuntu → cups (Ubuntu)
description: updated
Till Kamppeter (till-kamppeter) wrote :

The two attached spool files are absolutely identical, so it is most probably a problem of the printer not being set back to its initial state after the first job has completed.

With which drivers does this problem occur for you? You can try different drivers by changing them with system-config-printer, then turning off and turning on the printer again, after that sending your two print jobs. Are there drivers with which the second job comes out correctly?

Try all drivers offered, especially "Samsung ML-2250, 2.0.0", "Foomatic/gdi", "Foomatic/Postscript", "Foomatic/ljet4d", "CUPS+Gutenprint", "Foomatic/pxlmono", and "Generic PCL-5e printer, Foomatic/hpijs-pcl5e". The last driver is under the model "Generic PCL-5e printer".

Changed in cups (Ubuntu):
status: New → Incomplete
Alex Betis (alex-betis) wrote :

Following Guido Do from bug #855412

Have exactly the same problem with my OKI B410d.
Tried different drivers, no luck on 11.10, everything worked fine on 11.04.

Attaching some logs.
errors_log contain the following:
- restart of cups
- printing test page from printer settings page
- printed ok
- waiting a bit
- printing test page again
- pages start spitting out
- turned off the printer
- turned on the printer
- jammed page came out and after a second the print page was actually printed as well (that's something new, didn't happen before)

In the logs you can see that I have DYMO label writer 450 printer as well, it wasn't affected by upgrade to 11.10 and behaves normally.

Please propose a workaround or something, that's a total no-go for me.

Thanks,
Alex

Alex Betis (alex-betis) wrote :
Alex Betis (alex-betis) wrote :
Alex Betis (alex-betis) wrote :
Alex Betis (alex-betis) wrote :
Alex Betis (alex-betis) wrote :
Alex Betis (alex-betis) wrote :
Alex Betis (alex-betis) wrote :

Is there a way to reset the USB connection from command line or something like that to allow next printed document be printed ok?

There is a known kernel bug about USB printers but up to now it only showed by CUPS not recognizing certain USB printers at all (and so not printing anything), bug 872711. Perhaps this bug can also have caused your problem. Therefore please try the test kernel available here:

http://people.canonical.com/~ogasawara/lp872711/

To do so, download and install the three packages and reboot. This kernel is the original Oneiric kernel with the fix for the mentioned bug added.

Please tell us whether this solves your problem. Thanks.

Alex Betis (alex-betis) wrote :

I'll be happy to try the patches, but my kernel is 3.0.0-12, while the patches are for 3.0.0-13.

Just updated with apt, there was no kernel updates there.

3.0.0-13 is no problem. Simply install the packages as they are and on the next boot this kernel will be used.

The change in the version number is done to not overwrite your original kernel, for the rare case that the new kernel does not boot (I cannot imagine that a tiny patch to recognize USB printers prevents a kernel from booting) you can boot your original kernel.

Note that the packages are for 64-bit.

Alex Betis (alex-betis) wrote :

The patch doesn't help in my case.

My printers are properly recognized, so that's probably a different issue.

Alex Betis (alex-betis) wrote :

Anybody knows if it's possible to reset USB connection from command line?

Turning the printer off and on after every print job is a very bad solution for me since I have to print many documents.
Looks like disconnecting USB cable and reconnecting again have the same effect as off/on, so I wonder if there is a way to reset the connection by software and not by hardware until a solution will be found.

Try the kernel fix anyway, perhaps it helps.

Alex Betis (alex-betis) wrote :

I've tried, see post #18
Didn't help

Alex Betis (alex-betis) wrote :

Ok, found how to reset the USB port:
http://marc.info/?l=linux-usb-users&m=116827193506484&w=2

It helps as a workaround until a fix will be found.

Now I just need to find how to run it automatically after every print job.
Any ideas?

A possibility would be to patch the C code into the "usb" CUPS backend to be executed after each job.

Reported to CUPS upstream:

http://www.cups.org/str.php?L3964

Changed in cups (Ubuntu Oneiric):
importance: Undecided → Medium
Changed in cups (Ubuntu Precise):
importance: Undecided → Medium
status: Incomplete → Triaged
Changed in cups (Ubuntu Oneiric):
status: New → Triaged

The fix for this bug (add sending USBDEVFS_RESET IOCTL to the /dev/bus/usb/XXX/YYY file representing the printer before each job to the "usb" CUPS backend) is a tiny patch, therefore I suggest to make this available as an SRU for Oneiric.

pitti, mvo, so please hold back the SRU in -proposed for bug 877967 and bug 874835 and add also the fix for this bug, to avoid piling up CUPS SRUs.

Alex Betis (alex-betis) wrote :

Not sure that's the best solution for everybody, especially those who are not affected by the problem we've reported.

I can't measure it, but I think the reset cause a delay before the job is actually printed out.
I mean by printing doc1, reset, printing doc2 creates few seconds delay between the doc1 and doc2, while with 11.04 the pagaes came out one after another.

Not sure about it yet since I have to run the reset manually, maybe I wasn't too fast with that.

In any case, I think it's makes a sense to have a configuration flag around the reset before or after every job, so for those who are not affected this will not bring another problem.

I have tried to reproduce it on the following HP printers (I do not have any non-HP) and the bug does not occur for them:

- HP Color LaserJet CM3530 MFP
- HP LaserJet 3390
- HP PhotoSmart C8100
- HP PhotoSmart Pro B8800
- HP OfficeJet H470

For all printers I have created a queue based on the "usb" CUPS backend with system-config-printer and printed the test page two times (by clicking the appropriate button in system-config-printer). All printers print the two test pages correctly.

pitti, can you try on your Samsung? It seems that Samsung is one of the problematic brands.

Alex, I will try out the patch in my HP-only environment (bug does not occur) to check whether there is no regression especially no performance problem.

I have created a patch for the "usb" CUPS backend now, checked by reviewing the source code of libusb that it is really identical with the small C program from the link of comment #22, and did regression tests on my HP printers finding out that the change does not break anything, even not the performance. Print jobs get printed reliably and jobs quickly sent one after the other come out without interruption.

The patch is attached, so that who is familiar with source code can try it out (please report here then).

I will prepare an SRU for CUPS now.

tags: added: patch patch-accepted-debian patch-forwarded-upstream

Committed patch to the Debian BZR repository of CUPS, so the fix will be in the next CUPS packages for Debian unstable and Ubuntu Oneiric.

Changed in cups (Ubuntu Precise):
status: Triaged → Fix Committed

Uploaded CUPS package with the fix for this bug and bug 877967 to -proposed. As soon as the package is approved for testing we will post another comment with further instructions. Please test then and tell us whether the update fixes your problem. A debdiff of the changes is attached.

Changed in cups (Ubuntu Oneiric):
status: Triaged → Fix Committed
Guido Do (guido-dornbusch) wrote :

I tested the debdiff and it fixes the problem I had. All print jobs I tested are processed correctly - also the test-case that in all cases seem to produce the error with several copies.

Martin Lambert (tidosho) wrote :

I also suffer from exactly this problem with a Dell Laser 2330dn on the USB port of my Ubuntu 11.10 box (worked fine in 11.04). When will this fix be available via the Update Manager?

Hello Guido, or anyone else affected,

Accepted cups into oneiric-proposed, the package will build now and be available in a few hours. Please test and give feedback here. See https://wiki.ubuntu.com/Testing/EnableProposed for documentation how to enable and use -proposed. Thank you in advance!

tags: added: verification-needed
Guido Do (guido-dornbusch) wrote :

I just tested finally a document with two copies with the fixed cups from oneiric-proposed.

All print come out perfect again. And I have no performance limitation or interruption/pause between the two copies.

Thanks
Guido

Guido, thank you very much for verifying.

tags: added: verification-done
removed: verification-needed
Launchpad Janitor (janitor) wrote :

This bug was fixed in the package cups - 1.5.0-8ubuntu4

---------------
cups (1.5.0-8ubuntu4) oneiric-proposed; urgency=low

  * debian/patches/usb-backend-reset-printer-before-printing.patch: When
    using the "usb" CUPS backend, reset the printer before each job as
    otherwise on some printers subsequent jobs will come out as garbage
    (LP: #872483).
  * cups-avahi.patch: Make sure to guard against retrying the Avahi connection
    whilst already doing so. Thanks to Tim Waugh for the patch! (LP: #877967)
 -- Till Kamppeter <email address hidden> Thu, 20 Oct 2011 12:27:43 +0200

Changed in cups (Ubuntu Oneiric):
status: Fix Committed → Fix Released
Launchpad Janitor (janitor) wrote :

This bug was fixed in the package cups - 1.5.0-10

---------------
cups (1.5.0-10) unstable; urgency=low

  * debian/cups.postinst: Allow PPD updater trigger files in
    /usr/share/cups/ppd-updaters/ also be named <driver>.ppd-updater
    and not only simply <driver>. This makes it easier to provide these
    files in the printer driver packages.
  * debian/patches/usb-backend-reset-printer-before-printing.patch: When
    using the "usb" CUPS backend, reset the printer before each job as
    otherwise on some printers subsequent jobs will come out as garbage
    (LP: #872483).

 -- Till Kamppeter <email address hidden> Fri, 21 Oct 2011 06:26:41 +0200

Changed in cups (Ubuntu Precise):
status: Fix Committed → Fix Released
Alex Betis (alex-betis) wrote :

Thanks everybody, working great.

That's what I love in Linux / Open source world - the collaboration :)

Martin Lambert (tidosho) wrote :

I'd like to add my thanks too ... (my printing issues disappeared with cups (1.5.0-8ubuntu4) and no perceived performance hit). I agree: Linux and open source should serve as a model for how the world should be :)

It looks like the fix for this bug causes (or makes them more frequent, Bug #793244) random crashes of CUPS usb backend for us on some printers (Samsung ML-2015, Bug #887094).

Would it be possible to make a test cups package with a possible alternative fix from upstream (http://www.cups.org/str.php?L3965) instead of the current usb-backend-reset-printer-before-printing.patch fix?

Aurimas, I have made a CUPS package now which uses the patch of http://www.cups.org/str.php?L3965 instead of doing the USB device reset. It is in my PPA now.

Can everyone who suffers/suffered this bug try the new CUPS package in my PPA (https://launchpad.net/~till-kamppeter/+archive/ppa)? Simply follow the instructions under "Adding this PPA to your system" and then update your Oneiric system. Especially also try this package if the SRU (cups 1.5.0-8ubuntu4) already solved the problem for you, to check whether the alternative, less invasive fix also works for you.

New package (1.5.0-8ubuntu5~ppa2) uploaded to my PPA, to also fix crasher bug 887094. As soon as it gets available for download, please test this one.

Guido Do (guido-dornbusch) wrote :

I briefly tested the new package (1.5.0-8ubuntu5~ppa2) - it works. All print jobs I tested are correct.

We are switching now to the patch from comment #42 in both Precise and in the Oneiric SRU, to have a less invasive solution and to also fix bug 887094.

Changed in cups (Ubuntu Oneiric):
status: Fix Released → Fix Committed
Changed in cups (Ubuntu Precise):
status: Fix Released → Triaged
status: Triaged → Fix Committed
Changed in cups (Ubuntu Oneiric):
status: Fix Committed → Triaged
Launchpad Janitor (janitor) wrote :

This bug was fixed in the package cups - 1.5.0-11

---------------
cups (1.5.0-11) unstable; urgency=low

  [ Till Kamppeter ]
  * debian/patches/usb-backend-gracefully-fail-on-more-cases-of-bad-device-id.patch:
    When reading out the device ID check also for too short lengths of the
    device ID and also in this case try to change the byte order of the length
    bytes and fail if the device ID lenght is still too short (LP: #887094).
  * debian/patches/usb-backend-skip-set-configuration-set-interface.patch:
    Avoid unneeded SET_CONFIGURATION and SET_INTERFACE requests after the
    printer has already been configured. This often leads to subsequent jobs
    coming out as garbage or not at all (CUPS STR #3965, LP: #872483).
  * debian/patches/usb-backend-reset-printer-before-printing.patch: Removed,
    as we are using the less invasive approach of CUPS STR #3965 now.
    This also removes the Linux specific #include, causing FTBFS on non-Linux
    platforms. (Closes: #647666)
  * debian/cups.postinst: Allow PPD updater trigger files in
    /usr/share/cups/ppd-updaters/ also be named
    printer-driver-<driver>.ppd-updater and not only <driver> or
    <driver>.ppd-updater. This makes it easier to provide these
    files in the printer driver packages when we rename all binary packages
    of printer drivers to "printer-driver-<driver>".

  [ Martin-Éric Racine ]
  * debian/control:
    + Added the Homepage field.
    + Cleaned up duplicate Build-Depends.
  * Removed |libheimdal-dev alternative from Build-Depends (Closes: #648105)
 -- Martin Pitt <email address hidden> Fri, 11 Nov 2011 15:48:39 +0100

Changed in cups (Ubuntu Precise):
status: Fix Committed → Fix Released

Uploaded CUPS package with the new fix for this bug and bug 887094 to -proposed. As soon as the package is approved for testing we will post another comment with further instructions. Please test then and tell us whether the update fixes your problem, too. A debdiff of the changes is attached.

Changed in cups (Ubuntu Oneiric):
status: Triaged → Fix Committed

A CUPS package with this correction has been uploaded to oneiric-proposed. See bug 887094 for further instructions and test the package to see whether also this bug got fixed. Please report your results here.

Shanekpiper (shanekpiper) wrote :

Will the fix be released for 11.10 or will it stay as PPA till 12.04

Shanekpiper, yes, the fix will be released for 11.10. Please follow the instructions in bug 887094 for installing and testing the package for 11.10, the sooner we have your feedback, the sooner the package gets into the 11.10 updates for everyone.

McArcher (mcarcher-u) wrote :

Xubuntu 12.04, cups 1.5.2, bug is still not fixed.

1. When I switch on a USB printer Samsung ML-1640, it prints only a first job. Next jobs are written as completed, however they are not printer really.

2. Also, I don't know why, when I try to install printer as in older versions of Ubuntu/Debian using Samsung Unified Driver from Samsung's website, a printer is installed (as ML-1640spl2), but is unable to print anything and after I switch it off and then on, a new printer appears, which is auto-installed with a built-in driver and still I can't use a new one (see previous paragraph).

Felix Heinonen (fheinonen) wrote :

I have a Samsung ML-1655 and up-to-date Lubuntu 12.04. The problem is when I print over my network I have to print from libreoffice fast enough so it would print. If I go and check if printer has printed and I try gain to print it doesn't print anything, but if immediately try to print twice from libreoffice it works most of the time and it only prints maximum 2 pages from a file otherwise it always fails..

Jordi Sayol (g-sayol) wrote :

Bug is still not fixed.

- Ubuntu 12.04.1 64-bit
- linux-generic 3.2.0.29.31
- cups 1.5.3-0ubuntu4
- printer: OKIPAGE 14e (driver: Oki Okipage 14ex Foomatic/hpijs-pcl5e)

First job is correctly printed, but not the following ones. (identical print jobs)

Turning the printer off and on, or disconnecting USB cable and reconnecting again before every printing job, solves the problem.

I confirm the presence of the problem in 12.04.1: Second job comes out as garbage
printer is oki b410d with driver pxlmono or hpijs-pcl5e

the bug should be reopened for precise

Jordi, Ernst, can you do the following:

In a terminal window, run the command

lpadmin -p <printer> -o usb-unidir-default=true

with <printer> being the name of your printer as displayed by the "lpstat -p" command.

Now turn off and turn on your printer, then try to print several jobs. Does this solve the problem?

If not,

run

lpadmin -p <printer> -R usb-unidir-default

and then

lpadmin -p <printer> -o usb-no-reattach-default=true

Again, turn off and turn on your printer, then try to print several jobs. Does this solve the problem?

If not, try

lpadmin -p <printer> -o usb-no-reattach-default=true
lpadmin -p <printer> -o usb-unidir-default=true

and turn off and turn on your printer, then try to print several jobs. Does this solve the problem?

Please tell what works for you.

If nothing works, reset all to defaults via

lpadmin -p <printer> -R usb-no-reattach-default
lpadmin -p <printer> -R usb-unidir-default

Passi J (passi-kauf-mich) wrote :

Hello Till,

I have the same issue with an OKI B410d. I'm running cups 1.5.3 on Kubuntu 12.04

I followed your description with the follwing results:

lpadmin -p <printer> -o usb-unidir-default=true
=> same behavior as before

lpadmin -p <printer> -R usb-unidir-default
lpadmin -p <printer> -o usb-no-reattach-default=true
=> works fine

Thanks and Regards

Passi

Can everyone please also run the

lsusb

command, thanks.

Passi J (passi-kauf-mich) wrote :

...
Bus 002 Device 005: ID 06bc:01c7 Oki Data Corp.
...

Fix for the Oki printers is in Quantal now.

Mossroy (mossroy) wrote :

I have the same issue on an Epson Stylus Color 670 inkjet printer, on Precise 12.04.1 (32 and 64 bits).
The first print is ok, but the following prints result in random characters (see attached scan)
It's a regression because it was working fine on Lucid 10.04.x

lsusb gives :
Bus 002 Device 011: ID 04b8:0005 Seiko Epson Corp. Printer

I ran the requested tests :
lpadmin -p Stylus-COLOR-670 -o usb-unidir-default=true
+ switch off/on the printer
=> not better

lpadmin -p Stylus-COLOR-670 -R usb-unidir-default
lpadmin -p Stylus-COLOR-670 -o usb-no-reattach-default=true
+ switch off/on the printer
=> works

This setting seems to be kept after a reboot, so it looks like a viable workaround for now

Mossroy (mossroy) wrote :

Hi Till,

Could you include the patch for Epson Stylus Color 670, like you did for Oki printers?
Or should I open a separate bug ? (as this one is already marked as fixed)

peterthevicar (peterbcs) wrote :

Same problem of second page printing garbage with Samsung CLP-620ND using Samsung driver. This printer also has the problem of not printing landscape properly in LibreOffice until the printer device language is set to PostScript instead of PDF (Printer / Properties / Device / Printer language type -> PostScript (Level from driver))

The fix in comment 57 sorts out the second page being garbage (once you've switched the printer off and on again)

lpadmin -p Samsung-Laser -R usb-unidir-default
lpadmin -p Samsung-Laser -o usb-no-reattach-default=true

This fix, as reported above, seems to last across reboots so no need to put it in a startup script.

Thank you so much for posting this fix, it was driving me crazy!

ATB, Peter

Don Cristóbal (doncristobal) wrote :

I can confirm both the bug and the 2nd fix from post #56 by Till on Xubuntu 12.04.

Details:

Kernel version
$ cat /proc/version
Linux version 3.2.0-37-generic-pae (buildd@roseapple) (gcc version 4.6.3 (Ubuntu/Linaro 4.6.3-1ubuntu5) ) #58-Ubuntu SMP Thu Jan 24 15:51:02 UTC 2013

The fix that worked:
$ lpadmin -p <printer> -o usb-no-reattach-default=true
then turn off and on the printer.

Printer:
OKI B410d

Printer driver:
Oki B410 Foomatic/hpijs-pcl5e
(bug occured also with pxlmono driver and OKI driver from http://my.okidata.com/pp-B410d.nsf/openingdrivermenu?OpenFrameSet

lsusb:
...
Bus 001 Device 005: ID 06bc:01c7 Oki Data Corp.

Device URI:
usb://OKI%20DATA%20CORP/B410?serial=AF97001420

Don Cristóbal (doncristobal) wrote :

Also, I'd be glad to do more tests if it's useful for getting the fix distributed to everyone.

Linux 3.5.0-25-generic #39-Ubuntu SMP Mon Feb 25 18:26:58 UTC 2013 x86_64 x86_64 x86_64 GNU/Linux
Lexmark e232

same problem, second job prints garbage

resolved too by
sudo lpadmin -p Lexmark-International-Lexmark-E232 -o usb-no-reattach-default=true

peterthevicar, can you run the command

lsusb

with your Samsung printer connected and turned on? Thanks.

Silviu C. (silviucc) wrote :

lpadmin -p Lexmark-E230 -o usb-no-reattach-default=true

fixes the same problem with my Lexmark E230 printer on Precise 64bit

This is the relevant info from lsusb:

Bus 002 Device 009: ID 043d:009a Lexmark International, Inc.

I tried with the instrucction in post #56 but doesn't work.

I have an Lexmark E460dn.

When using: lpadmin -p Lexmark-E230 -o usb-no-reattach-default=true, look like work, but only for 2 distinct jobs, third job and next doesn't work.

What can I do?

Tanks in advance.

I am experiencing this bug / issue with a lexmark-E260d. I will try the lpadmin command and report back whether it worked.
I am using Kubuntu 14.04 64 bit.

Yep; the command:

    lpadmin -p <printer> -o usb-no-reattach-default=true

fixed my issue!

John Anthony Brown, can you please run the

lsusb

command with your printer connected and turned on? Thanks.

Rolf Leggewie (r0lf) wrote :

oneiric has seen the end of its life and is no longer receiving any updates. Marking the oneiric task for this ticket as "Won't Fix".

Changed in cups (Ubuntu Oneiric):
status: Fix Committed → Won't Fix
jimav (james-avera) wrote :

Is there a mechanism in place which will cause this "fix" to be removed when the underlying kernel issue is repaired?

Resetting the usb port between jobs is an undesirable hack (e.g. slows down printing) so should go away as soon as possible.

AnrDaemon (anrdaemon) wrote :

@jimav, how much exactly does it slow down printing? In milliseconds?

I have a problem that seems similar.
After recent upgrade to CUPS 1.5.3, my HP LJ 4L connected via USB adapter printing what looks like command leftovers from previous job before printing the next job - judging from

# lpstat -p
printer HPLJ4L is idle. enabled since Tue 06 Oct 2015 09:17:09 PM MSK
        Sending data to printer.

(the job is just finished, all fine et al, but printer driver seems to be stuck in some "sending".)

All jobs correctly printed, but the paper waste is, of course, undesirable.

# lsusb
Bus 003 Device 004: ID 1a86:7584 QinHeng Electronics CH340S
...

# lpadmin -p HPLJ4L -o usb-unidir-default=true

did not helped.

# lpadmin -p HPLJ4L -o usb-no-reattach-default=true

seems to have done the trick.
lpstat still shows the printer stuck in "Sending data", but jobs now coming out correctly.

LukeKendall (luke-zeta) wrote :

I started having exactly this problem when I moved the connection to the printer to be direct through my computer (connected via USB), instead of via the network to another older computer (where it was connected via USB). Up until then it printed flawlessly, after connecting it directly I basically have to power cycle between each print. The newer computer is running Ubuntu 14.04.

I have noticed that when I print something and the print panel appears and offers me the choice of printers, next to the printer it says "Sending data to printer" when it's sending the data, and it stays like that even after the job is finished. If I then print anything, I get garbage.

I tried unplugging the USB and re-plugging: the "Sending data to printer" message vanished. I then printed a tiny email message: the printer showed it was receiving USB data for a minute or two (weird, for a 10 line text email message!), but did print it correctly. But afterwards, the print panel showed the "Sending data to printer" message, and again the next print appeared as garbage.

The old Ubuntu system had CUPS 1.3.7, the new has CUPS 1.7.2. On the old Ubuntu system, I installed the .PPD file from Lexmark; when I configured it on the new system, it auto-detected the model correctly as a Lexmark c543 (it's a c543dn).

I tried installing the same PPD file as I used on the old Ubuntu system (8.04.), and re-did the tests, but the situation was unchanged.

It seems a completely reliable indicator of whether the next job will fail or not is if the print pane says "Sending data to printer" even after the job is complete. At that point, unplugging/replugging or power cycling is needed.

I'm pretty sure I had no problems printing from the old Ubuntu even though on that system of course the printer was connected locally, not via the network.

I hope this information is useful in developing a good fix for it. It does sound to me like it's a problem with a later Linux USB system.

luke

Paul BROWN (frozenzia) wrote :

#56:

lpadmin -p <printer> -o usb-no-reattach-default=true

WORKED for me as well w/Dell 5330dn (My problem was that it printed one job, then next ones just sort of "disappeared".)

Thanks Till Kamppeter!!

Paul, thanks for the info. Please do the following:

Connect your printer and turn it on, then run the command

lsusb

and post the output here. Thanks.

James Currie (jameshcurrie) wrote :

Same thing just worked for me using a LexMark e232 laser jet. I was getting strings of gibberish characters -- what you used to see back in the day when the printer didn't have enough memory to process the postscript job. The lpadmin command fixed it. I'm running Ubuntu 15.10 so I'm wondering how something that was identified 4 years ago as an issue is still a problem -- and it's been literally months of off-and-on trying to debug this until I finally found this thread today. I'd resorted to just printing via Windows in Virtualbox since I didn't have time to keep screwing with it.

benohb (hamid) wrote :

Kyocera Ecosys M3020DN
ubuntu 15.04 64bit
 Gutenprint,Foomatic/pxlmono, Generic PCL-5e + original Kyocera driver (PPD )
-----
The printer works well .until printer go to mode sleep (~1mn without any job) . .You can not print after the re-activation
(Symbols or lines unknown)
-------
Thanks for Solutions above .

To post a comment you must log in.
This report contains Public information  Edit
Everyone can see this information.

Other bug subscribers