Ubuntu

Unable to upgrade libcups2

Reported by Fran Diéguez on 2011-09-22
8
This bug affects 1 person
Affects Status Importance Assigned to Milestone
cups (Ubuntu)
Undecided
Unassigned

Bug Description

I can't upgrade to the new libcups2 version due dependencies problems.
If I try apt-get purge libcups2 for reinstalling it all the ubuntu-desktop packages are proposed for deleting too.

LC_ALL=C apt-get -f install
Reading package lists... Done
Building dependency tree
Reading state information... Done
0 upgraded, 0 newly installed, 0 to remove and 1 not upgraded.
12 not fully installed or removed.
After this operation, 0 B of additional disk space will be used.
dpkg: error processing libcups2 (--configure):
 libcups2:amd64 1.5.0-6bzr1 cannot be configured because libcups2:i386 is in a different version (1.5.0-6)
dpkg: dependency problems prevent configuration of libcupscgi1:
 libcupscgi1 depends on libcups2 (>= 1.4.0); however:
  Package libcups2 is not configured yet.
No apport report written because the error message indicates its a followup error from a previous failure.
                                                                                                          dpkg: error processing libcupscgi1 (--configure):
 dependency problems - leaving unconfigured
dpkg: dependency problems prevent configuration of libcupsdriver1:
 libcupsdriver1 depends on libcups2 (>= 1.4.0); however:
  Package libcups2 is not configured yet.
dpkg: error processing libcupsdriver1 (--configure):
 dependency problems - leaving unconfigured
dpkg: dependency problems prevent configuration of libcupsimage2:
 libcupsimage2 depends on libcups2 (>= 1.4.0); however:
  Package libcups2 is not configured yet.
dpkg: error processing libcupsimage2 (--configure):
 dependency problems - leaving unconfigured
dpkg: dependency problems prevent configuration of libcupsmime1:
 libcupsmime1 depends on libcups2 (>= 1.5~); however:
  Package libcups2 is not configured yet.
dpkg: error processing libcupsmime1 (--configure):
 dependency problems - leaving unconfigured
dpkg: dependency problems prevent configuration of libcupsppdc1:
 libcupsppdc1 depends on libcups2 (>= 1.4.0); however:
  Package liNo apport report written because the error message indicates its a followup error from a previous failure.
                                                                                                                      No apport report written because MaxReports is reached already
                                                                                                                                                                                    No apport report written because MaxReports is reached already
                                      No apport report written because MaxReports is reached already
                                                                                                    No apport report written because MaxReports is reached already
                                                                                                                                                                  No apport report written because MaxReports is reached already
                    No apport report written because MaxReports is reached already
                                                                                  No apport report written because MaxReports is reached already
                                                                                                                                                No apport report written because MaxReports is reached already
  No apport report written because MaxReports is reached already
                                                                bcups2 is not configured yet.
dpkg: error processing libcupsppdc1 (--configure):
 dependency problems - leaving unconfigured
dpkg: error processing libnss3 (--configure):
 libnss3:amd64 3.12.9+ckbi-1.82-0ubuntu6 cannot be configured because libnss3:i386 is in a different version (3.12.9+ckbi-1.82-0ubuntu5)
dpkg: dependency problems prevent configuration of cups-client:
 cups-client depends on libcups2 (>= 1.5.0); however:
  Package libcups2 is not configured yet.
 cups-client depends on libcupsimage2 (>= 1.4.0); however:
  Package libcupsimage2 is not configured yet.
dpkg: error processing cups-client (--configure):
 dependency problems - leaving unconfigured
dpkg: dependency problems prevent configuration of cups-ppdc:
 cups-ppdc depends on libcups2 (>= 1.4.0); however:
  Package libcups2 is not configured yet.
 cups-ppdc depends on libcupsppdc1 (>= 1.4.0); however:
  Package libcupsppdc1 is not configured yet.
dpkg: error processing cups-ppdc (--configure):
 dependency problems - leaving unconfigured
dpkg: dependency problems prevent configuration of cups:
 cups depends on libcups2 (>= 1.5.0); however:
  Package libcups2 is not configured yet.
 cups depends on libcupscgi1 (>= 1.4.2); however:
  Package libcupscgi1 is not configured yet.
 cups depends on libcupsdriver1 (>= 1.4.0); however:
  Package libcupsdriver1 is not configured yet.
 cups depends on libcupsimage2 (>= 1.4.0); however:
  Package libcupsimage2 is not configured yet.
 cups depends on libcupsmime1 (>= 1.5.0-0ubuntu1); however:
  Package libcupsmime1 is not configured yet.
 cups depends on libcupsppdc1 (>= 1.4.0); however:
  Package libcupsppdc1 is not configured yet.
 cups depends on cups-client (>= 1.5.0-6bzr1); however:
  Package cups-client is not configured yet.
 cups depends on cups-ppdc; however:
  Package cups-ppdc is not configured yet.
dpkg: error processing cups (--configure):
 dependency problems - leaving unconfigured
dpkg: error processing libnss3-1d (--configure):
 libnss3-1d:amd64 3.12.9+ckbi-1.82-0ubuntu6 cannot be configured because libnss3-1d:i386 is in a different version (3.12.9+ckbi-1.82-0ubuntu5)
dpkg: dependency problems prevent configuration of cups-bsd:
 cups-bsd depends on libcups2 (>= 1.4.0); however:
  Package libcups2 is not configured yet.
 cups-bsd depends on cups-client (= 1.5.0-6bzr1); however:
  Package cups-client is not configured yet.
dpkg: error processing cups-bsd (--configure):
 dependency problems - leaving unconfigured
Errors were encountered while processing:
 libcups2
 libcupscgi1
 libcupsdriver1
 libcupsimage2
 libcupsmime1
 libcupsppdc1
 libnss3
 cups-client
 cups-ppdc
 cups
 libnss3-1d
 cups-bsd
E: Sub-process /usr/bin/dpkg returned an error code (1)

ProblemType: Bug
DistroRelease: Ubuntu 11.10
Package: cups 1.5.0-6bzr1
ProcVersionSignature: Ubuntu 3.0.0-11.18-generic 3.0.4
Uname: Linux 3.0.0-11-generic x86_64
ApportVersion: 1.23-0ubuntu1
Architecture: amd64
CupsErrorLog:

Date: Thu Sep 22 12:17:54 2011
EcryptfsInUse: Yes
InstallationMedia: Ubuntu 11.10 "Oneiric Ocelot" - Beta amd64 (20110901)
Lpstat: Error: command ['lpstat', '-v'] failed with exit code 1: lpstat: Connection refused
MachineType: Apple Inc. MacBookPro8,2
Papersize: a4
ProcKernelCmdLine: BOOT_IMAGE=/boot/vmlinuz-3.0.0-11-generic root=UUID=591efb90-948a-4b67-bca0-14f7f1dfcdbc ro quiet splash vt.handoff=7
SourcePackage: cups
UpgradeStatus: Upgraded to oneiric on 2011-09-16 (5 days ago)
dmi.bios.date: 09/09/11
dmi.bios.vendor: Apple Inc.
dmi.bios.version: MBP81.88Z.0047.B1E.1109091244
dmi.board.asset.tag: Base Board Asset Tag#
dmi.board.name: Mac-94245A3940C91C80
dmi.board.vendor: Apple Inc.
dmi.board.version: MacBookPro8,2
dmi.chassis.type: 10
dmi.chassis.vendor: Apple Inc.
dmi.chassis.version: Mac-94245A3940C91C80
dmi.modalias: dmi:bvnAppleInc.:bvrMBP81.88Z.0047.B1E.1109091244:bd09/09/11:svnAppleInc.:pnMacBookPro8,2:pvr1.0:rvnAppleInc.:rnMac-94245A3940C91C80:rvrMacBookPro8,2:cvnAppleInc.:ct10:cvrMac-94245A3940C91C80:
dmi.product.name: MacBookPro8,2
dmi.product.version: 1.0
dmi.sys.vendor: Apple Inc.

Fran Diéguez (frandieguez) wrote :
Martin Pitt (pitti) wrote :

1.5.0-6bzr1 is available for all architectures now:

  libcups2 | 1.5.0-6bzr1 | oneiric | amd64, armel, i386, powerpc

So this just seems to be mirror lag, that the i386 package is behind?

Changed in cups (Ubuntu):
status: New → Invalid
Fran Diéguez (frandieguez) wrote :

I'm using archive.ubuntu.com repository

Fran Diéguez (frandieguez) wrote :

Ok, I have solved it by activated again the Multiarch support for dpkg.
But I have one question. Why is libcups2:i386 installed if my system is amd64 based?

Fran Diéguez [2011-09-22 11:21 -0000]:
> Ok, I have solved it by activated again the Multiarch support for dpkg.

Oh, you disabled that? Yes, that'd explain it.

> But I have one question. Why is libcups2:i386 installed if my system is amd64 based?

Presumably you installed the flash plugin or something else?
flashplugin pulls in the i386 version of libcups2 through some other
libraries.

Martin
--
Martin Pitt | http://www.piware.de
Ubuntu Developer (www.ubuntu.com) | Debian Developer (www.debian.org)

Fran Diéguez (frandieguez) wrote :

Ok, I want to clean all the i386 dependencies. So, how I can get a list of packages that depends on libcups2:i386, for trying to install the amd64 version or try to uninstall those apps.

Martin Pitt (pitti) wrote :

Fran Diéguez [2011-09-22 11:49 -0000]:
> Ok, I want to clean all the i386 dependencies. So, how I can get a list
> of packages that depends on libcups2:i386, for trying to install the

This will do it

  sudo apt-get purge libcups2:i386

But please double-check the list of packages that it will remove.

To post a comment you must log in.
This report contains Public information  Edit
Everyone can see this information.

Other bug subscribers