Ubuntu

Cannot print with Samsung ML-1910

Reported by Bas Roset on 2011-05-04
6
This bug affects 1 person
Affects Status Importance Assigned to Milestone
cups (Ubuntu)
Undecided
Unassigned

Bug Description

Binary package hint: cups

For some reason i cannot print to my new Samsung ML-1910.

I have connected the printer via USB to my headless 10.04 server.
I added the printer via the webinterface of CUPS, and supplied the Samsung ppd file.
I'm printing to the printer through a Samba share with my Windows laptops.
This used to go fine with my old Samsung ML-2010 printer, but that one broke down the other day.

The printer accepts the print jobs, sound arises from the printer, job is completed according to CUPS, but no print out of the printer.

I then added the rastertosamsungspl to /usr/lib/cups/filter, like detailed here: http://forums.debian.net/viewtopic.php?f=16&t=57364
Restarted the smbd and cups services, but still only sound, no print.

I then tried the three Splix ppd's, of which one should support the ML-1910, https://launchpad.net/ubuntu/natty/+source/splix/2.0.0+20110219-0ubuntu1

Is it a problem that I use natty splix drivers? Because still no joy: only sound, but no print.

On another sad note, directly connecting it to a Windows XP/7 machine makes it not only make sound, but print as well. So the printer seems to be fine.

Details: Ubuntu 10.04.2 LTS

Bas Roset (broset) wrote :

Ok, I think something else in my setup seems to be borked:
After installing the Samsung Unified drivers from their website, using an install.sh script, the printer is now installed onto a different location: instead of usb: it's now located at mfp:/dev/mfp4 Not sure what that is.

I can however print a testfile from cups but not through SMB, with that only sound, no print.

Bas Roset (broset) wrote :

Ok, I think I've found the problem.

The problem is the new Universal Printer Driver from Samsung, which you can install for all Samsung printers nowadays.
When you install this driver on a Windows machine (tested with XP x86 and 7 x64), then printing will fail to the Samsung printer attached to a Linux server running CUPS and sharing the printer via the Samsba protocol. The job gets processed by CUPS, and CUPS shows it as completed. Apparently it has received the document to print as well, but the printer will only make noise but not print.

Now, to fix this you must be lucky if Samsung has provided older Windows drivers in the past, because with those older specific drivers installed the printing job will actually take place!! Samsung supplies all versions of their drivers on their website, so if it exists, you'll find a working driver on the website.

Unfortunately, no such drivers exist for the ML-1910, so I brought that one back to the shop and swapped it for an ancient model (ML-2510). With the Universal Printer Driver installed on the Windows machines, exactly the same problem occurred, but there are older drivers that I tested and they work flawlessly.

So Samsung has written their latest and greatest drivers not correctly. I'm not sure if any modification of CUPS would fix this, but I'm willing to test if someone wants anything tested.

papukaija (papukaija) on 2012-04-27
description: updated
tags: added: lucid
To post a comment you must log in.
This report contains Public information  Edit
Everyone can see this information.

Other bug subscribers