cupsd crashed with SIGSEGV in main()

Bug #711875 reported by Jean-Baptiste Lallement on 2011-02-02
72
This bug affects 15 people
Affects Status Importance Assigned to Milestone
cups (Ubuntu)
High
Canonical Desktop Team
Natty
High
Canonical Desktop Team

Bug Description

Binary package hint: cups

ISOTesting Ubuntu Desktop i386 Upgrade 20110202

I've got this report on login after the upgrade.
I upgraded from a fresh installation of Maverick.

ProblemType: Crash
DistroRelease: Ubuntu 11.04
Package: cups 1.4.5-1ubuntu6
ProcVersionSignature: Ubuntu 2.6.38-1.28-generic 2.6.38-rc2
Uname: Linux 2.6.38-1-generic i686
Architecture: i386
CupsErrorLog:
 E [02/Feb/2011:13:04:16 +0100] [cups-driverd] Bad driver information file "/usr/share/cups/drv/sample.drv"!
 E [02/Feb/2011:13:04:19 +0100] [cups-driverd] Bad driver information file "/usr/share/cups/drv/sample.drv"!
 E [02/Feb/2011:13:04:22 +0100] [cups-driverd] Bad driver information file "/usr/share/cups/drv/sample.drv"!
CurrentDmesg:
 [ 23.835981] EXT4-fs (sda1): re-mounted. Opts: errors=remount-ro,commit=0
 [ 27.056026] eth0: no IPv6 routers present
 [ 29.899975] EXT4-fs (sda1): re-mounted. Opts: errors=remount-ro,commit=0
Date: Wed Feb 2 14:56:29 2011
ExecutablePath: /usr/sbin/cupsd
InstallationMedia: Ubuntu 10.10 "Maverick Meerkat" - Release i386 (20101007)
Lpstat: Error: command ['lpstat', '-v'] failed with exit code 1: lpstat: No destinations added.
Lsusb:
 Bus 001 Device 002: ID 80ee:0021
 Bus 001 Device 001: ID 1d6b:0001 Linux Foundation 1.1 root hub
MachineType: innotek GmbH VirtualBox
Papersize: letter
ProcAttrCurrent: /usr/sbin/cupsd (enforce)
ProcCmdline: /usr/sbin/cupsd -F
ProcEnviron: PATH=(custom, no user)
ProcKernelCmdLine: BOOT_IMAGE=/boot/vmlinuz-2.6.38-1-generic root=UUID=21770122-8e8c-4e3c-9726-19e1ee08564a ro quiet splash vt.handoff=7
SegvAnalysis:
 Segfault happened at: 0x1aac25: call *%edx
 PC (0x001aac25) ok
 source "*%edx" (0x74616369) not located in a known VMA region (needed readable region)!
 destination "(%esp)" (0xbfee36b0) ok
SegvReason: reading unknown VMA
Signal: 11
SourcePackage: cups
Stacktrace:
 #0 0x001aac25 in ?? ()
 No symbol table info available.
 #1 0x001787c8 in main ()
 No symbol table info available.
StacktraceTop:
 ?? ()
 main ()
Title: cupsd crashed with SIGSEGV in main()
UserGroups:

dmi.bios.date: 12/01/2006
dmi.bios.vendor: innotek GmbH
dmi.bios.version: VirtualBox
dmi.modalias: dmi:bvninnotekGmbH:bvrVirtualBox:bd12/01/2006:svninnotekGmbH:pnVirtualBox:pvr1.2:
dmi.product.name: VirtualBox
dmi.product.version: 1.2
dmi.sys.vendor: innotek GmbH

Jean-Baptiste Lallement (jibel) wrote :

Stacktrace:
 #0 0x001aac25 in ?? () from /usr/sbin/cupsd
 No symbol table info available.
 #1 0x001787c8 in main () from /usr/sbin/cupsd
 No symbol table info available.
StacktraceTop:
 ?? () from /usr/sbin/cupsd
 main () from /usr/sbin/cupsd

tags: added: apport-failed-retrace
tags: removed: need-i386-retrace
tags: added: iso-testing
visibility: private → public
Kate Stewart (kate.stewart) wrote :

Given the bug has been seen by 8 other people, marking it confirmed, and setting the importance, etc.

Changed in cups (Ubuntu Natty):
status: New → Confirmed
importance: Undecided → High
assignee: nobody → Canonical Desktop Team (canonical-desktop-team)
Jean-Baptiste Lallement (jibel) wrote :

I'm closing this report. I can't reproduce it with the latest updates.

Changed in cups (Ubuntu Natty):
status: Confirmed → Fix Released

It just happened to me with latest upgrades on Ubuntu 11.10 beta1 64bit.
https://bugs.launchpad.net/ubuntu/+source/cups/+bug/845052

To post a comment you must log in.
This report contains Public information  Edit
Everyone can see this information.

Other bug subscribers