[maverick] cups does not start at boot time

Bug #650893 reported by Thierry Carrez on 2010-09-29
8
This bug affects 1 person
Affects Status Importance Assigned to Milestone
cups (Ubuntu)
High
Martin Pitt
Maverick
High
Martin Pitt

Bug Description

Binary package hint: cups

Testing Maverick RC, Server ISO / amd64, Print server task

cups does not start at boot-time. You can start it afterwards by running sudo start cups.

Thierry Carrez (ttx) on 2010-09-29
Changed in cups (Ubuntu Maverick):
importance: Undecided → Medium
tags: added: server-mrs
tags: added: iso-testing
Till Kamppeter (till-kamppeter) wrote :

This is probably caused by the upstartification of CUPS. Pitti, can you have a look into this?

Changed in cups (Ubuntu Maverick):
assignee: nobody → Martin Pitt (pitti)
importance: Medium → High
milestone: none → ubuntu-10.10
Martin Pitt (pitti) wrote :

What does this show?

  initctl list |egrep 'dbus|cups'

My hunch is that it waits on dbus to start, which might not be present in a server installation.

Martin Pitt (pitti) wrote :

Thierry,

can you please try to replace /etc/init/cups.conf with this one and verify that it works now?

Merci!

Thierry Carrez (ttx) wrote :

$ sudo initctl list |egrep 'dbus|cups'
cups stop/waiting

Thierry Carrez (ttx) wrote :

With proposed init script, it starts at boot-time.

Martin Pitt (pitti) wrote :

Thanks Thierry. It also works fine on a desktop environment.

Fix committed to packaging trunk.

Changed in cups (Ubuntu Maverick):
status: New → In Progress
Martin Pitt (pitti) wrote :

Merged into maverick branch and uploaded. Will be accepted right after RC.

Changed in cups (Ubuntu Maverick):
status: In Progress → Fix Committed
tags: added: regression-potential
Launchpad Janitor (janitor) wrote :

This bug was fixed in the package cups - 1.4.4-6ubuntu2

---------------
cups (1.4.4-6ubuntu2) maverick; urgency=low

  * ubuntu-upstart.dpatch: If D-BUS is not available, start on runlevels 2 to
    5, so that this also works in server environments. Patch cherrypicked from
    packaging trunk. (LP: #650893)
 -- Martin Pitt <email address hidden> Wed, 29 Sep 2010 11:01:42 +0200

Changed in cups (Ubuntu Maverick):
status: Fix Committed → Fix Released
To post a comment you must log in.
This report contains Public information  Edit
Everyone can see this information.

Other bug subscribers