printing from openoffice prints a blank page and the job shows as "stopped" in the printer applet

Bug #603236 reported by Aaron Welch on 2010-07-08
12
This bug affects 2 people
Affects Status Importance Assigned to Milestone
cups (Ubuntu)
Undecided
Unassigned

Bug Description

Binary package hint: cups

See title, relevant error seems to be "Job stopped due to filter errors; please consult the error_log file for details". I used "ubuntu-bug cups" to report this, so I assume the additional troubleshooting information has been submitted, if not, I can add additional log output or whatever else is helpful.

ProblemType: Bug
DistroRelease: Ubuntu 10.04
Package: cups 1.4.3-1ubuntu1.2
ProcVersionSignature: Ubuntu 2.6.32-23.37-generic 2.6.32.15+drm33.5
Uname: Linux 2.6.32-23-generic i686
Architecture: i386
Date: Thu Jul 8 12:22:43 2010
Lpstat: device for Xerox6280: socket://192.168.75.105
MachineType: Apple Computer, Inc. MacBook1,1
Papersize: letter
PpdFiles: Xerox6280: Xerox Phaser 6280N
ProcCmdLine: root=UUID=50e13f1b-76b4-4b94-a501-d9afdffb2939 ro quiet splash
ProcEnviron:
 LANGUAGE=
 PATH=(custom, user)
 LANG=en_US.UTF-8
 SHELL=/bin/bash
SourcePackage: cups
dmi.bios.date: 10/12/06
dmi.bios.vendor: Apple Computer, Inc.
dmi.bios.version: MB11.88Z.0061.B03.0610121324
dmi.board.asset.tag: Base Board Asset Tag
dmi.board.name: Mac-F4208CC8
dmi.board.vendor: Apple Computer, Inc.
dmi.board.version: PVT
dmi.chassis.asset.tag: Asset Tag
dmi.chassis.type: 10
dmi.chassis.vendor: Apple Computer, Inc.
dmi.chassis.version: Mac-F4208CC8
dmi.modalias: dmi:bvnAppleComputer,Inc.:bvrMB11.88Z.0061.B03.0610121324:bd10/12/06:svnAppleComputer,Inc.:pnMacBook1,1:pvr1.0:rvnAppleComputer,Inc.:rnMac-F4208CC8:rvrPVT:cvnAppleComputer,Inc.:ct10:cvrMac-F4208CC8:
dmi.product.name: MacBook1,1
dmi.product.version: 1.0
dmi.sys.vendor: Apple Computer, Inc.

Aaron Welch (welch-advomatic) wrote :
Till Kamppeter (till-kamppeter) wrote :

Problem is that Ghostscript errors out on the PostScript input file. Can you please attach the OpenOffice file which you tried to print and also print your OpenOffice file with the "Print to file" option in the print dialog set. Attach the resulting PostScript file.

Changed in cups (Ubuntu):
status: New → Incomplete
Aaron Welch (welch-advomatic) wrote :

Sure thing, here is the original .odt, 'test.odt' and the ps file 'test.ps'

Thanks!

-A

Aaron Welch (welch-advomatic) wrote :

Can't attach two files, here is the .ps

i seem to have the same problem, the issue has only appeared after upgrading from Ubuntu 8.04.

Ubuntu 10.04 LTS
Xerox Phaser 6280DN

i can print from all programs OK except for OpenOffice. if i try to print any document via the OO word processor, the print status applet generates a "Print error" message box, and the print job shows in the status queue as "Stopped".

meanwhile, the printer prints a blank page.

if i export the document as PDF and print that with "lp", it works fine.

the following message appears in /var/log/cups

E [04/Sep/2010:15:27:58 +0100] [Job 37] Job stopped due to filter errors; please consult the error_log file for details.

Till Kamppeter (till-kamppeter) wrote :

The PostScript file is actually broken PostScript. I cannot display it by

gs -sDEVICE=x11 test.ps

nor print it directly (unfiltered) on a PostScript printer via

nc -w1 <IP of the printer> 9100 < test.ps

If I open the attached .odt file it prints always for me, with both Lucid's and Maverick's OpenOffice.org and print queues set up on both Lucid or Maverick.

Perhaps you have some broken font file installed on your machine which makes OpenOffice.org producing broken PostScript.

in response to the above post, i have just tried printing from OpenOffice to a .ps file, and then tried "gs -sDEVICE=x11 test.ps"

it always fails. i have tried changing the font in the simple test document to a range of different fonts, but always the same problem. should this affect the issue if the issue is as you suggest? (e.g. a broken font)

this is odd because as far as i'm aware, this is a standard install of Ubuntu 10.04 LTS

the "extra" ms core fonts are on it, but i have not installed anything else.

ok more to report on this. i deleted the xerox 6280 driver from my system, and then just used the (built in ubuntu) drivers for xerox phaser 6250N.

that works! e.g. it looks like (for me) the problem is in the Xerox driver.

this driver did however work fine on Ubuntu 8.04, so i'm guessing there is some incompatibility there with the xerox driver and 10.04 LTS.

phil

Launchpad Janitor (janitor) wrote :

[Expired for cups (Ubuntu) because there has been no activity for 60 days.]

Changed in cups (Ubuntu):
status: Incomplete → Expired
To post a comment you must log in.
This report contains Public information  Edit
Everyone can see this information.

Other bug subscribers