CUPS service stopped

Bug #524186 reported by YannUbuntu on 2010-02-19
32
This bug affects 8 people
Affects Status Importance Assigned to Milestone
cups (Ubuntu)
Undecided
Unassigned

Bug Description

Binary package hint: cups

Since 2 or 3 weeks, my Ubuntu 9.10 can not automatically find the connected printers.
See attached screenshot:
- I click on System->Administration->Printing : no printer detected
- I go on the Troobleshoot (F1) menu, Next, I get the following message: "CUPS service stopped. The CUPS printer spooler does not appear to be running. To correct this, choose System ->Administration->Services from the main menu and look for the 'cups' service.
- so I follow the advice: I go into System ->Administration, but there is no System ->Administration->Services menu !!! (see screenshot)

FYI, I found a workaround: I enter "sudo service cups start" in the terminal to start the service, but that's boring as I have to do it each time I boot my computer...

YannUbuntu (yannubuntu) wrote :
YannUbuntu (yannubuntu) wrote :

Minimum 2 other users have the same bug : http://forum.ubuntu-fr.org/viewtopic.php?pid=3329206#p3329206

Here is a workaround proposed by an ubuntu-fr member:
* Create /etc/init/cups.conf file and fill it with :
        #cups
        start on runlevel [2345]
        stop on runlevel [!2345]
        respawn
        exec /usr/sbin/cupsd -C /etc/cups/cupsd.conf
* Then launch the service with : sudo initctl start cups

It worked for 1 user (the service automatically starts from now), but not for 2 other users (including me). For us 2, we have to type either "sudo initctl start cups" or "sudo /etc/init.d/cups start" to launch the service at the beginning of each session.

Also, we both observed that the command "runlevel" returns "unknown". Maybe the source of the problem is here ?

Hope this helps to solve this bug.

uboops (oops66) wrote :

+1 I have the same bug, so I have tried exactly the same way to try to solve this cups issue but without success.
FI: I also have this runlevel problem (returns "unknown") maybe due to this other bug " the boot stop at: starting early crypto disks OK" - see bellow ???
https://bugs.launchpad.net/ubuntu/+source/cryptsetup/+bug/450620

sebastien teyssier (steyssier) wrote :

I can confirm this bug affects me only since a few days.

ls /etc/rc2.d/
README S20kerneloops S50rsync S99ondemand
S20boinc-client S20speech-dispatcher S50saned S99rc.local
S20dkms_autoinstaller S31atieventsd S90binfmt-support
S20fancontrol S50cups S99acpi-support
S20hddtemp S50pulseaudio S99grub-common

but boinc-client and cups aren't running

I've followed the workaround (ie, creating /etc/init/cups.conf)
I'm seeking for the correct syntax for boinc

Ndawa (david-waiengnier) wrote :

Hi. This bug affect me since 11 march 2010.

I must restart cups et reinstall my printer on each reboot !

- Kubuntu 9.10

Neetesh Biswas (leonardo-neo) wrote :

Hello,

This is to confirm this bug affects my system too. I am not frequent with printing so not sure since when it is there, but it is exactly the same problem as described above. Hope a fix should come soon.

Neetesh Biswas (leonardo-neo) wrote :

Hello,

Didn't how to edit my previous post, so posting another one.

The fix mentioned by YannUbuntu seems to fix my problem. I can see the connected printers now.

description: updated
YannUbuntu (yannubuntu) wrote :

Tried several other things (cf http://forum.ubuntu-fr.org/viewtopic.php?pid=3360111#p3360111)

1) Create the file /etc/inittab with the following content:
id:2:initdefault:
-> Doesn' work, even after a reboot

2) $sudo telinit 2
-> Changes my "runlevel" from "unknown" to "N2" (and launches CUPS for the current session, but after a reboot it does not work any more (my runlevel returns to "unknown")

Hope this helps...

YannUbuntu (yannubuntu) wrote :

For information, I don't have this bug on Ubuntu 10.04 beta (installed on HD).

hveeramani (pseudomonas) wrote :

I can confirm this bug on my Ubuntu 10.04 installation.

To post a comment you must log in.
This report contains Public information  Edit
Everyone can see this information.

Other bug subscribers

Bug attachments