cups produces error on attempt to print test page

Bug #510781 reported by Bruce Miller on 2010-01-21
22
This bug affects 4 people
Affects Status Importance Assigned to Milestone
cups (Ubuntu)
Low
Unassigned

Bug Description

Binary package hint: cups

Actions taken:
1. point browser to localhost:631
2. select Printers | Manage Printers
3. select the physical printer (as opposed to the Virtual PDF Printer)
4. select Maintenance | Print Self Test Page

Expected: printer issues the well-known CUPS test page
Observed: error message: Unsupported format 'application/vnd.cups-command'!

Background:
I have been upgrading to new Kubuntu versions on this four or five-year old machine ever since I bought it. I have space for three releases at any one time. The home directory is in its own partition and I have always left it intact. I was suffering several small but infuriating functionality problems that drew zero response from several increasingly plaintive postings. I suspected cruft in my "dot files" (configuration files). I did a "bare metal" reinstall of both the OS and my own user partition, copying back only config directories that contained useful data, as opposed to config settings, e.g. ~/.cddb and ~/.thumbnails.

I provide this detail because the previous Lucid Lynx instance on this machine --- as well as the karmic and jaunty releases --- have always printed the CUPS test page uneventfully. It is therefore puzzling to receive this error on the "cleanest" reinstall that I have done in years.

OT: the cruft removal exercise does, however, seem to have resolved the other functionality problems.

ProblemType: Bug
Architecture: i386
Date: Thu Jan 21 03:42:29 2010
DistroRelease: Ubuntu 10.04
InstallationMedia: Error: [Errno 13] Permission denied: '/var/log/installer/media-info'
Lpstat:
 device for HPLaserJet4L: dnssd://P1._printer._tcp.local/
 device for VirtualPDFPrinter: cups-pdf:/
MachineType: MICRO-STAR INC. MS-6580
NonfreeKernelModules: nvidia
Package: cups 1.4.2-6
Papersize: letter
PpdFiles:
 HPLaserJet4L: HP LaserJet 4L Foomatic/ljet4 (recommended)
 VirtualPDFPrinter: Generic PostScript Printer Foomatic/Postscript (recommended)
ProcCmdLine: BOOT_IMAGE=//vmlinuz-2.6.32-11-generic root=UUID=d85b8ba0-25f1-4c76-b27f-30e24d3743ec ro quiet splash
ProcEnviron:
 LANGUAGE=
 PATH=(custom, user)
 LANG=en_CA.UTF-8
 SHELL=/bin/bash
ProcVersionSignature: Ubuntu 2.6.32-11.15-generic
SourcePackage: cups
Uname: Linux 2.6.32-11-generic i686
dmi.bios.date: 05/19/2003
dmi.bios.vendor: American Megatrends Inc.
dmi.bios.version: V3.7 0
dmi.board.name: MS-6580
dmi.board.vendor: MICRO-STAR INC.
dmi.board.version: 20A
dmi.chassis.asset.tag: 0123ABC
dmi.chassis.type: 3
dmi.chassis.vendor: Uknown Chassis Manufacture
dmi.chassis.version: Version 1.00
dmi.modalias: dmi:bvnAmericanMegatrendsInc.:bvrV3.70:bd05/19/2003:svnMICRO-STARINC.:pnMS-6580:pvr20A:rvnMICRO-STARINC.:rnMS-6580:rvr20A:cvnUknownChassisManufacture:ct3:cvrVersion1.00:
dmi.product.name: MS-6580
dmi.product.version: 20A
dmi.sys.vendor: MICRO-STAR INC.

Bruce Miller (brm0423) wrote :
Bruce Miller (brm0423) wrote :

This bug appears to be related to --- although, in my view, not a duplicate of --- Bug #428065

Rolf Leggewie (r0lf) wrote :

just ran into this myself. Confirming.

Bruce, there are two entries to print a test page. One works and the other one does not. I assume they will print different test pages and thus it makes sense to have two entries.

"print self test page" -> does not work, gives the error as described by Bruce
"print test page" -> works (for me, at least)

Changed in cups (Ubuntu):
importance: Undecided → Low
status: New → Confirmed
Rolf Leggewie (r0lf) wrote :

FWIW, I get the same error for "clean print heads" and honestly, I don't even know why that menu entry is there. I'm printing to a laser printer and would expect that kind of entry for inkjets only. May be another bug entirely.

David Rahrer (david-rahrer) wrote :

Ditto of Rolf's last remarks except I have a Brother QL-570 label printer. I also get the same error as the OP, on self-test only, test page works fine. Does "self-test" page trigger something in the printing device itself like a stored test vs. a test page coming from the system? I seem to remember long ago that this was to distinguish between a device problem and a connection/system error, but I'm really not sure.

Till Kamppeter (till-kamppeter) wrote :

"Print self-test page" is in fact to trigger the printing of a test page which is built into the printer, usually to check for clogged nozzles or used up print heads in inkjet printers. For laser printers or thermal transfer printers it does not make sense, The bug is in system-config-printer upstream, not graying out the buttons when the driver does not make available these functions. Tim, can you look into this?

affects: cups (Ubuntu) → system-config-printer (Ubuntu)
Tim Waugh (twaugh) wrote :

Well, can you? I've already explained this problem to you before by email... It some sort of CUPS bug IMHO.

Bruce Miller (brm0423) wrote :

Thanks for following up on this bug.

I am the original submitter.

It has been fixed upstream.

I have had to reinstall a 64-bit system since Lucid was released and explicitly tested the Print test page function in KDE System Settings.

Changed in system-config-printer (Ubuntu):
status: Confirmed → Fix Released
Cesare Mastroianni (cece) wrote :

Sorry to bother You but the problem is still here around, it has not been fixed.
I'm using Lucid, and the "Print self-test page" is not gray-disabled (using HP 1320n printer).

Many thanks in advance.

Ciao
CM

This needs the following CUPS upstream bug to be fixed:

http://www.cups.org/str.php?L3273

Moving to CUPS ...

Changed in system-config-printer (Ubuntu):
status: Fix Released → Confirmed
affects: system-config-printer (Ubuntu) → cups (Ubuntu)
dino99 (9d9) wrote :

Closing that outdated report as EOL has been reached long time ago

Changed in cups (Ubuntu):
status: Confirmed → Invalid
To post a comment you must log in.
This report contains Public information  Edit
Everyone can see this information.

Other bug subscribers