/etc/cups/interfaces doesn't exist; lpadmin fails to add interface scripts

Bug #499585 reported by Jonathan Reed
32
This bug affects 7 people
Affects Status Importance Assigned to Milestone
cups (Ubuntu)
Fix Released
Critical
Unassigned

Bug Description

Binary package hint: cups

/etc/cups/interfaces does not exist by default in Ubuntu (at least not in Karmic or Jaunty). Normally, one should be able to add interface scripts for SysV queues with something like:

lpadmin -p myprinter -E -i /path/to/my/interface/script -v parallel:/dev/lp

However, this fails with "lpadmin: Unable to copy interface script - No such file or directory!". An strace on the process reveals that "No such file or directory" in fact refers to the attempt to copy the interface script into /etc/cups/interfaces.

If I create /etc/cups/interfaces (which exists on every other platform using CUPS), then the lpadmin command succeeds.

/etc/cups/interfaces should be created by default when cups is installed.

Revision history for this message
Launchpad Janitor (janitor) wrote :

Status changed to 'Confirmed' because the bug affects multiple users.

Changed in cups (Ubuntu):
status: New → Confirmed
Revision history for this message
Tom Ellis (tellis) wrote :

Still seeing this on 10.04 LTS

Revision history for this message
Tom Ellis (tellis) wrote :

oh and 11.10 :)

Revision history for this message
Tim Bishop (tdb) wrote :

And 12.04...

Revision history for this message
Till Kamppeter (till-kamppeter) wrote :

This will be fixed at least in Saucy as we will make use of the interface script concept for PPD/driver-less printing.

Changed in cups (Ubuntu):
status: Confirmed → Triaged
importance: Undecided → Critical
milestone: none → ubuntu-13.10
Gowdham (gowdhampillai)
Changed in cups (Ubuntu):
assignee: nobody → Gowdham (gowdhampillai)
assignee: Gowdham (gowdhampillai) → nobody
Revision history for this message
Launchpad Janitor (janitor) wrote :

This bug was fixed in the package cups - 1.7.0~rc1-0ubuntu3

---------------
cups (1.7.0~rc1-0ubuntu3) saucy; urgency=low

  * debian/local/cups-daemon.cups.upstart: Increased timeout for waiting for
    the CUPS daemon to get ready before automatically configuring printers
    from 3 sec to 30 sec, on slower systems CUPS often needs more than 3
    seconds and so the automatic printer configuration does not get done
    (LP: #933308).
  * debian/cups.dirs: Create empty /etc/cups/interfaces directory
    (LP: #499585).
 -- Till Kamppeter <email address hidden> Wed, 18 Sep 2013 18:51:01 +0200

Changed in cups (Ubuntu):
status: Triaged → Fix Released
To post a comment you must log in.
This report contains Public information  
Everyone can see this information.

Other bug subscribers