cups testsuite failures don't trigger a build failure

Bug #447919 reported by Matthias Klose on 2009-10-10
14
This bug affects 1 person
Affects Status Importance Assigned to Milestone
launchpad-buildd
Undecided
LaMont Jones
cups (Ubuntu)
High
Martin Pitt
Karmic
High
Unassigned

Bug Description

Binary package hint: cups

echo Running HTTP API tests...
Running HTTP API tests...
./testhttp
httpGetDateString()/httpGetDateTime(): PASS
httpDecode64_2()/httpEncode64_2(): PASS
httpGetHostname(): PASS (imbe)
httpAddrGetList(imbe): FAIL
httpSeparateURI(): PASS (34 URIs tested)
httpAssembleURI(): PASS (13 URIs tested)

1 TESTS FAILED!
make[2]: *** [testhttp] Error 1
make[2]: Leaving directory `/build/buildd/cups-1.4.1/cups'

Related branches

Matthias Klose (doko) on 2009-10-10
Changed in cups (Ubuntu):
milestone: none → ubuntu-9.10
status: New → Confirmed
importance: Undecided → High

It fails on all architectures due to that. This seems to be a regression from Till's recent hostname change.

summary: - cups-1.4.1-4 ftbfs on armel (and sparc)
+ cups-1.4.1-4 FTBFS
Martin Pitt (pitti) on 2009-10-14
Changed in cups (Ubuntu Karmic):
assignee: nobody → Till Kamppeter (till-kamppeter)
Till Kamppeter (till-kamppeter) wrote :

I have checked this test (cups/testhttp.c) and my host name patch and the failure cannot be caused by my patch, as my patch only changes source files of the CUPS daemon (scheduler/*.c) and this test uses only code of the CUPS library (cups/*.c). It even runs when the CUPS daemon is stopped.

Steve Langasek (vorlon) wrote :

I think this is clearly a result of the recent buildd chroot updates - it looks like the buildd chroots no longer know how to map their own names to an IP.

I think that should be fixed on the buildds.

Martin Pitt (pitti) wrote :

Lamont updated the buildd chroots, so this should be fixed now. I'm about to do a new cups upload.

Changed in cups (Ubuntu Karmic):
assignee: Till Kamppeter (till-kamppeter) → nobody
status: Confirmed → Fix Committed
Martin Pitt (pitti) wrote :

I did a new upload, but it still fails. Lamont, do the chroots just need more time to update, or do they still not have a resolvable hostname? Thanks!

Martin Pitt (pitti) wrote :

As a workaround, to get cups built finally and the bug fixes effective, I uploaded a cups which doesn't fail to build when the test suilte fails.

Steve Langasek (vorlon) wrote :

Inverting the bug description now, since the bug here is that cups's testsuite needs to be re-enabled once the chroots are fixe

Changed in cups (Ubuntu Karmic):
milestone: ubuntu-9.10 → none
status: Fix Committed → Won't Fix
summary: - cups-1.4.1-4 FTBFS
+ cups testsuite failures don't trigger a build failure
Changed in cups (Ubuntu):
status: Fix Committed → Triaged
Martin Pitt (pitti) wrote :

Since this is blocking on the buildd chroots, I add another task for soyuz.

Changed in cups (Ubuntu):
assignee: nobody → Martin Pitt (pitti)
Changed in soyuz:
assignee: nobody → LaMont Jones (lamont)
status: New → Confirmed
affects: soyuz → launchpad-buildd
Martin Pitt (pitti) wrote :

I uploaded a new cups today (synced from Debian), and it still FTBFSes because the buildds can't resolve their own name. I'll upload the "disable test suite" workaround again.

Setting to incomplete until the buildds are fixed, to get it off my +assignedbugs list. (I'm still subscribed, so will promptly react to buildd fixes).

Changed in cups (Ubuntu):
assignee: Martin Pitt (pitti) → nobody
status: Triaged → Incomplete
Martin Pitt (pitti) wrote :

Lamont fixed the buildds (thanks!), uploading cups again.

Changed in cups (Ubuntu):
assignee: nobody → Martin Pitt (pitti)
status: Incomplete → In Progress
Launchpad Janitor (janitor) wrote :

This bug was fixed in the package cups - 1.4.2-1git2

---------------
cups (1.4.2-1git2) lucid; urgency=low

  * debian/rules: Have test suite failures fail the build again, chroots have
    been fixed (thanks Lamont!). (LP: #447919)
 -- Martin Pitt <email address hidden> Fri, 13 Nov 2009 14:42:00 +0100

Changed in cups (Ubuntu):
status: In Progress → Fix Released
Martin Pitt (pitti) wrote :

Failed again, sorry. Next upload will ignore test suite again.

Changed in cups (Ubuntu):
status: Fix Released → Confirmed
LaMont Jones (lamont) wrote :

There are a number of files that launchpad-buildd needs to be updating in the chroot before it starts the build:

/etc/hostname (says invalid, could stay that way, i expect)
/etc/hosts (needs an entry for the hostname (hostname --short and --fqdn) pointing to 127.0.1.1)
/etc/resolv.conf (should match the hosts /etc/resolv.conf)

possibly others.

Paul Larson (pwlars) wrote :

removed armel tag since it was determined to be arch unspecific

tags: removed: armel
LaMont Jones (lamont) on 2009-12-14
Changed in launchpad-buildd:
status: Confirmed → In Progress
LaMont Jones (lamont) wrote :

fixed in version 54

Changed in launchpad-buildd:
status: In Progress → Fix Released
Launchpad Janitor (janitor) wrote :

This bug was fixed in the package cups - 1.4.2-6

---------------
cups (1.4.2-6) unstable; urgency=medium

  [ Till Kamppeter ]
  * Urgency medium, this only fixes a highly visible crash.
  * debian/local/filters/pdf-filters/pdftopdf/P2PGfx.cxx: Fixed segfault of
    the pdftopdf filter when the input PDF file has ICC-profile-based color
    space inline images. Thanks to Koji Otani for the fix. Fixes:
    LP: #407344, LP: #466119, LP: #467919, LP: #475330, LP: #488752.

  [ Martin Pitt ]
  * debian/rules: Have a failed test suite fail the build on Ubuntu again,
    buildds were fixed. (LP: #447919)
 -- Martin Pitt <email address hidden> Mon, 21 Dec 2009 10:19:44 +0100

Changed in cups (Ubuntu):
status: Confirmed → Fix Released
To post a comment you must log in.
This report contains Public information  Edit
Everyone can see this information.

Other bug subscribers