Printing fails with 'cups-insecure-filter'

Bug #436544 reported by Matej Kenda on 2009-09-25
16
This bug affects 3 people
Affects Status Importance Assigned to Milestone
cups (Ubuntu)
Undecided
Unassigned

Bug Description

Binary package hint: cups

Ubuntu Karmic (9.10).

I added new printer (Samsung CLX-2160N) and wanted to print a test page. Printing failed with error 'cups-insecure-filter'.

Matej Kenda (matejken) wrote :

After running troubleshooting tool I have some more details abou the issue:

"Filter directory /usr/lib/cups/filter for printer Samsung CLX-2160 Series" is not owned by root.

Matej Kenda (matejken) wrote :

Changing ownership solved the problem, however the directory should be created with proper ownership from the beginning.

Till Kamppeter (till-kamppeter) wrote :

The CUPS package of Ubuntu installs the /usr/lib/cups/filter directory correctly with root as owner. Perhaps the installer of the propriatary Samsung driver changed the ownership. Please contact Samsung in this case.

Changed in cups (Ubuntu):
status: New → Invalid
Matej Kenda (matejken) wrote :

I use the driver in the Ubuntu supplied package splix. I don't think that that one is proprietary.

Matej Kenda,
The troubleshoot.txt clearly shows that your are using the proprietary Samsung driver and not the splix driver.

Matej Kenda (matejken) wrote :

I was adding new printer and I was sure that splix driver was used. Samsung driver was installed before I upgraded to Karmic so I wrongly assumed that the upgrade caused the problem.

The driver will "get fired" immediately. I apologize for causing confusion.

Stepan Martiyanov (symsym) wrote :

I had the same problem with cannon ip1000 in Karmic.

This problem occurs due to wrong rights on /usr/lib/cups/filter/pstocanonbj.

-rwxrwxr-x 1 1000 1000 14084 2005-05-31 13:43 pstocanonbj

Next line solve my problem.

$ sudo chown root:root /usr/lib/cups/filter/pstocanonbj.

You should run this line for your printer.

beesblaas (bromhoek) wrote :

I have an Epson printer.
This problem occurred after upgrading from 9.04 to 9.10, the printer worked fine before the upgrade.
I first tried the commands as described below, seen on another forum:

sudo chown -hR root /usr/lib/cups/filter
sudo chown -hR root /usr/lib/cups/backend
sudo chgrp -hR root /usr/lib/cups/filter
sudo chgrp -hR root /usr/lib/cups/backend

It did not work, the printer had the same error message.
I then deleted and re-installed the printer, which fixed the problem.

Malcolm (marza-mora) wrote :

Am about to throw in the towel with Linux after days trying to get iP1000 to print!!!. Stefans #7 is giving results; at first a "chown root : root /........ " gave a "cannot access ':' nor 'root' " but a "chown root /........ /pstocanonbj " printed a test page . File pstocanonbj has now "-rwxrwx-x 1 root username " whilst the other files in the folder are "-rwxr-xr-x 1 root root" . I now have to test printing, after taking a breather of relief, but I wonder if all printing problems are solved ?????. This sort of thing put me off Linux years ago, at the ubuntu5 stage, as well as the soft modem on my machine for dial-up. How many millions of potential users are put off with these bugs which should not be too difficult to eliminate.???

Hello I have the same problem with a lexmark x1110 and ubuntu 9.10 "cups-insecure-filter" . Moreover I'm a beginner with linux and my English isn't very good. I have installed the driver following this Howto "http://linuxbot.wordpress.com/2009/04/27/instalando-impresora-lexmark-x1100-series-en-ubuntu/"

Kevin Payne (kap1000) wrote :

I use a Samsung laser printer from Ubuntu which has worked fine for over a year but after upgrading to 9.10 I received the 'cups-insecure-filter' error.

After reading other threads and here, I first changed the owner of /usr/lib/cups/filter and /usr/lib/cups/backend to root, but I still got the errror. Then I looked in the /usr/lib/cups/filter directory and saw three samsung files that were not owned by root. After running

 sudo chown root:root rastertosamsung*

in the /usr/lib/cups/filter directory my printer worked again. I would suggest anyone having this problem look for any files in this directory not owned by root and change them.

Robert Kofler (robert-kofler) wrote :

have the same/similar problem with Lexmark network printer and HP OfficeJet Pro 8000-A809 USB printer.
Both report the following error in printing dialog:
Filter "/usr/lib/cups/filter/foomatic-rip" for printer "<herr is the printer name>" has insecure permissions (0100777)

permissions:
-rwxrwxrwx 1 root root 97976 2010-02-15 18:02 /usr/bin/foomatic-rip*

Robert Kofler, the Ubuntu package (foomatic-filters) installs foomatic-rip with standard permissions:

till@till:~/ghostscript/gpl/gs$ ls -l /usr/bin/foomatic-rip
-rwxr-xr-x 1 root root 107272 2010-06-08 18:19 /usr/bin/foomatic-rip
till@till:~/ghostscript/gpl/gs$

Perhaps a third-party program (proprietary printer driver?) is messing up your file permissions.

Robert Kofler (robert-kofler) wrote :

thx till! solved!

I did a
 rk@gobi:~$ sudo chmod 755 /usr/bin/foomatic-rip
 rk@gobi:~$ ll /usr/bin/foomatic-rip
 -rwxr-xr-x 1 root root 97976 2010-02-15 18:02 /usr/bin/foomatic-rip*
 rk@gobi:~$ sudo /etc/init.d/cups restart
  * Restarting Common Unix Printing System: cupsd

and works!
btw: I use ubuntu 10.4

sleipner (andreas-zieritz) wrote :

Had the same problem with 10.10 on a new HP Printer (a Samsung was installed on the PC before).

Changing ownership of /usr/lib/cups/filter and /usr/lib/cups/backend to root solved the problem

jujenio (linux-jujenio) wrote :

hi to all. In debian wheezy 64bit with hp 3050 usb connected, got same issue, changing python-cups solved the "unknown IPP tag" but "cups-insecure-filter" keeping the error and dont print the test page, changing permission doesnt work for me. im using hplip 3.12.4.

TNAndy (pgbush) wrote :

If you have changed the ownership of /usr/lib/cups/filter and /usr/lib/cups/backend to root and the group to root, and are still getting this message, you have a SElinux problem. Change SElinux from enforcing to permissive as explained here:
http://www.crypt.gen.nz/selinux/disable_selinux.html

Good luck!

To post a comment you must log in.
This report contains Public information  Edit
Everyone can see this information.

Other bug subscribers