Ubuntu

cups fails on usb-parallel printer

Reported by Daniel Newman on 2009-09-11
26
This bug affects 5 people
Affects Status Importance Assigned to Milestone
cups (Ubuntu)
Undecided
Unassigned

Bug Description

Binary package hint: cups

cups has been working correctly on this installation since new. After a recent upgrade, a HP LaserJet 6L connected via a PRolific PL2305 usb to parallel interface stopped working. The foomatic/ljet4 driver is used

Using the "Print Properties" dialog, "Print Self-Test Page" fails with the message

CUPS server error
There was an error during the CUPS operation: 'client-error-document-format-not-supported'

"Print Test Page" accepts the job and prints the ubuntu test page correctly

However, printing any pdf file fails silently. There is heavy cpu usage for about a minute on a two-page file, but no attempt to access the printer. Other files, such as png, also fail to print. The cups error log for a pdf and a png file, each about 200k, is:

E [11/Sep/2009:11:31:49 +1000] [Job 407] Unable to write 8192 bytes to printer!
E [11/Sep/2009:11:38:06 +1000] [Job 408] Unable to write 4096 bytes to printer!

ProblemType: Bug
Architecture: amd64
CupsErrorLog:
 E [11/Sep/2009:11:07:00 +1000] [Job 403] Unable to write 8192 bytes to printer!
 E [11/Sep/2009:11:09:59 +1000] Unable to remove temporary file "/var/spool/cups/tmp/.hplip" - Is a directory
 E [11/Sep/2009:11:12:49 +1000] Returning IPP client-error-document-format-not-supported for Print-Job (ipp://localhost/printers/HP-LaserJet-6L) from localhost
 E [11/Sep/2009:11:20:37 +1000] Returning IPP client-error-document-format-not-supported for Print-Job (ipp://localhost/printers/HP-LaserJet-6L) from localhost
Date: Fri Sep 11 11:21:38 2009
DistroRelease: Ubuntu 9.10
Lpstat:
 device for DellDirect: socket://delldirect:9100
 device for DellSamba: smb://vmdaedalus/GSPSPrin
 device for HP-LaserJet-6L: usb://HP/HP%20LaserJet%206L?serial=?
MachineType: System manufacturer System Product Name
NonfreeKernelModules: fglrx
Package: cups 1.4.0-5
Papersize: a4
PccardctlIdent:

PccardctlStatus:

PpdFiles:
 DellSamba: Generic PostScript Printer
 DellSamba: Generic PostScript Printer
 HP-LaserJet-6L: HP LaserJet 6L Foomatic/ljet4 (recommended)
ProcCmdLine: BOOT_IMAGE=/boot/vmlinuz-2.6.31-10-generic root=UUID=06da8c6c-d07d-46e8-becf-5a4f4e3a31b1 ro quiet splash
ProcEnviron:
 LANG=en_AU.UTF-8
 SHELL=/bin/bash
ProcVersionSignature: Ubuntu 2.6.31-10.31-generic
SourcePackage: cups
Uname: Linux 2.6.31-10-generic x86_64
dmi.bios.date: 07/16/2008
dmi.bios.vendor: American Megatrends Inc.
dmi.bios.version: 0307
dmi.board.asset.tag: To Be Filled By O.E.M.
dmi.board.name: P3-P5G31
dmi.board.vendor: ASUSTeK Computer INC.
dmi.board.version: x.xx
dmi.chassis.asset.tag: Asset-1234567890
dmi.chassis.type: 3
dmi.chassis.vendor: Chassis Manufacture
dmi.chassis.version: Chassis Version
dmi.modalias: dmi:bvnAmericanMegatrendsInc.:bvr0307:bd07/16/2008:svnSystemmanufacturer:pnSystemProductName:pvrSystemVersion:rvnASUSTeKComputerINC.:rnP3-P5G31:rvrx.xx:cvnChassisManufacture:ct3:cvrChassisVersion:
dmi.product.name: System Product Name
dmi.product.version: System Version
dmi.sys.vendor: System manufacturer

Daniel Newman (dmnewman) wrote :
Till Kamppeter (till-kamppeter) wrote :

Can you do a complete update of your system and then run the shell command

sudo rmmod usblp

After that your printer should work again.

Changed in cups (Ubuntu):
status: New → Incomplete
Daniel Newman (dmnewman) wrote :

I don't think it is a duplicate bug.

The usblp module was not installed in the configuration tested above. However, I followed your instructions, and rebooted as well, before checking that usblp was not installed and was blacklisted in /etc/modules.d.

The results were the same as before.

The printer test page printed, but nothing else. When trying to print a pdf and a png, the cups error log was:

E [11/Sep/2009:19:56:46 +1000] [Job 410] Unable to write 8192 bytes to printer!
E [11/Sep/2009:19:57:48 +1000] [Job 411] Unable to write 1263 bytes to printer!

Daniel Newman (dmnewman) wrote :

bug is still current with cups 1.4.1-1 and an up-to-date karmic distribution.

Printing now works the first time after a reboot, but fails on all subsequent attempts. A typical failure message in the error_log is:

E [17/Sep/2009:11:43:16 +1000] [Job 427] Unable to write 4096 bytes to printer!

However, the access_log records a success:

localhost - - [17/Sep/2009:11:42:29 +1000] "POST /printers/HP-LaserJet-6L HTTP/1.1" 200 25573 Print-Job successful-ok

Using a different printer, accessed via the network, functions normally.

Daniel Newman (dmnewman) wrote :

bug still occurs with cups 1.4.1-2

Printing worked twice after a reboot, but failed on two subsequent attempts.

The access_log for these four print jobs was:

localhost - - [25/Sep/2009:12:59:19 +1000] "POST /printers/HP-LaserJet-6L HTTP/1.1" 200 241209 Print-Job successful-ok
localhost - - [25/Sep/2009:12:59:20 +1000] "POST / HTTP/1.1" 200 323 Create-Printer-Subscription successful-ok
localhost - - [25/Sep/2009:13:00:35 +1000] "POST /printers/HP-LaserJet-6L HTTP/1.1" 200 332278 Print-Job successful-ok
localhost - - [25/Sep/2009:13:01:21 +1000] "POST /printers/HP-LaserJet-6L HTTP/1.1" 200 348289 Print-Job successful-ok
localhost - - [25/Sep/2009:13:04:44 +1000] "POST /printers/HP-LaserJet-6L HTTP/1.1" 200 348289 Print-Job successful-ok

and the error_log for the four print jobs was:

E [25/Sep/2009:13:02:07 +1000] [Job 439] Unable to write 4096 bytes to printer!
E [25/Sep/2009:13:05:30 +1000] [Job 440] Unable to write 8192 bytes to printer!

Alan Herron (a-herron) wrote :

Newbie to launchpad...Alan

I'm having the same problem. The printer ran under 9.04, but was a bit "flaky" and had to be teased sometimes. When I installed 9.10 final beta the printer quit.

I think the problem is related to the PL-2305 not being recognized, as the command lsusb no longer lists it. I can reboot or unplug/replug and the result is the same.

I tried the sudo rmmod usblp as suggested. It returned this message

ERROR: Module usblp does not exist in /proc/modules

Hope this helps.

Alan

Daniel Newman (dmnewman) wrote :

I don't think these are the same bug, but I agree that Cups has become more flaky.

In my current Karmic installation, lsusb detects the PL-2305 correctly as:

Bus 001 Device 007: ID 067b:2305 Prolific Technology, Inc. PL2305 Parallel Port

My problem is that the printer connected to the PL-2305 always works for the first print job after a reboot of the computer, but always fails for all subsequent print jobs, with the CUPS administration page log saying:

HP_LaserJet_6L-96 Test Page anonymous 1k Unknown completed at
Fri 30 Oct 2009 04:05:53 PM EST
"Unable to write 8192 bytes to printer!"
HP_LaserJet_6L-95 Test Page anonymous 1k Unknown completed at
Fri 30 Oct 2009 03:59:00 PM EST
"Unable to write 8192 bytes to printer!"
HP_LaserJet_6L-94 Test Page anonymous 1k Unknown completed at
Fri 30 Oct 2009 03:56:54 PM EST

This has been going on for a couple of months now.

Geoff (geoffch) wrote :

Perhaps there is more than one bug, not only the usblp problem. I have upgraded my laptop to karmic, and my desktop is still running jaunty. Before the upgrade, I could print from the laptop to the printer attached to the desktop via either IPP or Samba. After the upgrade, when trying to print anything, even the test page, I get the same error message in the CUPS error log file: "Returning IPP client-error-document-format-not-supported for Print-Job". I get the same problem whether I connect to the remote printer via IPP or via Samba.

Alan Herron (a-herron) wrote :

re Daniel's comments: Under Intrepid my machine used to get the same message from lsusb...it listed the "Prolific..." string as you indicated. When I upgraded to Karmic that disappeared. There is no listing identifying the Prolific chip specifically like this at all. As I understand it this ID would be "downstream" of the print driver, making the choice of driver irrelevant until cleared.

Under Intrepid recognition of the printer wasn't reliable. I sometimes had to reboot, or unplug / replug the usb connection or turn the printer off and back on to get the computer to realize it was there. Push the threshold a bit and you get the behaviour I'm seeing now. I wouldn't think this would be a software problem, but the effort on Karmic involved speeding it up. That could have introduced faster timing for handshaking, and the older Prolific chips became marginal or simply too slow. A guess.

The following should be taken as coming from someone who has used computers for a long time, but is not familiar with CUPS at the detail level involved here:

re the failure after one print: this is a wild shot on my part, but I just had a similar problem with Open Office spreadsheet. It was resolved by removing the old configuration directory (which apparently contained a corrupted file) and letting OO generate a new one. Is it possible there is a similar problem in, say, a spool directory for you?

By way of possible clues: does the lockup clear if you turn the printer off and restart it? If so that suggests a handshake signal isn't making it through or is not being processed to clear the print status. I've had this happen, for example, if an end-of-page isn't sent to the printer when the job is complete. The computer "thinks" the job is done, but the printer is waiting for the "Tha's All Folks" signal to tidy up. Adding the EOP automatically is usually set as an option in the printer (driver) config, sometimes in an editor config.

re Geoff's comment: having trouble with networked printers, in the context of the flaky Prolific recognition, suggests the hardware recognition problem may be more generic than just the Prolific chip. Whatever it is something changed in the jump from Intrepid to karmic in this area. the "fault" is persistent and reproducible.

Hope this is helpful, and not ridiculous in context. A price of learning is to risk being seen as foolish!

Mark Greenwood (fatgerman) wrote :

I'm seeing this issue too, on a completely up-to-date Karmic. I'm using an Epson Stylus Photo R1800

Usually I get messages like

[Job 23] Unable to write 8192 bytes to printer!

,or sometimes the job is accepted but then nothing happens at all, not even a message in the Cups error log. The printer's LED flashes though, which indicates it is receiving something from the computer, but I left it alone for 2 hours last night and it still hadn't managed to even begin printing a 150k test page.

Sometimes if I look at the printer's status it says 'Idle..Processing Page 2' or 'Paused.. Processing Page 2'. Since I'm only trying to print a 1 page document I think this is the clue, but I don't know where to look.

I have not been able to print at all since I upgraded to Karmic and Cups 1.4. Previously I was using a Mandriva system with Cups 1.3 (same hardware) and the printer worked perfectly every time.

DaNieL (daniele-pignedoli) wrote :

This issue is still here with Ubuntu 10.04 LTD.

Launchpad Janitor (janitor) wrote :

[Expired for cups (Ubuntu) because there has been no activity for 60 days.]

Changed in cups (Ubuntu):
status: Incomplete → Expired

Running Ubuntu 'classic' 11.04

I've had to use a USB to parallel printer adapter to get my printer to work on a new motherboard.
lsusb lists it :-
Prolific Technology, Inc. PL2305 Parallel Port
This is always in the list if the printer cable is plugged in.

I'm getting the same problem as mentioned above. It looks like this has still not been fixed.

I can boot up and the first print job works. After that I have to unplug and replug the USB lead before every print job otherwise the job is just queued.

In Printer properties:-
Device URI: usb://HP/DESKJET%20820C

To post a comment you must log in.
This report contains Public information  Edit
Everyone can see this information.

Other bug subscribers