Ubuntu

CUPS 1.4.0, jobs stall in "processing..."

Reported by ilna on 2009-08-27
14
This bug affects 3 people
Affects Status Importance Assigned to Milestone
cups (Ubuntu)
Undecided
Unassigned
Nominated for Karmic by ilna

Bug Description

Binary package hint: cups

Up to date Kubuntu Karmic is in use.

After recent CUPS updating to 1.4.0 version, all jobs just stall in "processing..." state. It doesn't depend on the way a job was started: say, printing from Okular or printing a test page from CUPS web admin frontend - both result in stalling.

Kyocera FS-1030D USB printer (with manufacturer's ppd) is in use.

Must I supply some additional information?

P.S. As there are many updates have took place last days, I can not be sure a CUPS updating is a reason of the issue.

John Yates (andyfranyates) wrote :

Same here.

ilna (a-gaydenko) wrote :

Additional information.

Also I have two own CUPS backends (in fact, it is just 'pstops' convertion) - printers based on these backends don't stall in processing - rather successfully directs a job to real printer mentioned above (Kyocera), and this way got job for Kyocera does stall also.

The problem isn't related to, say, apparmor - stopping the service (and restarting CUPS) doesn't help.

ilna (a-gaydenko) wrote :

The same with 2.6.31.8 kernel - "processing", a printer doesn't receive any data.

ilna (a-gaydenko) wrote :

Again addition.

Have tried to readd this (Kyocera FS-1030D) printer. Deleted, than have tried to add it with CUPS admin and KDE's printer config in systemsettings. The printer isn't visible at both cases. Of course, lsusb shows the printer without problems. 'usblp' kernel module is also loaded.

USB CUPS backend?

Till Kamppeter (till-kamppeter) wrote :

Ilna, you must UNLOAD the "usblp" CUPS kernel module as described in bug 420015. The new USB CUPS backend does not use it any more and works only without it.

Atti (atti84it) wrote :

I have the same problem but only when I try to print PDFs!

Till Kamppeter (till-kamppeter) wrote :

Atti, your problem is NOT the one described here, it is bug 488710.

To post a comment you must log in.
This report contains Public information  Edit
Everyone can see this information.

Other bug subscribers