Ubuntu

CUPS does not work with Firefox, HTTPS bug (Hardy LTS)

Reported by K on 2009-05-05
34
This bug affects 4 people
Affects Status Importance Assigned to Milestone
cups (Debian)
Fix Released
Unknown
cups (Ubuntu)
Undecided
Unassigned
Hardy
Medium
Unassigned

Bug Description

Binary package hint: cups

CUPS forces the use of httpS connection to add a new printer. There is a bug in CUPS-1.3.7 with httpS connection when connecting interface with Firefox 3.

The official CUPS bug report is here :
http://www.cups.org/str.php?L2892

The bug is corrected in CUPS-1.3.9. This version is present on Ubuntu Jaunty.

* Hardy/LTS will be supported for 5 years long.
* It is impossible to add a printer with Firefox 3 on LTS (do not want to push users to use IE instead).
Is it possible to backport CUPS from Jaunty to LTS (Hardy) ?

Krzysztof Klimonda (kklimonda) wrote :

I think that the right way would be to backport this patch: http://www.cups.org/strfiles/2892/str2892-1.3.patch as a SRU.

Changed in cups (Debian):
status: Unknown → New
Martin Pitt (pitti) wrote :

Fixed in intrepid and beyond.

http://www.cups.org/str.php?L2892

Changed in cups (Ubuntu):
status: New → Fix Released
James Andrewartha (trs80) wrote :

Maybe it is fixed in intrepid, but as the title says, this bug is for hardy.

Changed in cups (Ubuntu):
status: Fix Released → Confirmed
James Andrewartha (trs80) wrote :

A statement explaining the impact of the bug on users and justification for backporting the fix to the stable release:
Prevents users of the default browser, Firefox, from configuring CUPS through the web interface

An explanation of how the bug has been addressed in the development branch, including the relevant version numbers of packages modified in order to implement the fix:
Fixed upstream and in intrepid.

A minimal patch applicable to the stable version of the package. If preparing a patch is likely to be time-consuming, it may be preferable to get a general approval from the SRU team first.
http://www.cups.org/strfiles/2892/str2892-1.3.patch applies cleanly, with just a few lines of offset.

Detailed instructions how to reproduce the bug. These should allow someone who is not familiar with the affected package to reproduce the bug and verify that the updated package fixes the problem. Please mark this with a line "TEST CASE:".
TEST CASE: Try to add a printer through the CUPS web interface with Firefox 3. It will hang after selecting the Make.

A discussion of the regression potential of the patch and how users could get inadvertently affected:
Minimal, fix already applied upstream

Martin Pitt (pitti) on 2009-07-31
Changed in cups (Ubuntu):
status: Confirmed → Fix Released
Changed in cups (Ubuntu Hardy):
importance: Undecided → Medium
status: New → Triaged
stevenp (spocks-penis) wrote :

I've _never_ been able to share a printer on Hardy (or Hoary). Everything else in the world I can do. Share the printer? No. It's the reason I loaded 10.whatever on my laptop, to no avail. Ironically, that's the first thing I learned to do with M$ products network-wise.

It's just cheaper, time-wise, to buy a print server and take the OS from between the client and the printer.

Changed in cups (Debian):
status: New → Fix Released
To post a comment you must log in.
This report contains Public information  Edit
Everyone can see this information.

Duplicates of this bug

Other bug subscribers

Remote bug watches

Bug watches keep track of this bug in other bug trackers.