System print config "forgets" printer status / settings on reboot

Bug #368977 reported by Reuben Firmin on 2009-04-29
This bug affects 2 people
Affects Status Importance Assigned to Milestone
Gnome Print
System Config Printer
cups (Ubuntu)
kubuntu-meta (Ubuntu)
system-config-printer (Ubuntu)

Bug Description

I will update this bug the next time it happens. If anybody can suggest debugging information that would be helpful, I'll include it. So far, this has happened twice, both in very recent versions of KDE 4.2 (Kubuntu 9.04; I was on the RCs).

I have a Laserjet 8150. I try to print (e.g. from Firefox), choose the printer, and nothing happens. Then I look in the KDE printer applet, and it says the printer is unavailable, or busy, or...

No combination of restarting the printer, clearing the print job queue, or restarting the computer seems to work. The only workaround I have is to go through KDE's printer configuration and remove/install the printer. After that, it works. My working theory based on this is that something about the printer config is being screwed up.

Before a week or so ago, I never had this problem, and the printer worked reliably. So, it's a recent bug.

At what point in the workflow I don't know. More information when I have it.

Reuben Firmin (reubenf) wrote :

See attached screenshot demonstrating the bug. Note the error message in the terminal, which showed up at the same time as the synchronization (I ran plasma manually earlier today after a crash; I don't usually run it manually, but it's hopefully good debugging info.)

As before, going through the new printer wizard is enough to start printing. I have not printed since filing this bug; aka every time I print after rebooting the computer I have to set the printer up again. Extremely annoying bug.

Reuben Firmin (reubenf) wrote :

Adding a project to it. I really don't know where this belongs, but the bug needs attention. It can't just be me.

affects: ubuntu → kubuntu-meta (Ubuntu)
Peter Lemieux (seijisensei) wrote :

I have a similar problem. I configure a printer using the "printer configuration" tool in the KDE Control Module. (This is an unbearably slow procedure, by the way, though I doubt that's related to the bug here.) I can then print, but if I shutdown or reboot, the configured printer disappears from the list, and I'm forced to configure it again.

Kubuntu 9.04

I noticed that there was a substantial update of the CUPS software on 4/28. Also on 4/23, I see an update to this package: system-config-printer-common_1.1.3+git20090218-0ubuntu19.1_all

Perhaps there's some conflict between these updates and the KDE4 configuration tool? The problem started to appear only recently, so these updates look like plausible suspects.

This is pretty much a show-stopper in my mind. If people have to reconfigure a printer repeatedly, they'll not be staying with Kubuntu for long.

Reuben Firmin (reubenf) wrote :

I suspect it is system-config-printer at fault, as that corresponds with about the time that I first saw the issue.

affects: wyocode → cups
Peter Lemieux (seijisensei) wrote :

I believe the problem has to do with file permissions. It seems like you can set the configuration as an ordinary user and have it persist even through logout and re-login, but rebooting the machine destroys the saved configuration. For the moment I've "fixed" the problem by using kmenuedit to require root permissions for the "Printer Configuration" app. That approach created configuration files that persisted through rebooting.

In addition a small announcement box flashes up on the screen when you first save as an ordinary user, but it appears for only an instant so I can't tell what it says. I'm guessing it's reporting an error. I also get errors like these upon launch in .xsession-errors:

kcmshell(3619) KServiceFactory::findServiceByDesktopPath: "findServiceByDesktopPath: kcm-scpk.desktop not found"

(kcm-scpk is the Python script that executes when you run Printer Configuration.)

I've only recently come to Ubuntu from RedHat/Fedora and was surprised not to be required to have root privileges when configuring printers. As an ordinary user I should only be able to write to $HOME and /tmp. I don't see any new files in those places when I run the Printer Configuration utility under my ordinary username.

I'm going to file a bug under system-config-printer-kde since I think the problem concerns how the KDE application works that may not occur with GNOME Ubuntu.

Reuben Firmin (reubenf) wrote :

Excellent sleuthing and thanks for the workaround.

Reuben Firmin (reubenf) wrote :

Your workaround doesn't work for me unfortunately.

I've reproduced this same issue on Gnome, now that I've switched away from Kubuntu, so I added gnome-print.

Again, the steps:
1. Add printer via gnome-printer
2. Print happily
3. Reboot
4. Printing doesn't work (jobs just hang as "processing")
5. Curse.
6. Delete and re-add printer via gnome-printer
7. Goto 2.

Reuben Firmin (reubenf) on 2009-06-24
summary: - KDE4 "forgets" printer status / settings
+ System print config "forgets" printer status / settings on reboot
Murz (murznn) wrote :

Confirm on Kubuntu Jaunty AMD64 and KDE 4.2.
On another computer with Jaunty and KDE updated to 4.3 beta 2 this bug is disappear.

Jonathan Thomas (echidnaman) wrote :

Not an issue with the kubuntu-desktop meta package -> Invalid for kubuntu-meta.

Changed in kubuntu-meta (Ubuntu):
status: New → Invalid
MightyPork (mighty-pork) wrote :

I have the same problem on Lucid:
when I install cups, I can print, add printers etc..
However, after reboot nothing works, even the "add printer" dialog in system settings is broken (impossible to add printer).
The only thing I can do is to REINSTALL CUPS and other cups-related packages via synaptic.
I hope it will be fixed soon, because now non-admin users can't use printer at all.

The Lucid problem is known and handled as bug 554172.

Michael Lueck (mlueck) wrote :

I, as a work around, command line script attach to the printer(s) at boot-up. Please see the following blog post:

Print queue information is saved in the /etc/cups/printers.conf file. Is CUPS able to write into it (see whether it actually contains the info about the queues you have set up)? Does the file survive a reboot (must be on a real HD file system, not on a RAM disk or so)? Backup the file after configuring the printers. Then restart CUPS via

sudo /etc/init.d/cups stop
sudo /etc/init.d/cups start

Compare /etc/cups/printers.conf with the backup. Did something change? Does CUPS still list the queues? If the file changed, stop CUPS, restore the file and start CUPS. Is then all back to normal again?

Reboot your computer. Compare /etc/cups/printers.conf with the backup again. Did something change? Does CUPS still list the queues? If the file changed, stop CUPS, restore the file and start CUPS. Is then all back to normal again?

Hello Reuben,
Thank you for submitting this bug and reporting a problem with cups and printing. You made this bug report some time ago and Ubuntu has been updated since then.

Could you confirm that this is no longer a problem and that we can close the ticket?
If it is still a problem, are you still interested in finding a solution to this bug?
If you are, could you let us know, and in the current version, run the following (only once):
apport-collect BUGNUMBER
and upload the updated logs and and any other logs that are relevant for this particular issue.

Thank you again for helping make Ubuntu better.

Changed in system-config-printer (Ubuntu):
status: New → Incomplete
Changed in cups (Ubuntu):
status: New → Incomplete
Changed in system-config-printer:
status: New → Incomplete
Changed in gnome-print:
status: New → Incomplete
To post a comment you must log in.
This report contains Public information  Edit
Everyone can see this information.

Other bug subscribers

Bug attachments