Printing broken on jaunty (cnpkmodule?)

Bug #367594 reported by Jaap Weel on 2009-04-26
28
This bug affects 2 people
Affects Status Importance Assigned to Milestone
cups (Ubuntu)
Undecided
Unassigned

Bug Description

I'm using jaunty on a Thinkpad T61 with a Canon imageClass MF4150 printer attached with a USB cable.

I run the following command:

 echo "Test" | a2ps

I expect a page with the word "Test" on it to be printed.

No such thing happens. At no point, in fact, does the printer do anything at all.

The print job does get into the print queue; when I run

   lpq

I get

MF4100-Series is ready and printing
Rank Owner Job File(s) Total Size
active weel 1589 (stdin) 18432 bytes

When I run

   ps axf

I find, among many others, the following processes:

 4376 ? Ss 0:00 /usr/sbin/cupsd
 5715 ? S 0:00 \_ MF4100-Series 1589 weel (stdin) 1 media=Letter sides=one-sided finishings=3 number-up=1 job-uuid=urn:uuid:4ad
 5736 ? S 0:00 \_ /usr/bin/gs -r600 -dDEVICEWIDTH=5100 -dDEVICEHEIGHT=6600 -sDEVICE=opvp -sDriver=libcanonc3pl.so -sModel=M
 5739 ? Z 0:00 \_ [c3pldrv] <defunct>
 5741 ? R 9:44 /usr/bin/cnpkmodule --format=2 --output=1 --cmd_fd=7 --res_fd=15 --dat_fd=16

In particular, the process cnpkmodule takes up 100% CPU! I don't know what it's doing, but it sure is busy doing it, and it keeps going. To find out what it's doing, I run

   sudo strace -p 5741

and I get

read(7, ""..., 4) = 0
read(7, ""..., 4) = 0
read(7, ""..., 4) = 0
read(7, ""..., 4) = 0
....

over and over and over agin.

Apparently, cnpkmodule is very busy reading nothing in particular from file handle 7, so let's find out what file handle 7 is...

I run

       sudo lsof -p 5741

and get

COMMAND PID USER FD TYPE DEVICE SIZE NODE NAME
[...]
cnpkmodul 5741 lp 7r FIFO 0,6 35341 pipe
[...]

Apparently, it's a pipe.

That's all the debugging I'm going to do for now, but I hope it gives someone a lead as to what's going on here.

affects: ubuntu → cups (Ubuntu)
Rixx (ruri) wrote :

I have Canon MF4010 and this problem too. On Intrepid is all good.

Alvaro Gonzalez (andor) wrote :

I have a Canon ImageRunner Color 2380i.

I have installed the Canon Linux Drivers.

When I print from a webpage, it works ok, but when I print a pdf from Evince, cnpkmodule gets stuck, and the document stays in the print queue. Even when I cancel the job from the print queue it still is stuck.

AwAkE (javi-serrano) wrote :

I have the same problem with the same printer Cannon ImageRunner Color 2380i when the print method is two sided. I review the code of the driver and I think that it got a bug that sends the whole document each time the printer must print a new page. This is only an idea that I have, but I have no time to test it as I would like to.

npopov (npopov1) wrote :

Same problem with Canon MF4270.
I've killed the: cnpkmodul and the socket processes, but after that the print jobs will get hosed.

nachiket (nachiket) wrote :

I can confirm this is a problem with my MF4100 as well. I have been able to get it to scan just fine...

I can report following CUPS status:
E [26/Jun/2009:10:58:21 -0400] [Job 9] Unable to open device "hal:///org/freedesktop/Hal/devices/usb_device_4a9_26a3_SDF680281822B_if1_printer_noserial": Permission denied
E [26/Jun/2009:10:58:21 -0400] PID 6339 (/usr/lib/cups/backend/hal) stopped with status 1!
E [26/Jun/2009:10:58:23 -0400] [Job 9] src = libcanon_pdlwrapper.c, line = 630, err = -1Â¥nError Response:ReqNo=2, SeqNo=3,errorno=-2

nachiket (nachiket) wrote :

This has been fixed in the new UFR-II 1.9 driver from Canon..
See post-> https://answers.launchpad.net/ubuntu/+question/79913

frankie (frankie-etsetb) wrote :

The UFR2 1.9 driver works for me and my iR C2880. It is not easy to find the driver, typing the printer model is useless. I had more luck searching for "ufr". Anyway the link is :

http://support-sg.canon-asia.com/contents/SG/EN/0100093003.html

demmsnt (demmsnt) wrote :

i have Canon MF-4150. And download UFR_II_Printer_Driver_for_Linux_V220_uk_EN driver.
And in my computer too when print cnpkmoduleufr2 eat all CPU.
But i have maverick meerkat Ubuntu. In oldest Ubuntu distributions i not have this bug.

Changed in cups (Ubuntu):
status: New → Confirmed

Problem of Canon's proprietary driver which is not part of Ubuntu. Please report this problem to Canon. Closing ...

Changed in cups (Ubuntu):
status: Confirmed → Invalid
David Faure (faure) wrote :

As I found on openSUSE forums, this is in fact a bug in ghostscript version 9.

Check `gs --version` to see which version you're using.
And check /var/log/messages for lines like "gs[...]: segfault at ..."

A workaround is to downgrade to ghostscript 8.

To post a comment you must log in.
This report contains Public information  Edit
Everyone can see this information.

Other bug subscribers