Ubuntu

Constant errors with Brother MFC-8440 and cups

Reported by Brett Alton on 2009-02-16
4
Affects Status Importance Assigned to Milestone
cups (Ubuntu)
Undecided
Unassigned

Bug Description

Binary package hint: cups

When I plug in my Brother MFC-8440 and try to print from OpenOffice.org, I always receive this error:

ERROR NAME:
    configurationerror
COMMAND:
    setpagedevice
OPERAND STACK:
    --dicttype--

But a 'test page' from system-config-printer works.

I was following Till Kamppeter when he and someone else knocked off brother/cups packages for Hardy, so I installed those ('brother-lpr-drivers-laser1' and 'brother-cups-wrapper-laser1') on my 8.10 fresh install.

Then I switched the driver from 'Brother MFC-8440 BR-Script3' to 'Brother MFC-8440 for CUPS'.

It works, but not perfectly, so I'll submit another bug for that.

What can I do in the mean time about the BR-Script3 error? If it's happening to me, it's surely happening to others.

JanBrinkmann (jbrinkmann) wrote :

Thank you for taking the time to report this bug and helping to make Ubuntu better. Unfortunately, we can't fix it because your description didn't include enough information. You may find it helpful to read "How to report bugs effectively" http://www.chiark.greenend.org.uk/~sgtatham/bugs.html. We'd be grateful if you would then provide a more complete description of the problem.

We have instructions on debugging some types of problems at http://wiki.ubuntu.com/DebuggingProcedures

At a minimum, we need:
1. the specific steps or actions you took that caused you to encounter the problem,
2. the behavior you expected, and
3. the behavior you actually encountered (in as much detail as possible).
4. The version of the related packages you've installed
Thanks!

Changed in cups:
status: New → Incomplete
Brett Alton (brett-alton) wrote :

I'm sorry, but please don't send me that generic "need more info" message.

I gave you all the information I can as a competent Linux user. What else would you like to know? I gave you:
 * the printer I use
 * the printer drivers I use
 * the program I used to print from
 * the version of Ubuntu I am using
 * the specific error message that is being printed

I don't know how to debug ghostscript or any other printing procedures, so I'll need your help with that.

Nothing shows in the error logs; this simply occurs when printing using my Brother MFC-8440, using the default driver.

What can I give you to further this investigation? Please tell me.

Brett Alton (brett-alton) wrote :

$ apt-cache policy cups linux-image-generic openoffice.org-common brother-lpr-drivers-laser1 brother-cups-wrapper-laser1 && lsb_release -a
cups:
  Installed: 1.3.9-2ubuntu6.1
  Candidate: 1.3.9-2ubuntu6.1
  Version table:
 *** 1.3.9-2ubuntu6.1 0
        500 http://archive.ubuntu.com intrepid-updates/main Packages
        500 http://security.ubuntu.com intrepid-security/main Packages
        100 /var/lib/dpkg/status
     1.3.9-2 0
        500 http://archive.ubuntu.com intrepid/main Packages
linux-image-generic:
  Installed: 2.6.27.11.14
  Candidate: 2.6.27.11.14
  Version table:
 *** 2.6.27.11.14 0
        500 http://archive.ubuntu.com intrepid-updates/main Packages
        500 http://security.ubuntu.com intrepid-security/main Packages
        100 /var/lib/dpkg/status
     2.6.27.7.11 0
        500 http://archive.ubuntu.com intrepid/main Packages
openoffice.org-common:
  Installed: 1:2.4.1-11ubuntu2.1
  Candidate: 1:2.4.1-11ubuntu2.1
  Version table:
 *** 1:2.4.1-11ubuntu2.1 0
        500 http://archive.ubuntu.com intrepid-updates/main Packages
        500 http://security.ubuntu.com intrepid-security/main Packages
        100 /var/lib/dpkg/status
     1:2.4.1-11ubuntu2 0
        500 http://archive.ubuntu.com intrepid/main Packages
brother-lpr-drivers-laser1:
  Installed: 1.0.0-3-0ubuntu4
  Candidate: 1.0.0-3-0ubuntu4
  Version table:
 *** 1.0.0-3-0ubuntu4 0
        500 http://archive.ubuntu.com intrepid/multiverse Packages
        100 /var/lib/dpkg/status
brother-cups-wrapper-laser1:
  Installed: 1.0.2-1-0ubuntu6
  Candidate: 1.0.2-1-0ubuntu6
  Version table:
 *** 1.0.2-1-0ubuntu6 0
        500 http://archive.ubuntu.com intrepid/multiverse Packages
        100 /var/lib/dpkg/status
No LSB modules are available.
Distributor ID: Ubuntu
Description: Ubuntu 8.10
Release: 8.10
Codename: intrepid

JanBrinkmann (jbrinkmann) wrote :

Thanks you very much for the package version information. I thought the problem and the sentence 'It works, but not perfectly, so I'll submit another bug for that.' was related to this report. That would be a vague description. I can confirm the problem. Tested it and exactly the same error. However, that error message comes from the printer. It's not something that cups prints. This happens also under Windows, using a wrong/problematic driver.

Changed in cups:
status: Incomplete → Confirmed
To post a comment you must log in.
This report contains Public information  Edit
Everyone can see this information.

Other bug subscribers