[needs-packaging] PPD for Dymo LabelWriter 400 not complete

Bug #322210 reported by Ben Andersen on 2009-01-28
22
This bug affects 3 people
Affects Status Importance Assigned to Milestone
cups (Ubuntu)
Wishlist
Unassigned
Declined for Jaunty by Till Kamppeter
Declined for Karmic by Brian Murray

Bug Description

Binary package hint: cups

Release: 8.10
Cups package version: 1.3.9-2ubuntu6.1

I installed Dymo LabelWriter 400 with the Multi-Purpose labels 11354.
I chose the only available driver: Dymo Label Printer, 1.3

Problem: I could not set the correct label size as the Multi-Purpose labels are missing from the ppd-file. The result is that I get printouts which do not fit the labels.

Solution:
I downloaded the driver from the manufacturer and extracted the lines for the Multi-Purpose labels from their ppd-file.
drivers page: https://global.dymo.com/enUS/RNW/RNW.html?pg=std_adp.php&p_faqid=101
driver file: http://www.dymo.com/media/Software/dymo-cups-drivers-1.0.3.tar.gz

What should be done is that the ppd-file in cups should be updated with all the labels in the manufacturers ppd. Depending on their license.

Anders (andersja+launchpad-net) wrote :
tags: added: needs-packaging
Brian Murray (brian-murray) wrote :

*** This is an automated message ***

This bug is tagged needs-packaging which identifies it as a request for a new package in Ubuntu. As a part of the managing needs-packaging bug reports specification, https://wiki.ubuntu.com/QATeam/Specs/NeedsPackagingBugs, all needs-packaging bug reports have Wishlist importance. Subsequently, I'm setting this bug's status to Wishlist.

summary: - PPD for Dymo LabelWriter 400 not complete
+ [needs-packaging] PPD for Dymo LabelWriter 400 not complete
Changed in cups (Ubuntu):
importance: Undecided → Wishlist

The file linked to by Ben supports a wide range of devices including (but not limited to):

- LabelManager 400
- LabelManager 450
- LabelPrinter 350
- LabelWriter 300
- LabelWriter 310
- LabelWriter 315
- LabelWriter 320
- LabelWriter 330
- LabelWriter 330 Turbo
- LabelWriter 400
- LabelWriter 400 Turbo
- LabelWriter Duo
- LabelWriter Duo Turbo

Even though manual installation is trivial, packaging this up should hopefully be fairly straight forward as well. As far as I can see it's all GPLed too. Awesomity all around!

Mr Ben Andersen,

The upstream bug tracker http://www.cups.org/str.php is the correct place to post your enhancement request for the dymo ppd-file from cups, please post it there.

Instead of packaging the manufacturers driver for Ubuntu it would be better to provide a openprinting distribution independent driver package as described here: http://www.linux-foundation.org/en/OpenPrinting/WritingAndPackagingPrinterDrivers
This would allow automatic download and installation of the manufacturers printer driver by system-config-printer as already implemented by this specification: https://blueprints.launchpad.net/ubuntu/+spec/printerdriverautodownload since Ubuntu Intrepid. Please consider asking to the manufacturer of providing such a package that allows their printer driver to be installed automatically on Linux in general (not only Ubuntu).

George Farris (george-gmsys) wrote :

Can you please add this driver to Karmic. I just had a go around with a customer who had Jaunty and couldn't understand why the drive was there for Jaunty and yet a new version of Ubuntu didn't have it. Yes I did explain that Karmic was beta and no I didn't install it, they did it on their own.

Still I'm don't get it either why the driver suddenly disappeared.

Also the linuxprinting.org site lists this printer Dymo Lablewriter as working perfectly with a cups included driver.

Cheers and thanks for considering this.
George

I just installed Karmic (final) but can't find the driver for my Dymo LabelWriter! It worked fine in Jaunty. What to do?

George Farris (george-gmsys) wrote :

You can download the driver from the manufacturer, compile and install it. It works. Pretty unfriendly IMHO. I have no idea why this regression happened, shouldn't have.

See the first message for download links.

tags: added: karmic-regression

@George: compiling and installing the driver manually does not work for me. Download URL: https://global.dymo.com/enUS/RNW/RNW.html?pg=std_adp.php&p_faqid=101

According to the readme what you need to do is:

1) Download the .tar.gz and extract it. Fine.
2) Open a terminal and browse to the extracted directory. There run ./configure. That went fine after I installed a package first, I have to search on the internet to find the command again.

3) Run make. Errors:

Making all in src
make[1]: Entering directory `/home/daniel/Desktop/dymo-cups-drivers-1.2.0/src'
make all-recursive
make[2]: Entering directory `/home/daniel/Desktop/dymo-cups-drivers-1.2.0/src'
Making all in lw
make[3]: Entering directory `/home/daniel/Desktop/dymo-cups-drivers-1.2.0/src/lw'
Making all in tests
make[4]: Entering directory `/home/daniel/Desktop/dymo-cups-drivers-1.2.0/src/lw/tests'
make[4]: Nothing to be done for `all'.
make[4]: Leaving directory `/home/daniel/Desktop/dymo-cups-drivers-1.2.0/src/lw/tests'
make[4]: Entering directory `/home/daniel/Desktop/dymo-cups-drivers-1.2.0/src/lw'
source='raster2dymolw.cpp' object='raster2dymolw.o' libtool=no \
 DEPDIR=.deps depmode=none /bin/bash ../../depcomp \
 g++ -DHAVE_CONFIG_H -I. -I../../src -I../common -O2 -Wall -Wno-unknown-pragmas -c -o raster2dymolw.o raster2dymolw.cpp
../../depcomp: line 504: exec: g++: not found
make[4]: *** [raster2dymolw.o] Error 127
make[4]: Leaving directory `/home/daniel/Desktop/dymo-cups-drivers-1.2.0/src/lw'
make[3]: *** [all-recursive] Error 1
make[3]: Leaving directory `/home/daniel/Desktop/dymo-cups-drivers-1.2.0/src/lw'
make[2]: *** [all-recursive] Error 1
make[2]: Leaving directory `/home/daniel/Desktop/dymo-cups-drivers-1.2.0/src'
make[1]: *** [all] Error 2
make[1]: Leaving directory `/home/daniel/Desktop/dymo-cups-drivers-1.2.0/src'
make: *** [all-recursive] Error 1

Daniel,

you'll need to `sudo aptitude install build-essential`.

Thanks, I got my Dymo Labelwriter 400 to work! Indeed quite unfriendly that it has to be done this way.

davescafe (davescafe) wrote :

I am also stranded by the absence of the DYMO driver in Ubuntu 9.10. Besides the comments on this page, I found this information helpful when manually installing the driver from dymo.com: http://ubuntuforums.org/archive/index.php/t-861781.html

Miek Gieben (miek) wrote :

You can just download the source of cups: apt-get source cups and get the dymo.ppd file from there. It is located
in the ppd subdirectory and called dymo.ppd. At least for the dymo 400 (which I have) I can say it works ok.

More detailed instruction can be found at:
http://www.miek.nl/blog/archives/2009/10/31/dymo_400_label_writer_in_ubuntu_jauntykarmic/index.html

Based on the comments above, should this bug be upgraded from "Wishlist" to a proper bug?

J. Cook (cookiecaper) wrote :

After building dymo-cups-drivers-1.2.0 things work fine and the driver is located automatically. I had to install libcupsimage2-dev and libcups-dev. I would really like to see this properly packaged and distributed; my dad would have been impressed if it had worked out of the box. ;)

Additionally, no information appears when the printer is plugged in. This should be fixed as well. Here's the lsusb if there's a whitelist: ID 0922:0020 Dymo-CoStar Corp.

This is LabelWriter 450.

Launchpad Janitor (janitor) wrote :

Status changed to 'Confirmed' because the bug affects multiple users.

Changed in cups (Ubuntu):
status: New → Confirmed
annunaki2k2 (russell-knighton) wrote :

Agreeing with Anders - I think this should no longer be a bug marked as "wishlist" but should be upgraded to something more important. As a business user, this missing functionality is a bit of a ball ache...

Jaunty is not supported any more. Please update to a supported version of Ubuntu. Declining Jaunty task.

gf (gf-interlinks) wrote :

Hello Ben,
Thank you for submitting this feature/enhancement request for the hplip package. You made this request quite some time ago and Ubuntu has been updated since then.

Do you think this feature/enhancement is still needed or can we close this bug report?

Thank you again for helping make Ubuntu better.
G
[Ubuntu Bug Squad volunteer triager]

Changed in cups (Ubuntu):
status: Confirmed → Incomplete
gf (gf-interlinks) wrote :

Sorry, I meant: ".. with the *cups* package." :)

Ben Andersen (ben72) wrote :

Thanks for getting back to me! I no longer have this piece of hardware so it's ok for me to close this one for now.

gf (gf-interlinks) wrote :

Thanks for the update, Ben. I will close the report now.
Have a great day!
:)
G

Closed per reporter’s feedback.

Changed in cups (Ubuntu):
status: Incomplete → Invalid
To post a comment you must log in.
This report contains Public information  Edit
Everyone can see this information.

Other bug subscribers