No driver for Canon i250 printer

Bug #278514 reported by sam tygier
30
This bug affects 6 people
Affects Status Importance Assigned to Milestone
cups (Ubuntu)
Fix Released
Wishlist
Unassigned
jockey (Ubuntu)
Invalid
Undecided
Unassigned

Bug Description

Binary package hint: cups

The printer is detected when plugged in, but the "Generic text-only printer" driver is selected. This does not print anything, even a plain text document in gedit.

I tried manually choosing the printer in the system->admin->printing but i250 is not in the list of canons.

there are instructions of the web about getting
http://download.canon.com.au/bj/i250linux/bjfilteri250-2.3-0.i386.rpm
http://download.canon.com.au/bj/i250linux/bjfiltercups-2.3-0.i386.rpm
and using alien.

these drivers ought to be included in the repos (or partnet repo).

Revision history for this message
sam tygier (samtygier) wrote :
Changed in cups (Ubuntu):
importance: Undecided → Wishlist
Revision history for this message
bigal50 (bigal50) wrote :

There is a workaround that is posted on the web. The following commands are for Intrepid 8.10
[code]gksudo "aptitude -y install libpng3 libtiff4 cupsys alien"
cd /tmp
wget http://download.canon.com.au/bj/i250linux/bjfilteri250-2.3-0.i386.rpm
wget http://download.canon.com.au/bj/i250linux/bjfiltercups-2.3-0.i386.rpm
gksudo "alien --scripts bjfilteri250-2.3-0.i386.rpm"
gksudo "alien --scripts bjfiltercups-2.3-0.i386.rpm"
gksudo "dpkg -i bjfiltercups_2.3-1_i386.deb bjfilteri250_2.3-1_i386.deb"
gksudo "ln -s /usr/lib/libtiff.so.4 /usr/lib/libtiff.so.3"
gksudo "ln -s /usr/lib/libpng.so.3 /usr/lib/libpng.so.2"
gksudo "/etc/init.d/cups restart"
[/code]
The code don't actually set the printer up. You will still have to do that in the normal way through System → Administration → Printing. When offered the option, tell the computer to use the PPD file at /usr/share/cups/model/canoni250.ppd.

New > Confirmed

Changed in cups:
status: New → Confirmed
Revision history for this message
Grey Nicholson (greytheearthling) wrote :

I should point out that this script doesn't actually work reliably—I published it when it worked for me first time, but the printer's since stopped working again.

Revision history for this message
bigal50 (bigal50) wrote :

This could be a work around until it shows up in Foomatic

http://www.openprinting.org/show_printer.cgi?recnum=Canon-i250

Revision history for this message
Dante Díaz (dante) wrote :

Yes, i still have this model of Canon printer and can't make works with Ubuntu :(

Revision history for this message
Till Kamppeter (till-kamppeter) wrote :

Note that we cannot include the proprietary drivers mentioned here and also on the OpenPrinting web site in the Ubuntu distribution. It is in the hands of Canon to provide drivers which work flawlessly with the current Linux distributions and also make them auto-downloadable via OpenPrinting. This is not a bug of the Ubuntu distribution.

Changed in cups (Ubuntu):
status: Confirmed → Invalid
Revision history for this message
sam tygier (samtygier) wrote :

There are 2 ways that this could be fixed in ubuntu.
1) Jocky could install the proprietary driver (as done with various wireless and graphics card)
2) An opensource driver could be written.
There for it makes little sense to mark this as invalid

Changed in cups (Ubuntu):
status: Invalid → New
Revision history for this message
Pad (apourir) wrote :

This might be an old bug report but I'm still using this old Canon i250 and, since I updated my Hardy Heron to Lucid Lynx I don't manage to make it working.
I have an "unknown tag" error message when converting .rpm to .deb... Then when I run an impression the impression manager tell me that the job is done... but nothing started

P.S. Excuse me if this isn't proper English but I have a very big handicap for speaking foreign languages: I'm French :p

Revision history for this message
Launchpad Janitor (janitor) wrote :

Status changed to 'Confirmed' because the bug affects multiple users.

Changed in cups (Ubuntu):
status: New → Confirmed
Changed in jockey (Ubuntu):
status: New → Confirmed
Revision history for this message
dino99 (9d9) wrote :

Jockey has been superseded by software-properties, which now handles
third-party driver configuration.

Changed in jockey (Ubuntu):
status: Confirmed → Invalid
Revision history for this message
dino99 (9d9) wrote :
Changed in cups (Ubuntu):
status: Confirmed → Fix Released
To post a comment you must log in.
This report contains Public information  
Everyone can see this information.

Other bug subscribers

Bug attachments