Race condition on boot between cups and sssd

Bug #1822062 reported by Victor Tapia on 2019-03-28
10
This bug affects 1 person
Affects Status Importance Assigned to Milestone
cups (Ubuntu)
Status tracked in Eoan
Xenial
Medium
Victor Tapia
Bionic
Medium
Victor Tapia
Cosmic
Medium
Victor Tapia
Disco
Medium
Victor Tapia
Eoan
Medium
Victor Tapia

Bug Description

[Impact]

 * When cups has set the "SystemGroup" directive to an external group provided through sss and cups starts before sssd has finished booting, cups will crash because the group does not exist.

 * The patch adds an "After=sssd.service" clause to the service unit file.

[Test Case]

 * Configure an external authentication service (LDAP, AD...) and create a group, for instance "<email address hidden>"

 * Set SystemGroup to match that group in /etc/cups/cups-files.conf:
SystemGroup <email address hidden>

 * Reboot

 * If cups has started before sssd has finished booting, cups will crash:
Mar 27 10:10:33 cups-sssd cupsd[21463]: Unknown SystemGroup "<email address hidden>" on line 19 of /etc/cups/cups-files.conf.

 * If cups starts after sssd, it will work fine.

[Regression Potential]

 * Minimal: this patch affects just the ordering of the service unit file.

[Other Info]

 * Upstream: https://github.com/apple/cups/commit/4d0f1959a3f46973caec2cd41828c59674fe195d

[Original description]

When cups has set the "SystemGroup" directive to an external group provided through sss and cups starts before sssd has finished booting, cups will crash because the group does not exist. For instance, with a group named <email address hidden> served from Active Directory through sssd, if the sssd service hasn't booted before cups:

Mar 27 10:10:33 cups-sssd systemd[1]: Started CUPS Scheduler.
Mar 27 10:10:33 cups-sssd systemd[1]: Started CUPS Scheduler.
Mar 27 10:10:33 cups-sssd systemd[1]: Started Make remote CUPS printers available locally.
Mar 27 10:10:33 cups-sssd cupsd[21463]: Unknown SystemGroup "<email address hidden>" on line 19 of /etc/cups/cups-files.conf.
Mar 27 10:10:33 cups-sssd cupsd[21463]: Unable to read "/etc/cups/cups-files.conf" due to errors.
Mar 27 10:10:33 cups-sssd systemd[1]: cups.service: Main process exited, code=exited, status=1/FAILURE
Mar 27 10:10:33 cups-sssd systemd[1]: cups.service: Failed with result 'exit-code'.
Mar 27 10:10:33 cups-sssd systemd[1]: cups.service: Service hold-off time over, scheduling restart.
Mar 27 10:10:33 cups-sssd systemd[1]: cups.service: Scheduled restart job, restart counter is at 2.
Mar 27 10:10:33 cups-sssd systemd[1]: Stopping Make remote CUPS printers available locally...
Mar 27 10:10:33 cups-sssd systemd[1]: Stopped Make remote CUPS printers available locally.
Mar 27 10:10:33 cups-sssd systemd[1]: Stopped CUPS Scheduler.

If sssd is running before cups starts, everything works as expected.

Victor Tapia (vtapia) wrote :
description: updated
description: updated
Victor Tapia (vtapia) wrote :
Victor Tapia (vtapia) wrote :
Victor Tapia (vtapia) wrote :
Victor Tapia (vtapia) wrote :
Eric Desrochers (slashd) on 2019-04-24
Changed in cups (Ubuntu Eoan):
importance: Undecided → Medium
status: New → In Progress
assignee: nobody → Victor Tapia (vtapia)
Eric Desrochers (slashd) wrote :

There is a debian->ubuntu sync right now in eoan-proposed.

I'll sponsor it once the actual sync is completed and found in eoan-releases.

Meanwhile, could you please report a bug and forward the patch to debian to make sure the problem is fix to prevent re-introducing the issue at next debian->ubuntu sync/merge.

- Eric

The attachment "eoan-cups.debdiff" seems to be a debdiff. The ubuntu-sponsors team has been subscribed to the bug report so that they can review and hopefully sponsor the debdiff. If the attachment isn't a patch, please remove the "patch" flag from the attachment, remove the "patch" tag, and if you are member of the ~ubuntu-sponsors, unsubscribe the team.

[This is an automated message performed by a Launchpad user owned by ~brian-murray, for any issue please contact him.]

tags: added: patch
Changed in cups (Ubuntu Xenial):
importance: Undecided → Medium
Changed in cups (Ubuntu Bionic):
importance: Undecided → Medium
Changed in cups (Ubuntu Cosmic):
importance: Undecided → Medium
Changed in cups (Ubuntu Disco):
importance: Undecided → Medium
Changed in cups (Ubuntu Disco):
assignee: nobody → Victor Tapia (vtapia)
Changed in cups (Ubuntu Cosmic):
assignee: nobody → Victor Tapia (vtapia)
Changed in cups (Ubuntu Bionic):
assignee: nobody → Victor Tapia (vtapia)
Changed in cups (Ubuntu Xenial):
assignee: nobody → Victor Tapia (vtapia)
Eric Desrochers (slashd) wrote :

Sponsored for 'Eoan'. Let's start the SRU once cups land in eoan-releases (Fix Released).

Thanks Victor !

- Eric

Changed in cups (Ubuntu Eoan):
status: In Progress → Fix Committed
Changed in cups (Ubuntu Disco):
status: New → In Progress
Changed in cups (Ubuntu Cosmic):
status: New → In Progress
Changed in cups (Ubuntu Bionic):
status: New → In Progress
Changed in cups (Ubuntu Xenial):
status: New → In Progress
Launchpad Janitor (janitor) wrote :

This bug was fixed in the package cups - 2.2.10-6ubuntu1

---------------
cups (2.2.10-6ubuntu1) eoan; urgency=medium

  * d/p/systemd-service-for-cupsd-after-sssd.patch: Start cupsd after sssd if
    installed (LP: #1822062)

 -- Victor Tapia <email address hidden> Wed, 24 Apr 2019 17:04:55 +0200

Changed in cups (Ubuntu Eoan):
status: Fix Committed → Fix Released
Eric Desrochers (slashd) wrote :

Sponsored for D/C/B/X.

Thanks Victor !

-Eric

Hello Victor, or anyone else affected,

Accepted cups into disco-proposed. The package will build now and be available at https://launchpad.net/ubuntu/+source/cups/2.2.10-4ubuntu1 in a few hours, and then in the -proposed repository.

Please help us by testing this new package. See https://wiki.ubuntu.com/Testing/EnableProposed for documentation on how to enable and use -proposed. Your feedback will aid us getting this update out to other Ubuntu users.

If this package fixes the bug for you, please add a comment to this bug, mentioning the version of the package you tested and change the tag from verification-needed-disco to verification-done-disco. If it does not fix the bug for you, please add a comment stating that, and change the tag to verification-failed-disco. In either case, without details of your testing we will not be able to proceed.

Further information regarding the verification process can be found at https://wiki.ubuntu.com/QATeam/PerformingSRUVerification . Thank you in advance for helping!

N.B. The updated package will be released to -updates after the bug(s) fixed by this package have been verified and the package has been in -proposed for a minimum of 7 days.

Changed in cups (Ubuntu Disco):
status: In Progress → Fix Committed
tags: added: verification-needed verification-needed-disco
Changed in cups (Ubuntu Cosmic):
status: In Progress → Fix Committed
tags: added: verification-needed-cosmic
Łukasz Zemczak (sil2100) wrote :

Hello Victor, or anyone else affected,

Accepted cups into cosmic-proposed. The package will build now and be available at https://launchpad.net/ubuntu/+source/cups/2.2.8-5ubuntu1.3 in a few hours, and then in the -proposed repository.

Please help us by testing this new package. See https://wiki.ubuntu.com/Testing/EnableProposed for documentation on how to enable and use -proposed. Your feedback will aid us getting this update out to other Ubuntu users.

If this package fixes the bug for you, please add a comment to this bug, mentioning the version of the package you tested and change the tag from verification-needed-cosmic to verification-done-cosmic. If it does not fix the bug for you, please add a comment stating that, and change the tag to verification-failed-cosmic. In either case, without details of your testing we will not be able to proceed.

Further information regarding the verification process can be found at https://wiki.ubuntu.com/QATeam/PerformingSRUVerification . Thank you in advance for helping!

N.B. The updated package will be released to -updates after the bug(s) fixed by this package have been verified and the package has been in -proposed for a minimum of 7 days.

Changed in cups (Ubuntu Bionic):
status: In Progress → Fix Committed
tags: added: verification-needed-bionic
Łukasz Zemczak (sil2100) wrote :

Hello Victor, or anyone else affected,

Accepted cups into bionic-proposed. The package will build now and be available at https://launchpad.net/ubuntu/+source/cups/2.2.7-1ubuntu2.5 in a few hours, and then in the -proposed repository.

Please help us by testing this new package. See https://wiki.ubuntu.com/Testing/EnableProposed for documentation on how to enable and use -proposed. Your feedback will aid us getting this update out to other Ubuntu users.

If this package fixes the bug for you, please add a comment to this bug, mentioning the version of the package you tested and change the tag from verification-needed-bionic to verification-done-bionic. If it does not fix the bug for you, please add a comment stating that, and change the tag to verification-failed-bionic. In either case, without details of your testing we will not be able to proceed.

Further information regarding the verification process can be found at https://wiki.ubuntu.com/QATeam/PerformingSRUVerification . Thank you in advance for helping!

N.B. The updated package will be released to -updates after the bug(s) fixed by this package have been verified and the package has been in -proposed for a minimum of 7 days.

Changed in cups (Ubuntu Xenial):
status: In Progress → Fix Committed
tags: added: verification-needed-xenial
Łukasz Zemczak (sil2100) wrote :

Hello Victor, or anyone else affected,

Accepted cups into xenial-proposed. The package will build now and be available at https://launchpad.net/ubuntu/+source/cups/2.1.3-4ubuntu0.8 in a few hours, and then in the -proposed repository.

Please help us by testing this new package. See https://wiki.ubuntu.com/Testing/EnableProposed for documentation on how to enable and use -proposed. Your feedback will aid us getting this update out to other Ubuntu users.

If this package fixes the bug for you, please add a comment to this bug, mentioning the version of the package you tested and change the tag from verification-needed-xenial to verification-done-xenial. If it does not fix the bug for you, please add a comment stating that, and change the tag to verification-failed-xenial. In either case, without details of your testing we will not be able to proceed.

Further information regarding the verification process can be found at https://wiki.ubuntu.com/QATeam/PerformingSRUVerification . Thank you in advance for helping!

N.B. The updated package will be released to -updates after the bug(s) fixed by this package have been verified and the package has been in -proposed for a minimum of 7 days.

Victor Tapia (vtapia) wrote :
Download full text (5.8 KiB)

# VERIFICATION: XENIAL
- Using the reproducer defined in the test case and the version in -updates:

ubuntu@xenial-sssd-ad:~$ dpkg -l | grep -E "cups-daemon| cups |cups-common"
ii cups 2.1.3-4ubuntu0.7 amd64 Common UNIX Printing System(tm) - PPD/driver support, web interface
ii cups-common 2.1.3-4ubuntu0.7 all Common UNIX Printing System(tm) - common files
ii cups-daemon 2.1.3-4ubuntu0.7 amd64 Common UNIX Printing System(tm) - daemon

ubuntu@xenial-sssd-ad:~$ grep -i systemgroup /etc/cups/cups-files.conf
SystemGroup <email address hidden>

ubuntu@xenial-sssd-ad:~$ systemd-analyze critical-chain cups.service
The time after the unit is active or started is printed after the "@" character.
The time the unit takes to start is printed after the "+" character.

cups.service @5d 44min 12.341s
└─basic.target @35.619s
  └─sockets.target @35.617s
    └─lxd.socket @35.592s +11ms
      └─sysinit.target @35.463s
        └─cloud-init.service @31.929s +3.152s
          └─networking.service @15.375s +16.549s
            └─network-pre.target @15.326s
              └─cloud-init-local.service @6.646s +8.677s
                └─systemd-remount-fs.service @5.484s +342ms
                  └─system.slice @5.461s
                    └─-.slice @5.389s

- After reboot, cups fails to start:

ubuntu@xenial-sssd-ad:~$ systemctl status cups
● cups.service - CUPS Scheduler
   Loaded: loaded (/lib/systemd/system/cups.service; enabled; vendor preset: enabled)
   Active: failed (Result: start-limit-hit) since Tue 2019-05-07 10:06:07 UTC; 1min 57s ago
     Docs: man:cupsd(8)
  Process: 1152 ExecStart=/usr/sbin/cupsd -l (code=exited, status=1/FAILURE)
 Main PID: 1152 (code=exited, status=1/FAILURE)

May 07 10:06:07 xenial-sssd-ad systemd[1]: cups.service: Failed with result 'exit-code'.
May 07 10:06:07 xenial-sssd-ad systemd[1]: Started CUPS Scheduler.
May 07 10:06:07 xenial-sssd-ad cupsd[1152]: Unknown SystemGroup "<email address hidden>" on line 19 of /etc/
May 07 10:06:07 xenial-sssd-ad cupsd[1152]: Unable to read "/etc/cups/cups-files.conf" due to errors.
May 07 10:06:07 xenial-sssd-ad systemd[1]: cups.service: Main process exited, code=exited, status=1/FAILUR
May 07 10:06:07 xenial-sssd-ad systemd[1]: cups.service: Unit entered failed state.
May 07 10:06:07 xenial-sssd-ad systemd[1]: cups.service: Failed with result 'exit-code'.
May 07 10:06:07 xenial-sssd-ad systemd[1]: cups.service: Start request repeated too quickly.
May 07 10:06:07 xenial-sssd-ad systemd[1]: Failed to start CUPS Scheduler.
May 07 10:06:07 xenial-sssd-ad systemd[1]: cups.service: Failed with result 'start-limit-hit'.

- Using the version in -proposed, after rebooting:

ubuntu@xenial-sssd-ad:~$ dpkg -l | grep -E "cups-daemon| cups |cups-common"
ii cups 2.1.3-4ubuntu0.8 amd64 Common UNIX Printing System(tm) - PPD/driver support, web interface
ii cups-common 2.1.3-4ubuntu0.8 all Common UNIX Printing Sys...

Read more...

Victor Tapia (vtapia) wrote :
Download full text (6.1 KiB)

# VERIFICATION: BIONIC
- Using the reproducer defined in the test case and the version in -updates:

ubuntu@bionic-sssd-ad:~$ dpkg -l | grep -E "cups-daemon| cups |cups-common"
ii cups 2.2.7-1ubuntu2.4 amd64 Common UNIX Printing System(tm) - PPD/driver support, web interface
ii cups-common 2.2.7-1ubuntu2.4 all Common UNIX Printing System(tm) - common files
ii cups-daemon 2.2.7-1ubuntu2.4 amd64 Common UNIX Printing System(tm) - daemon

ubuntu@bionic-sssd-ad:~$ grep -i systemgroup /etc/cups/cups-files.conf
SystemGroup <email address hidden>

ubuntu@bionic-sssd-ad:~$ systemd-analyze critical-chain cups.service
The time after the unit is active or started is printed after the "@" character.
The time the unit takes to start is printed after the "+" character.

cups.service @5d 44min 17.034s
└─basic.target @41.538s
  └─sockets.target @41.534s
    └─lxd.socket @41.422s +104ms
      └─sysinit.target @41.320s
        └─systemd-update-utmp.service @40.757s +99ms
          └─systemd-tmpfiles-setup.service @39.550s +1.181s
            └─local-fs.target @13.659s
              └─var-lib-lxcfs.mount @43.131s
                └─local-fs-pre.target @9.991s
                  └─systemd-tmpfiles-setup-dev.service @8.859s +1.127s
                    └─kmod-static-nodes.service @8.510s +303ms
                      └─systemd-journald.socket @8.460s
                        └─system.slice @8.334s
                          └─-.slice @8.326s

- After reboot, cups fails to start:

ubuntu@bionic-sssd-ad:~$ systemctl status cups
● cups.service - CUPS Scheduler
   Loaded: loaded (/lib/systemd/system/cups.service; enabled; vendor preset: enabled)
   Active: failed (Result: exit-code) since Tue 2019-05-07 10:06:32 UTC; 27min ago
     Docs: man:cupsd(8)
  Process: 969 ExecStart=/usr/sbin/cupsd -l (code=exited, status=1/FAILURE)
 Main PID: 969 (code=exited, status=1/FAILURE)

May 07 10:06:32 bionic-sssd-ad systemd[1]: cups.service: Service hold-off time over, scheduling restart.
May 07 10:06:32 bionic-sssd-ad systemd[1]: cups.service: Scheduled restart job, restart counter is at 5.
May 07 10:06:32 bionic-sssd-ad systemd[1]: Stopped CUPS Scheduler.
May 07 10:06:32 bionic-sssd-ad systemd[1]: cups.service: Start request repeated too quickly.
May 07 10:06:32 bionic-sssd-ad systemd[1]: cups.service: Failed with result 'exit-code'.
May 07 10:06:32 bionic-sssd-ad systemd[1]: Failed to start CUPS Scheduler.

ubuntu@bionic-sssd-ad:~$ grep cupsd /var/log/syslog | grep -v kernel
May 7 10:06:30 bionic-sssd-ad cupsd[860]: Unknown SystemGroup "<email address hidden>" on line 19 of /etc/cups/cups-files.conf.
May 7 10:06:30 bionic-sssd-ad cupsd[860]: Unable to read "/etc/cups/cups-files.conf" due to errors.
...

- Using the version in -proposed, after rebooting, cups works fine:

ubuntu@bionic-sssd-ad:~$ dpkg -l | grep -E "cups-daemon| cups |cups-common"
ii cups 2.2.7-1ubuntu2.5 amd64 Common UNIX Printing System(tm) - PPD/driver support, web interface
i...

Read more...

tags: added: verification-done-bionic
removed: verification-needed-bionic
tags: added: verification-needed-bionic verification-xenial
removed: verification-done-bionic verification-needed-xenial

Victor thank you very much for your great verification reports on Xenial and Bionic. I have marked these two as verified now.

tags: added: verification-done-xenial
removed: verification-xenial
Victor Tapia (vtapia) wrote :
Download full text (6.3 KiB)

# VERIFICATION: COSMIC
- Using the reproducer defined in the test case and the version in -updates:

ubuntu@cosmic-sssd-ad:~$ dpkg -l | grep -E "cups-daemon| cups |cups-common"
ii cups 2.2.8-5ubuntu1.2 amd64 Common UNIX Printing System(tm) - PPD/driver support, web interface
ii cups-common 2.2.8-5ubuntu1.2 all Common UNIX Printing System(tm) - common files
ii cups-daemon 2.2.8-5ubuntu1.2 amd64 Common UNIX Printing System(tm) - daemon

ubuntu@cosmic-sssd-ad:~$ grep -i systemgroup /etc/cups/cups-files.conf
SystemGroup <email address hidden>
ubuntu@cosmic-sssd-ad:~$ systemd-analyze critical-chain cups.service
The time after the unit is active or started is printed after the "@" character.
The time the unit takes to start is printed after the "+" character.

cups.service @5d 44min 19.075s
└─basic.target @32.610s
  └─sockets.target @32.602s
    └─snap.lxd.daemon.unix.socket @2min 24.862s
      └─snap-lxd-10601.mount @2min 1.485s +39ms
        └─local-fs-pre.target @8.493s
          └─systemd-tmpfiles-setup-dev.service @8.103s +386ms
            └─systemd-sysusers.service @7.546s +550ms
              └─systemd-remount-fs.service @7.143s +373ms
                └─systemd-journald.socket @7.033s
                  └─-.mount @6.938s
                    └─system.slice @6.938s
                      └─-.slice @6.938s

- After reboot, cups fails to start:

ubuntu@cosmic-sssd-ad:~$ systemctl status cups
● cups.service - CUPS Scheduler
   Loaded: loaded (/lib/systemd/system/cups.service; enabled; vendor preset: enabled)
   Active: failed (Result: exit-code) since Tue 2019-05-07 10:06:49 UTC; 57min ago
     Docs: man:cupsd(8)
  Process: 1173 ExecStart=/usr/sbin/cupsd -l (code=exited, status=1/FAILURE)
 Main PID: 1173 (code=exited, status=1/FAILURE)

May 07 10:06:49 cosmic-sssd-ad systemd[1]: cups.service: Service RestartSec=100ms expired, scheduling rest
May 07 10:06:49 cosmic-sssd-ad systemd[1]: cups.service: Scheduled restart job, restart counter is at 5.
May 07 10:06:49 cosmic-sssd-ad systemd[1]: Stopped CUPS Scheduler.
May 07 10:06:49 cosmic-sssd-ad systemd[1]: cups.service: Start request repeated too quickly.
May 07 10:06:49 cosmic-sssd-ad systemd[1]: cups.service: Failed with result 'exit-code'.
May 07 10:06:49 cosmic-sssd-ad systemd[1]: Failed to start CUPS Scheduler.
ubuntu@cosmic-sssd-ad:~$ grep cupsd /var/log/syslog | grep -v kernel
May 7 10:06:45 cosmic-sssd-ad cupsd[1033]: Unknown SystemGroup "<email address hidden>" on line 19 of /etc/cups/cups-files.conf.
May 7 10:06:45 cosmic-sssd-ad cupsd[1033]: Unable to read "/etc/cups/cups-files.conf" due to errors.
May 7 10:06:47 cosmic-sssd-ad cupsd[1122]: Unknown SystemGroup "<email address hidden>" on line 19 of /etc/cups/cups-files.conf.
May 7 10:06:47 cosmic-sssd-ad cupsd[1122]: Unable to read "/etc/cups/cups-files.conf" due to errors.
...

- Using the version in -proposed, after rebooting, cups works fine:

ubuntu@cosmic-sssd-ad:~$ dpkg -l | grep -E "cups-daemon| cups |cups-common"
ii cups 2.2.8-5ubuntu1.3 ...

Read more...

tags: added: verification-done-bionic
removed: verification-needed-bionic
tags: added: verification-done-cosmic
removed: verification-needed-cosmic
Victor Tapia (vtapia) wrote :
Download full text (6.5 KiB)

# VERIFICATION: DISCO
- Using the reproducer defined in the test case and the version in -updates:

ubuntu@disco-sssd-ad:~$ dpkg -l | grep -E "cups-daemon| cups |cups-common"
ii cups 2.2.10-4 amd64 Common UNIX Printing System(tm) - PPD/driver support, web interface
ii cups-common 2.2.10-4 all Common UNIX Printing System(tm) - common files
ii cups-daemon 2.2.10-4 amd64 Common UNIX Printing System(tm) - daemon

ubuntu@disco-sssd-ad:~$ grep -i systemgroup /etc/cups/cups-files.conf
SystemGroup <email address hidden>
ubuntu@disco-sssd-ad:~$ systemd-analyze critical-chain cups.service
The time after the unit is active or started is printed after the "@" character.
The time the unit takes to start is printed after the "+" character.

cups.service +161ms
└─cups.socket @46.229s
  └─sysinit.target @42.682s
    └─cloud-init.service @37.411s +5.239s
      └─systemd-networkd-wait-online.service @35.640s +1.727s
        └─systemd-networkd.service @35.419s +189ms
          └─network-pre.target @35.415s
            └─cloud-init-local.service @21.419s +13.992s
              └─systemd-remount-fs.service @7.277s +570ms
                └─systemd-journald.socket @7.070s
                  └─system.slice @6.915s
                    └─-.slice @6.915s

- After reboot, cups fails to start:

ubuntu@disco-sssd-ad:~$ systemctl status cups
● cups.service - CUPS Scheduler
   Loaded: loaded (/lib/systemd/system/cups.service; enabled; vendor preset: enabled)
   Active: failed (Result: exit-code) since Tue 2019-05-07 11:12:09 UTC; 16min ago
     Docs: man:cupsd(8)
  Process: 747 ExecStart=/usr/sbin/cupsd -l (code=exited, status=1/FAILURE)
 Main PID: 747 (code=exited, status=1/FAILURE)

May 07 11:12:09 disco-sssd-ad systemd[1]: Stopped CUPS Scheduler.
May 07 11:12:09 disco-sssd-ad systemd[1]: Started CUPS Scheduler.
May 07 11:12:09 disco-sssd-ad systemd[1]: cups.service: Main process exited, code=exited, status=1/FAILURE
May 07 11:12:09 disco-sssd-ad systemd[1]: cups.service: Failed with result 'exit-code'.
May 07 11:12:09 disco-sssd-ad systemd[1]: cups.service: Service RestartSec=100ms expired, scheduling resta
May 07 11:12:09 disco-sssd-ad systemd[1]: cups.service: Scheduled restart job, restart counter is at 5.
May 07 11:12:09 disco-sssd-ad systemd[1]: Stopped CUPS Scheduler.
May 07 11:12:09 disco-sssd-ad systemd[1]: cups.service: Start request repeated too quickly.
May 07 11:12:09 disco-sssd-ad systemd[1]: cups.service: Failed with result 'exit-code'.
May 07 11:12:09 disco-sssd-ad systemd[1]: Failed to start CUPS Scheduler.

ubuntu@disco-sssd-ad:~$ grep cupsd /var/log/syslog | grep -v kernel
May 7 11:12:10 disco-sssd-ad cupsd[692]: Unknown SystemGroup "<email address hidden>" on line 19 of /etc/cups/cups-files.conf.
May 7 11:12:10 disco-sssd-ad cupsd[692]: Unable to read "/etc/cups/cups-files.conf" due to errors.
May 7 11:12:10 disco-sssd-ad cupsd[721]: Unknown SystemGroup "<email address hidden>" on line 19 of /etc/cups/cups-files.conf.
...

- Using the version in -proposed, after rebooting, cups...

Read more...

Victor Tapia (vtapia) on 2019-05-07
tags: added: verification-done verification-done-disco
removed: verification-needed verification-needed-disco

Thank you, Victor, for all the verifications and the nice reports for each of them!

Łukasz Zemczak (sil2100) wrote :

Some of the cups SRUs have some ADT failures reported for them, but from what I see most are just testbed/infrastructure issues. I have re-ran the tests for now - let's look into releasing this later today once the re-runs are finished.

Eric Desrochers (slashd) wrote :

I re-run a few test myselfs, and was able to clean them up.
Only remaining blocker is the FTBFS situation in Xenial for s390x arch which seems to fails at override_dh_auto_test.

# Pending SRU:
cups
s390x: Failed to build
https://launchpadlibrarian.net/423558504/buildlog_ubuntu-xenial-s390x.cups_2.1.3-4ubuntu0.8_BUILDING.txt.gz

Eric Desrochers (slashd) wrote :

FAIL: 12 warning messages, expected 8.
W [13/May/2019:13:53:19.857395 +0000] No JobPrivateAccess defined in policy default - using defaults.
W [13/May/2019:13:53:19.857412 +0000] No JobPrivateValues defined in policy default - using defaults.
W [13/May/2019:13:53:19.857428 +0000] No SubscriptionPrivateAccess defined in policy default - using defaults.
W [13/May/2019:13:53:19.857443 +0000] No SubscriptionPrivateValues defined in policy default - using defaults.
W [13/May/2019:13:53:30.125242 +0000] [Job 7] temp file: can\'t find PDF header
W [13/May/2019:13:53:30.125347 +0000] [Job 7] temp file: file is damaged
W [13/May/2019:13:53:30.125422 +0000] [Job 7] temp file: can\'t find startxref
W [13/May/2019:13:53:30.125486 +0000] [Job 7] temp file: Attempting to reconstruct cross-reference table
W [13/May/2019:13:53:46.287322 +0000] No JobPrivateAccess defined in policy default - using defaults.
W [13/May/2019:13:53:46.287338 +0000] No JobPrivateValues defined in policy default - using defaults.
W [13/May/2019:13:53:46.287355 +0000] No SubscriptionPrivateAccess defined in policy default - using defaults.
W [13/May/2019:13:53:46.287372 +0000] No SubscriptionPrivateValues defined in policy default - using defaults.

Launchpad Janitor (janitor) wrote :

This bug was fixed in the package cups - 2.2.10-4ubuntu1

---------------
cups (2.2.10-4ubuntu1) disco; urgency=medium

  * d/p/systemd-service-for-cupsd-after-sssd.patch: Start cupsd after sssd if
    installed (LP: #1822062)

 -- Victor Tapia <email address hidden> Wed, 24 Apr 2019 17:02:49 +0200

Changed in cups (Ubuntu Disco):
status: Fix Committed → Fix Released

The verification of the Stable Release Update for cups has completed successfully and the package has now been released to -updates. Subsequently, the Ubuntu Stable Release Updates Team is being unsubscribed and will not receive messages about this bug report. In the event that you encounter a regression using the package from -updates please report a new bug using ubuntu-bug and tag the bug report regression-update so we can easily find any regressions.

Launchpad Janitor (janitor) wrote :

This bug was fixed in the package cups - 2.2.8-5ubuntu1.3

---------------
cups (2.2.8-5ubuntu1.3) cosmic; urgency=medium

  * d/p/systemd-service-for-cupsd-after-sssd.patch: Start cupsd after sssd if
    installed (LP: #1822062)

 -- Victor Tapia <email address hidden> Wed, 24 Apr 2019 17:21:13 +0200

Changed in cups (Ubuntu Cosmic):
status: Fix Committed → Fix Released
Launchpad Janitor (janitor) wrote :

This bug was fixed in the package cups - 2.2.7-1ubuntu2.5

---------------
cups (2.2.7-1ubuntu2.5) bionic; urgency=medium

  * d/p/systemd-service-for-cupsd-after-sssd.patch: Start cupsd after sssd if
    installed (LP: #1822062)

 -- Victor Tapia <email address hidden> Wed, 24 Apr 2019 16:58:30 +0200

Changed in cups (Ubuntu Bionic):
status: Fix Committed → Fix Released
Launchpad Janitor (janitor) wrote :

This bug was fixed in the package cups - 2.1.3-4ubuntu0.8

---------------
cups (2.1.3-4ubuntu0.8) xenial; urgency=medium

  * d/p/systemd-service-for-cupsd-after-sssd.patch: Start cupsd after sssd if
    installed (LP: #1822062)

 -- Victor Tapia <email address hidden> Tue, 23 Apr 2019 17:44:19 +0200

Changed in cups (Ubuntu Xenial):
status: Fix Committed → Fix Released
To post a comment you must log in.
This report contains Public information  Edit
Everyone can see this information.

Other bug subscribers