Update to cups-daemon 2.1.3-4ubuntu0.2 results in maintainer script failures

Bug #1676380 reported by Frode Nordahl on 2017-03-27
76
This bug affects 16 people
Affects Status Importance Assigned to Milestone
cups (Ubuntu)
Critical
Dimitri John Ledkov
Xenial
Undecided
Unassigned

Bug Description

Even though LP: #1642966 states that this is now fixed, the very update that was SRU'ed in that bug-report caused this error just now.

ProblemType: Package
DistroRelease: Ubuntu 16.04
Package: cups-daemon 2.1.3-4
ProcVersionSignature: Ubuntu 4.10.0-13.15~16.04.2-generic 4.10.1
Uname: Linux 4.10.0-13-generic x86_64
ApportVersion: 2.20.1-0ubuntu2.5
Architecture: amd64
CupsErrorLog:

Date: Mon Mar 27 12:53:31 2017
ErrorMessage: subprocess new pre-removal script returned error exit status 1
InstallationDate: Installed on 2017-03-15 (11 days ago)
InstallationMedia: Ubuntu 16.04.2 LTS "Xenial Xerus" - Release amd64 (20170215.2)
Lpstat: device for iP5200R: usb://Canon/iP5200R?serial=9045C0
MachineType: Dell Inc. Precision 5520
Papersize: a4
PpdFiles: iP5200R: Canon iP5200R series - CUPS+Gutenprint v5.2.11
ProcCmdline: BOOT_IMAGE=/vmlinuz-4.10.0-13-generic root=/dev/mapper/ubuntu--vg-root ro quiet splash acpi_rev_override vt.handoff=7
ProcKernelCmdLine: BOOT_IMAGE=/vmlinuz-4.10.0-13-generic root=/dev/mapper/ubuntu--vg-root ro quiet splash acpi_rev_override vt.handoff=7
RelatedPackageVersions:
 dpkg 1.18.4ubuntu1.1
 apt 1.2.19
SourcePackage: cups
Title: package cups-daemon 2.1.3-4 failed to install/upgrade: subprocess new pre-removal script returned error exit status 1
UpgradeStatus: No upgrade log present (probably fresh install)
dmi.bios.date: 01/18/2017
dmi.bios.vendor: Dell Inc.
dmi.bios.version: 1.1.3
dmi.board.name: 06X96V
dmi.board.vendor: Dell Inc.
dmi.board.version: A00
dmi.chassis.type: 10
dmi.chassis.vendor: Dell Inc.
dmi.modalias: dmi:bvnDellInc.:bvr1.1.3:bd01/18/2017:svnDellInc.:pnPrecision5520:pvr:rvnDellInc.:rn06X96V:rvrA00:cvnDellInc.:ct10:cvr:
dmi.product.name: Precision 5520
dmi.sys.vendor: Dell Inc.

Frode Nordahl (fnordahl) wrote :
description: updated
Robie Basak (racb) on 2017-03-27
tags: added: regression-update
Frode Nordahl (fnordahl) on 2017-03-27
summary: - package cups-daemon 2.1.3-4 failed to install/upgrade: subprocess new
- pre-removal script returned error exit status 1
+ [still occurs with package version 2.1.3-4ubuntu0.2] package cups-daemon
+ 2.1.3-4 failed to install/upgrade: subprocess new pre-removal script
+ returned error exit status 1

Status changed to 'Confirmed' because the bug affects multiple users.

Changed in cups (Ubuntu):
status: New → Confirmed
Robie Basak (racb) on 2017-03-27
summary: - [still occurs with package version 2.1.3-4ubuntu0.2] package cups-daemon
- 2.1.3-4 failed to install/upgrade: subprocess new pre-removal script
- returned error exit status 1
+ Update to cups-daemon 2.1.3-4ubuntu0.2 results in maintainer script
+ failures
Changed in cups (Ubuntu):
status: Confirmed → Triaged
importance: Undecided → Critical
Robie Basak (racb) wrote :

Thank you for the report.

cups 2.1.3-4ubuntu0.2 has now been removed. I have reopened bug 1642966, which tracks the original problem. I'll use this bug to track occurrences of the problem caused by the publication of 2.1.3-4ubuntu0.2. New occurrences caused by this publication should stop shortly. Bug 1642966 remains open to track the original problem.

Changed in cups (Ubuntu):
status: Triaged → Fix Released
Frode Nordahl (fnordahl) wrote :

Thank you back for swift action on this, making us all look good :-)

Adam Conrad (adconrad) wrote :

So, if old prerm is failing on a bad unit, then new prerm is attempted. New prerm should be written in a way that it skips/ignores the failure.

Changed in cups (Ubuntu):
assignee: nobody → Dimitri John Ledkov (xnox)
status: Fix Released → Confirmed
tags: removed: need-duplicate-check
Launchpad Janitor (janitor) wrote :

Status changed to 'Confirmed' because the bug affects multiple users.

Changed in cups (Ubuntu Xenial):
status: New → Confirmed
Changed in cups (Ubuntu):
milestone: none → ubuntu-17.06
Till Kamppeter (till-kamppeter) wrote :

Discussion about that problem is going on in bug 1642966. There is also a fix suggested. Marking this one as duplicate.

To post a comment you must log in.
This report contains Public information  Edit
Everyone can see this information.

Other bug subscribers