Error with cups-daemon package when reinstalling many packages to recover wireless connection with QCA9377

Bug #1665432 reported by Leonardo Müller on 2017-02-16
6
This bug affects 1 person
Affects Status Importance Assigned to Milestone
cups (Ubuntu)
Undecided
Unassigned

Bug Description

I had a issue with my Wireless and Bluetooth card, Qualcomm Atheros Device [168c:0042] (rev 30), which appears on Windows 10 as QCA9377, and to solve it I have searched and tried different alternatives. The one that worked was to reinstall many packages, all the ones I have found when searching for, firstly, "wireless", then "wifi" and then "internet", on synaptic. When doing the "internet" reinstall, a error happened on cups-daemon and it crashed. When I tried again, it worked. I rebooted the computer and the Wireless is functioning again (Bluetooth was already OK).

I am using the Kernel 4.9.10-040910-generic from http://kernel.ubuntu.com/~kernel-ppa/mainline/v4.9.10/ because I was trying to solve this issue and because the official Kernles 4.4 and 4.8 don't eject external HDDs from the USB 3.0 correctly. The notebook model is Lenovo Ideapad 310-14ISK.

While this window to report the bug appeared saying cups is the culprit, all this only happened because the wireless device QCA9377 was not working.

usuario@usuario-Lenovo-ideapad-310-14ISK:~$ lsb_release -rd
Description: Ubuntu 16.04.2 LTS
Release: 16.04

usuario@usuario-Lenovo-ideapad-310-14ISK:~$ uname -a
Linux usuario-Lenovo-ideapad-310-14ISK 4.9.10-040910-generic #201702141931 SMP Wed Feb 15 00:33:24 UTC 2017 x86_64 x86_64 x86_64 GNU/Linux

I hope this information may be helpful.

ProblemType: Package
DistroRelease: Ubuntu 16.04
Package: cups-daemon 2.1.3-4
Uname: Linux 4.9.10-040910-generic x86_64
ApportVersion: 2.20.1-0ubuntu2.5
Architecture: amd64
CupsErrorLog: W [16/Feb/2017:14:42:01 -0200] Notifier for subscription 298 (dbus://) went away, retrying!
Date: Thu Feb 16 16:05:14 2017
ErrorMessage: sub-processo novo script pre-removal retornou estado de saída de erro 1
InstallationDate: Installed on 2016-12-31 (47 days ago)
InstallationMedia: Xubuntu 16.04.1 LTS "Xenial Xerus" - Release amd64 (20160719)
Lpstat: device for Deskjet-2050-J510-series: hp:/usb/Deskjet_2050_J510_series?serial=BR1C1FK1K005D1
MachineType: LENOVO 80UG
Papersize: a4
PpdFiles: Deskjet-2050-J510-series: HP Deskjet 2050 j510 Series, hpcups 3.16.3
ProcCmdline: BOOT_IMAGE=/boot/vmlinuz-4.9.10-040910-generic root=UUID=0fbb0f28-6764-4447-a890-dc966d1f8adf ro
ProcKernelCmdLine: BOOT_IMAGE=/boot/vmlinuz-4.9.10-040910-generic root=UUID=0fbb0f28-6764-4447-a890-dc966d1f8adf ro
RelatedPackageVersions:
 dpkg 1.18.4ubuntu1.1
 apt 1.2.19
SourcePackage: cups
Title: package cups-daemon 2.1.3-4 failed to install/upgrade: sub-processo novo script pre-removal retornou estado de saída de erro 1
UpgradeStatus: No upgrade log present (probably fresh install)
dmi.bios.date: 10/03/2016
dmi.bios.vendor: LENOVO
dmi.bios.version: 0XCN37WW
dmi.board.asset.tag: NO Asset Tag
dmi.board.name: Toronto 4A2
dmi.board.vendor: LENOVO
dmi.board.version: SDK0J40679 WIN
dmi.chassis.asset.tag: NO Asset Tag
dmi.chassis.type: 10
dmi.chassis.vendor: LENOVO
dmi.chassis.version: Lenovo ideapad 310-14ISK
dmi.modalias: dmi:bvnLENOVO:bvr0XCN37WW:bd10/03/2016:svnLENOVO:pn80UG:pvrLenovoideapad310-14ISK:rvnLENOVO:rnToronto4A2:rvrSDK0J40679WIN:cvnLENOVO:ct10:cvrLenovoideapad310-14ISK:
dmi.product.name: 80UG
dmi.product.version: Lenovo ideapad 310-14ISK
dmi.sys.vendor: LENOVO

To post a comment you must log in.
This report contains Public information  Edit
Everyone can see this information.

Other bug subscribers