package cups-daemon 2.1.3-4 failed to install/upgrade: subprocess new pre-removal script returned error exit status 1

Bug #1642790 reported by Mike on 2016-11-18
84
This bug affects 20 people
Affects Status Importance Assigned to Milestone
cups (Ubuntu)
Undecided
Unassigned

Bug Description

occurred during upgrade

ProblemType: Package
DistroRelease: Ubuntu 16.04
Package: cups-daemon 2.1.3-4
ProcVersionSignature: Ubuntu 4.4.0-47.68-generic 4.4.24
Uname: Linux 4.4.0-47-generic x86_64
ApportVersion: 2.20.1-0ubuntu2.1
Architecture: amd64
CupsErrorLog:

Date: Thu Nov 17 20:46:19 2016
ErrorMessage: subprocess new pre-removal script returned error exit status 1
InstallationDate: Installed on 2015-06-11 (525 days ago)
InstallationMedia: Ubuntu 15.04 "Vivid Vervet" - Release amd64 (20150422)
Lpstat: device for HP-Officejet-Pro-8600: socket://192.168.1.9:9100
MachineType: Gigabyte Technology Co., Ltd. GA-990FXA-UD5
Papersize: letter
PpdFiles: HP-Officejet-Pro-8600: HP Officejet Pro 8600, hpcups 3.16.3
ProcCmdline: BOOT_IMAGE=/boot/vmlinuz-4.4.0-47-generic root=UUID=acc6d16a-821d-416e-b8c5-8eb389d3a212 ro quiet splash nomdmonddf nomdmonisw nomdmonddf nomdmonisw nomdmonddf nomdmonisw vt.handoff=7
ProcKernelCmdLine: BOOT_IMAGE=/boot/vmlinuz-4.4.0-47-generic root=UUID=acc6d16a-821d-416e-b8c5-8eb389d3a212 ro quiet splash nomdmonddf nomdmonisw nomdmonddf nomdmonisw nomdmonddf nomdmonisw vt.handoff=7
RelatedPackageVersions:
 dpkg 1.18.4ubuntu1.1
 apt 1.2.15
SourcePackage: cups
Title: package cups-daemon 2.1.3-4 failed to install/upgrade: subprocess new pre-removal script returned error exit status 1
UpgradeStatus: No upgrade log present (probably fresh install)
dmi.bios.date: 10/03/2013
dmi.bios.vendor: Award Software International, Inc.
dmi.bios.version: F12
dmi.board.name: GA-990FXA-UD5
dmi.board.vendor: Gigabyte Technology Co., Ltd.
dmi.board.version: x.x
dmi.chassis.type: 3
dmi.chassis.vendor: Gigabyte Technology Co., Ltd.
dmi.modalias: dmi:bvnAwardSoftwareInternational,Inc.:bvrF12:bd10/03/2013:svnGigabyteTechnologyCo.,Ltd.:pnGA-990FXA-UD5:pvr:rvnGigabyteTechnologyCo.,Ltd.:rnGA-990FXA-UD5:rvrx.x:cvnGigabyteTechnologyCo.,Ltd.:ct3:cvr:
dmi.product.name: GA-990FXA-UD5
dmi.sys.vendor: Gigabyte Technology Co., Ltd.

Mike (mediabot666) wrote :
Mike (mediabot666) wrote :

The system is now reporting

Building dependency tree
Reading state information... Done
You might want to run 'apt-get -f install' to correct these.
The following packages have unmet dependencies:
 cups : Depends: cups-daemon (>= 2.1.3-4ubuntu0.1)
 cups-core-drivers : Depends: cups-daemon (>= 2.1.3-4ubuntu0.1)
 cups-daemon : Depends: libcups2 (= 2.1.3-4) but 2.1.3-4ubuntu0.1 is installed
E: Unmet dependencies. Try using -f.

Launchpad Janitor (janitor) wrote :

Status changed to 'Confirmed' because the bug affects multiple users.

Changed in cups (Ubuntu):
status: New → Confirmed
Daniel Fleck (danielfleck) wrote :

-f works for me.

Stefano Longano (slongano) wrote :

apt-get -f install solved the problem for me

vensires (vensires) wrote :

-f worked for me too.

Amitabh (amitabh123) wrote :

-f does not work for me

sudo apt -f install cups

Reading package lists... Done
Building dependency tree
Reading state information... Done
Some packages could not be installed. This may mean that you have
requested an impossible situation or if you are using the unstable
distribution that some required packages have not yet been created
or been moved out of Incoming.
The following information may help to resolve the situation:

The following packages have unmet dependencies:
 cups : Depends: libcups2 (= 2.1.3-4) but 2.1.3-4ubuntu0.1 is to be installed
        Recommends: printer-driver-gutenprint but it is not going to be installed
E: Unable to correct problems, you have held broken packages.

Using Ubuntu 16.04

Robert Bernath (y-robert) wrote :

-f does not work for me

sudo apt -f install cups
Reading package lists... Done
Building dependency tree
Reading state information... Done
Some packages could not be installed. This may mean that you have
requested an impossible situation or if you are using the unstable
distribution that some required packages have not yet been created
or been moved out of Incoming.
The following information may help to resolve the situation:

The following packages have unmet dependencies:
 cups : Depends: libcups2 (= 2.1.3-4) but 2.1.3-4ubuntu0.2 is to be installed
        Depends: libcupscgi1 (>= 1.4.2) but it is not going to be installed
        Depends: libcupsmime1 (>= 1.4.0) but it is not going to be installed
        Depends: cups-core-drivers (>= 2.1.3-4) but it is not going to be installed
        Depends: cups-daemon (>= 2.1.3-4) but it is not going to be installed
        Recommends: printer-driver-gutenprint but it is not going to be installed
E: Unable to correct problems, you have held broken packages.

with Ubuntu 16.04

To post a comment you must log in.
This report contains Public information  Edit
Everyone can see this information.

Other bug subscribers