cupsd assert failure: cupsd: entrygroup.c:245: avahi_entry_group_free: Assertion `*_head == _item' failed.

Bug #1495276 reported by David Oxland on 2015-09-13
74
This bug affects 16 people
Affects Status Importance Assigned to Milestone
cups (Ubuntu)
Medium
Unassigned

Bug Description

This crash just appeared during startup.
Lots of CUPS updates and errors lately.
 Printer and scanner have worked mostly one way or the other using different apps.

ProblemType: Crash
DistroRelease: Ubuntu 15.10
Package: cups-daemon 2.1.0-1
ProcVersionSignature: Ubuntu 4.2.0-7.7-generic 4.2.0
Uname: Linux 4.2.0-7-generic x86_64
NonfreeKernelModules: fglrx
ApportVersion: 2.18.1-0ubuntu1
Architecture: amd64
AssertionMessage: cupsd: entrygroup.c:245: avahi_entry_group_free: Assertion `*_head == _item' failed.
CrashCounter: 1
Date: Sat Sep 12 22:57:48 2015
ExecutablePath: /usr/sbin/cupsd
InstallationDate: Installed on 2015-01-29 (226 days ago)
InstallationMedia: Ubuntu 14.04 LTS "Trusty Tahr" - Release amd64 (20140417)
Lpstat:
 device for Brother-DCP-7065DN: dnssd://Brother%20DCP-7065DN._pdl-datastream._tcp.local/
 device for Brother-DCP-7065DN-2: dnssd://Brother%20DCP-7065DN._pdl-datastream._tcp.local/
 device for david@david-Lenovo-H535: dnssd://Brother%20DCP-7065DN._pdl-datastream._tcp.local/
 device for PDF: cups-pdf:/
MachineType: LENOVO 10117
Papersize: letter
PpdFiles:
 david@david-Lenovo-H535: Brother DCP-7065DN, using brlaser v3
 PDF: Generic CUPS-PDF Printer
 Brother-DCP-7065DN-2: Brother DCP-7065DN, using brlaser v3
 Brother-DCP-7065DN: Brother DCP-7065DN, using brlaser v3
ProcAttrCurrent: /usr/sbin/cupsd (enforce)
ProcCmdline: BOOT_IMAGE=/boot/vmlinuz-4.2.0-7-generic root=UUID=94709fac-8bfa-41bf-8d29-24abdd9f77cc ro drm.debug=0xe plymouth:debug
ProcEnviron:
 LANG=en_CA.UTF-8
 LANGUAGE=en_CA:en
 PATH=(custom, no user)
ProcKernelCmdLine: BOOT_IMAGE=/boot/vmlinuz-4.2.0-7-generic root=UUID=94709fac-8bfa-41bf-8d29-24abdd9f77cc ro drm.debug=0xe plymouth:debug
Signal: 6
SourcePackage: cups
StacktraceTop:
 __assert_fail_base (fmt=0x7fed6ded1028 "%s%s%s:%u: %s%sAssertion `%s' failed.\n%n", assertion=assertion@entry=0x7fed6e80d132 "*_head == _item", file=file@entry=0x7fed6e80d117 "entrygroup.c", line=line@entry=245, function=function@entry=0x7fed6e80d3b0 "avahi_entry_group_free") at assert.c:92
 __GI___assert_fail (assertion=0x7fed6e80d132 "*_head == _item", file=0x7fed6e80d117 "entrygroup.c", line=245, function=0x7fed6e80d3b0 "avahi_entry_group_free") at assert.c:101
 avahi_entry_group_free () from /usr/lib/x86_64-linux-gnu/libavahi-client.so.3
 ?? ()
 ?? ()
Title: cupsd assert failure: cupsd: entrygroup.c:245: avahi_entry_group_free: Assertion `*_head == _item' failed.
UpgradeStatus: No upgrade log present (probably fresh install)
UserGroups:

dmi.bios.date: 11/05/2013
dmi.bios.vendor: LENOVO
dmi.bios.version: I7KT31AUS
dmi.board.vendor: LENOVO
dmi.board.version: 31900058 STD
dmi.chassis.type: 3
dmi.chassis.vendor: LENOVO
dmi.modalias: dmi:bvnLENOVO:bvrI7KT31AUS:bd11/05/2013:svnLENOVO:pn10117:pvrLenovoH535:rvnLENOVO:rn:rvr31900058STD:cvnLENOVO:ct3:cvr:
dmi.product.name: 10117
dmi.product.version: Lenovo H535
dmi.sys.vendor: LENOVO
modified.conffile..etc.default.cups:
 # Cups configure options

 # LOAD_LP_MODULE: enable/disable to load "lp" parallel printer driver module
 # LOAD_LP_MODULE has migrated to /etc/modules-load.d/cups-filters.conf
 # LOAD_LP_MODULE=yes
mtime.conffile..etc.default.cups: 2014-04-16T18:25:57

David Oxland (doxland) wrote :

StacktraceTop:
 __assert_fail_base (fmt=0x7fed6ded1028 "%s%s%s:%u: %s%sAssertion `%s' failed.\n%n", assertion=assertion@entry=0x7fed6e80d132 "*_head == _item", file=file@entry=0x7fed6e80d117 "entrygroup.c", line=line@entry=245, function=function@entry=0x7fed6e80d3b0 "avahi_entry_group_free") at assert.c:92
 __GI___assert_fail (assertion=0x7fed6e80d132 "*_head == _item", file=0x7fed6e80d117 "entrygroup.c", line=245, function=0x7fed6e80d3b0 "avahi_entry_group_free") at assert.c:101
 avahi_entry_group_free () from /tmp/apport_sandbox_ge9Ymp/usr/lib/x86_64-linux-gnu/libavahi-client.so.3
 dnssdDeregisterInstance (srv=0x5613a662d9d0, from_callback=<optimized out>) at dirsvc.c:684
 dnssdDeregisterPrinter (p=0x5613a662d230, clear_name=clear_name@entry=1, from_callback=from_callback@entry=1) at dirsvc.c:711

Changed in cups (Ubuntu):
importance: Undecided → Medium
tags: removed: need-amd64-retrace
information type: Private → Public
David Oxland (doxland) wrote :

Happening every boot.
No impediment.

Till Kamppeter (till-kamppeter) wrote :

Reported to CUPS upstream as https://www.cups.org/str.php?L4719

Launchpad Janitor (janitor) wrote :

Status changed to 'Confirmed' because the bug affects multiple users.

Changed in cups (Ubuntu):
status: New → Confirmed
VOIRIN ERIC (evoirin-9) on 2015-09-20
Changed in cups (Ubuntu):
assignee: nobody → VOIRIN ERIC (evoirin-9)
tags: added: xenial
Leo Milano (lmilano) wrote :

I guess this is obvious. But this bug still happens in Xenial.

####
lmilano@grisell:~$ cat /etc/lsb-release
DISTRIB_ID=Ubuntu
DISTRIB_RELEASE=16.04
DISTRIB_CODENAME=xenial
DISTRIB_DESCRIPTION="Ubuntu 16.04.2 LTS"
####
####
lmilano@grisell:~$ dpkg -l |grep cups-client
ii cups-client 2.1.3-4 amd64 Common UNIX Printing System(tm) - client programs (SysV)
####

Another attempt of upstream bug report: https://github.com/apple/cups/issues/5085

Changed in cups (Ubuntu):
status: Confirmed → Fix Committed

Fixed in CUPS 2.2.4-4.

Changed in cups (Ubuntu):
status: Fix Committed → Fix Released
Steve Langasek (vorlon) wrote :

This bug was asserted fixed in 2.2.4-4, but I just had a crash with 2.2.4-7ubuntu2 in Ubuntu 17.10 that was reported to be a duplicate of this issue.

Changed in cups (Ubuntu):
status: Fix Released → Triaged
assignee: VOIRIN ERIC (evoirin-9) → nobody
Olaf Seibert (rhialto) wrote :

Yes, I have this at every boot with Xubuntu 17.10 too.

To post a comment you must log in.
This report contains Public information  Edit
Everyone can see this information.

Duplicates of this bug

Other bug subscribers

Remote bug watches

Bug watches keep track of this bug in other bug trackers.