13.10 acroread and evince print only first page of document [SOLVED]

Bug #1247935 reported by peterthevicar
16
This bug affects 3 people
Affects Status Importance Assigned to Milestone
cups (Ubuntu)
Undecided
Unassigned

Bug Description

Since upgrading to 1.7.0~rc1-0ubuntu5 acroread and evince print only the first page of a multi-page document. Downgrading to raring (1.6.1-1ubuntu5) restores correct operation.

Lines in the error log when not working:
D [04/Nov/2013:17:51:18 +0000] cupsdSetBusyState: newbusy="Printing jobs and dirty files", busy="Printing jobs and dirty files"
D [04/Nov/2013:17:51:18 +0000] [Job 480] Set job-printer-state-message to "Formatting page 1.", current level=INFO
D [04/Nov/2013:17:51:18 +0000] Discarding unused job-progress event...
D [04/Nov/2013:17:51:18 +0000] Discarding unused printer-state-changed event...
D [04/Nov/2013:17:51:18 +0000] [Job 480] Writing 19 leading blank lines...
D [04/Nov/2013:17:51:18 +0000] [Job 480] Read 8192 bytes of print data...
D [04/Nov/2013:17:51:18 +0000] [Job 480] Wrote 8192 bytes of print data...
D [04/Nov/2013:17:51:18 +0000] [Job 480] Read 8192 bytes of print data...
....
D [04/Nov/2013:17:51:28 +0000] [Job 480] Writing 20 trailing blank lines...
D [04/Nov/2013:17:51:28 +0000] [Job 480] PID 9423 (/usr/lib/cups/filter/imagetoraster) exited with no errors.
D [04/Nov/2013:17:51:29 +0000] [Job 480] Wrote 8192 bytes of print data...
...
D [04/Nov/2013:17:51:32 +0000] [Job 480] Read 8192 bytes of print data...
D [04/Nov/2013:17:51:32 +0000] [Job 480] PID 9424 (/opt/epson-inkjet-printer-workforce-635-nx625-series/cups/lib/filter/epson_inkjet_printer_filter) exited with no errors.
D [04/Nov/2013:17:51:32 +0000] [Job 480] Wrote 8192 bytes of print data...
...
D [04/Nov/2013:17:51:32 +0000] [Job 480] Sent 1485448 bytes...
D [04/Nov/2013:17:51:32 +0000] [Job 480] Waiting for read thread to exit...
D [04/Nov/2013:17:51:32 +0000] [Job 480] PID 9425 (/usr/lib/cups/backend/usb) exited with no errors.

Whereas the similar section of the log with the raring version reads:
D [04/Nov/2013:18:32:32 +0000] cupsdSetBusyState: newbusy="Printing jobs and dirty files", busy="Printing jobs and dirty files"
D [04/Nov/2013:18:32:32 +0000] [Job 485] Set job-printer-state-message to "Processing page 1...", current level=INFO
D [04/Nov/2013:18:32:32 +0000] Discarding unused job-progress event...
D [04/Nov/2013:18:32:32 +0000] Discarding unused printer-state-changed event...
D [04/Nov/2013:18:32:36 +0000] [Job 485] Read 8192 bytes of print data...
D [04/Nov/2013:18:32:36 +0000] [Job 485] Wrote 8192 bytes of print data...
D [04/Nov/2013:18:32:36 +0000] [Job 485] Read 8192 bytes of print data...
D [04/Nov/2013:18:32:36 +0000] [Job 485] Wrote 8192 bytes of print data...
...
D [04/Nov/2013:18:32:53 +0000] [Job 485] Wrote 8192 bytes of print data...
I [04/Nov/2013:18:32:54 +0000] [Job 485] Processing page 2...
D [04/Nov/2013:18:32:54 +0000] cupsdMarkDirty(---J-)
D [04/Nov/2013:18:32:54 +0000] cupsdSetBusyState: newbusy="Printing jobs and dirty files", busy="Printing jobs and dirty files"
D [04/Nov/2013:18:32:54 +0000] [Job 485] Set job-printer-state-message to "Processing page 2...", current level=INFO
D [04/Nov/2013:18:32:54 +0000] Discarding unused job-progress event...
D [04/Nov/2013:18:32:54 +0000] Discarding unused printer-state-changed event...
D [04/Nov/2013:18:32:54 +0000] [Job 485] Read 4096 bytes of print data...
...
D [04/Nov/2013:18:33:02 +0000] [Job 485] Read 8192 bytes of print data...
I [04/Nov/2013:18:33:02 +0000] Saving job.cache...
D [04/Nov/2013:18:33:02 +0000] cupsdSetBusyState: newbusy="Printing jobs", busy="Printing jobs and dirty files"
D [04/Nov/2013:18:33:02 +0000] [Job 485] Wrote 8192 bytes of print data...
...
D [04/Nov/2013:18:33:07 +0000] [Job 485] Read 8192 bytes of print data...
I [04/Nov/2013:18:33:07 +0000] [Job 485] Processing page 3...
D [04/Nov/2013:18:33:07 +0000] cupsdMarkDirty(---J-)
D [04/Nov/2013:18:33:07 +0000] cupsdSetBusyState: newbusy="Printing jobs and dirty files", busy="Printing jobs"
D [04/Nov/2013:18:33:07 +0000] [Job 485] Set job-printer-state-message to "Processing page 3...", current level=INFO
D [04/Nov/2013:18:33:07 +0000] Discarding unused job-progress event...
D [04/Nov/2013:18:33:07 +0000] Discarding unused printer-state-changed event...
D [04/Nov/2013:18:33:07 +0000] [Job 485] Wrote 8192 bytes of print data...

and so on, with far more read and write reports. When not working the printer status remains as "idle - Formatting Page 1" whereas with the older version it clears to "idle - Rendering complete"

Hope this helps.
Peter

ProblemType: Bug
DistroRelease: Ubuntu 13.10
Package: cups-daemon 1.6.2-1ubuntu5
ProcVersionSignature: Ubuntu 3.11.0-12.19-generic 3.11.3
Uname: Linux 3.11.0-12-generic x86_64
NonfreeKernelModules: nvidia
ApportVersion: 2.12.5-0ubuntu2.1
Architecture: amd64
Date: Mon Nov 4 18:43:52 2013
ExecutablePath: /usr/sbin/cupsd
InstallationDate: Installed on 2013-05-05 (183 days ago)
InstallationMedia: Xubuntu 13.04 "Raring Ringtail" - Release amd64 (20130423.1)
Lpstat:
 device for B42WD-Duplex: usb://EPSON/Stylus%20Office%20B42WD?serial=4D4733593030303859
 device for B42WD-Duplex-Landscape: usb://EPSON/Stylus%20Office%20B42WD?serial=4D4733593030303859
 device for B42WD-Fast-Grey: usb://EPSON/Stylus%20Office%20B42WD?serial=4D4733593030303859
 device for B42WD-Simplex: usb://EPSON/Stylus%20Office%20B42WD?serial=4D4733593030303859
 device for PDF: cups-pdf:/
MachineType: Acer Aspire R3700
MarkForUpload: True
Papersize: a4
ProcAttrCurrent: /usr/sbin/cupsd (enforce)
ProcEnviron:
 PATH=(custom, no user)
 TERM=linux
ProcKernelCmdLine: BOOT_IMAGE=/boot/vmlinuz-3.11.0-12-generic root=UUID=643f0e37-fe91-4777-876c-41a4750284e5 ro quiet splash
SourcePackage: cups
UpgradeStatus: Upgraded to saucy on 2013-10-23 (11 days ago)
dmi.bios.date: 12/13/2010
dmi.bios.vendor: American Megatrends Inc.
dmi.bios.version: P01-A2L
dmi.board.asset.tag: To Be Filled By O.E.M.
dmi.board.name: TDPS05 R3700
dmi.board.vendor: Acer
dmi.board.version: To be filled by O.E.M.
dmi.chassis.type: 3
dmi.chassis.vendor: Acer
dmi.chassis.version: To Be Filled By O.E.M.
dmi.modalias: dmi:bvnAmericanMegatrendsInc.:bvrP01-A2L:bd12/13/2010:svnAcer:pnAspireR3700:pvrToBeFilledByO.E.M.:rvnAcer:rnTDPS05R3700:rvrTobefilledbyO.E.M.:cvnAcer:ct3:cvrToBeFilledByO.E.M.:
dmi.product.name: Aspire R3700
dmi.product.version: To Be Filled By O.E.M.
dmi.sys.vendor: Acer

Revision history for this message
peterthevicar (peterbcs) wrote :
Revision history for this message
peterthevicar (peterbcs) wrote :

Should have said: the printer is an Epson Stylus Office B42WD and I'm using the Epson driver from their website, version epson-inkjet-printer-workforce-635-nx625-series_1.0.1-1lsb3.2_amd64

Revision history for this message
peterthevicar (peterbcs) wrote :

OK, I purged cups (removing /etc/cups/ppd) and re-installed from scratch. This fixed the problem. I had copied the /etc/cups/ppd directory and the /etc/cups/printers.conf from a previous install so I guess that the problem was in one of those config files.

Incidentally on another machine I had a similar problem where acroread only printed the first page. This turned out to be because I needed to set acroread's "Print / Advanced / Font and resource policy" to Send with each Page. The same fix didn't help with this problem but I thought this might help desperate searchers!

summary: - 13.10 acroread and evince print only first page of document
+ 13.10 acroread and evince print only first page of document [SOLVED]
Revision history for this message
Launchpad Janitor (janitor) wrote :

Status changed to 'Confirmed' because the bug affects multiple users.

Changed in cups (Ubuntu):
status: New → Confirmed
Revision history for this message
Till Kamppeter (till-kamppeter) wrote :

Whoever die a me-too vote ("Does this bug affect you?"), please tell which printer you have, what you exactly tried to print, and follow the instructions of the sections "CUPS error_log" and "Capturing print job data" on https://wiki.ubuntu.com/DebuggingPrintingProblems#USB_printer_does_not_print_or_prints_garbage. Thanks.

Changed in cups (Ubuntu):
status: Confirmed → Incomplete
Revision history for this message
bbneo (brad-banko) wrote :

I'm having the same problem. Clean install of Ubuntu 13.10 in the past few days. Printer is Epson WF-3540.
Initially had difficulties installing the driver downloaded from Epson, but was able to get it to complete with:

sudo apt-get -f install Epson... .deb

Only prints the first page from Acrobat Reader.

I will try some of the fixes described above.

Revision history for this message
bbneo (brad-banko) wrote :

peterthevicar (peterbcs)... What did you reinstall from scratch? Your printer driver? CUPS (?)

I can get multiple pages printed from Firefox, but not from Adobe Acrobat. I have modifying the "Advanced Printing" settings as you mentioned above, but that doesn't fix the problem.

Revision history for this message
peterthevicar (peterbcs) wrote :

@bbneo
I copied from my old system the /etc/cups/printers.conf and /etc/cups/ppd directory and that's when it didn't work. To make it work I uninstalled (and purged) all the cups packages, deleted /etc/cups and then re-installed and re-added my printers. Printer driver is in post #2 for an Epson Stylus Office B42WD

HTH, Peter

Revision history for this message
Till Kamppeter (till-kamppeter) wrote :

bbneo, please follow the instructions of the sections "CUPS error_log" and "Capturing print job data" on https://wiki.ubuntu.com/DebuggingPrintingProblems#USB_printer_does_not_print_or_prints_garbage. Thanks.

Revision history for this message
Launchpad Janitor (janitor) wrote :

[Expired for cups (Ubuntu) because there has been no activity for 60 days.]

Changed in cups (Ubuntu):
status: Incomplete → Expired
To post a comment you must log in.
This report contains Public information  Edit
Everyone can see this information.

Other bug subscribers