CUPS broken (client-error-request-value-too-long) since upgrade to Raring

Bug #1192475 reported by Swâmi Petaramesh on 2013-06-19
6
This bug affects 1 person
Affects Status Importance Assigned to Milestone
cups (Ubuntu)
Undecided
Unassigned

Bug Description

Hi there,

Since upgraded from Quantal to Raring, my printer didn't work anymore, so I deleted it and (tried to) recreate it.

But trying to recreate it ends (from Ubuntu's Interface) in « client-error-request-value-too-long », and, if using a browser pointed to http://localhost:631, in « Request Entity Too Large ». (see screenshots).

I have reinstalled CUPS completely, to no avail, ad have no clue.

Help very much appreciated...

TIA.

ProblemType: Bug
DistroRelease: Ubuntu 13.04
Package: cups 1.6.2-1ubuntu5
ProcVersionSignature: Ubuntu 3.8.0-25.37-generic 3.8.13
Uname: Linux 3.8.0-25-generic x86_64
NonfreeKernelModules: nvidia zfs zcommon znvpair zavl zunicode
ApportVersion: 2.9.2-0ubuntu8.1
Architecture: amd64
Date: Wed Jun 19 09:34:54 2013
EcryptfsInUse: Yes
Lpstat: Error: command ['lpstat', '-v'] failed with exit code 1: lpstat: No destinations added.
MachineType: TOSHIBA SATELLITE L735
MarkForUpload: True
Papersize: a4
ProcKernelCmdLine: BOOT_IMAGE=/vmlinuz-3.8.0-25-generic root=ZFS=/UBUNTU/ROOTFS ro boot=zfs rpool=UZ1 rdblacklist=nouveau nouveau.blacklist=1 acpi_osi=Linux acpi_backlight=vendor quiet splash vt.handoff=7
SourcePackage: cups
UpgradeStatus: Upgraded to raring on 2013-04-25 (54 days ago)
dmi.bios.date: 06/26/2012
dmi.bios.vendor: INSYDE
dmi.bios.version: 2.50
dmi.board.asset.tag: Base Board Asset Tag
dmi.board.name: Base Board Product Name
dmi.board.vendor: Intel Corp.
dmi.board.version: Base Board Version
dmi.chassis.asset.tag: No Asset Tag
dmi.chassis.type: 10
dmi.chassis.vendor: OEM Chassis Manufacturer
dmi.chassis.version: OEM Chassis Version
dmi.modalias: dmi:bvnINSYDE:bvr2.50:bd06/26/2012:svnTOSHIBA:pnSATELLITEL735:pvrPSK0CE-00900LFR:rvnIntelCorp.:rnBaseBoardProductName:rvrBaseBoardVersion:cvnOEMChassisManufacturer:ct10:cvrOEMChassisVersion:
dmi.product.name: SATELLITE L735
dmi.product.version: PSK0CE-00900LFR
dmi.sys.vendor: TOSHIBA

Till Kamppeter (till-kamppeter) wrote :

Please follow the instructions of the section "CUPS error_log" on https://wiki.ubuntu.com/DebuggingPrintingProblems. Tell us also which printer you want to install and how it is connected. Thanks.

Changed in cups (Ubuntu):
status: New → Incomplete

Hi,

The problem occurs with both printers I tried, either Epson SX115 or Epson CX3200, eithern USB-connected or thru the network.

When locally USB connected, the printers are properly identified and correct drivers are proposed (from the control panel interface). Only when trying to "finalize the installation", it ends with « client-error-request-value-too-long ».

When using the CUPS web interface, simply clicking "Add a printer" immediately gives : « Request Entity Too Large »

It seems to me to be a generic issue with CUPS on my system, not related to a specific printer or connection method, either local or network...

Changed in cups (Ubuntu):
status: Incomplete → New

It may be worth noting that also, my /var/log/cups directory is completely empty, and trying to set any CUPS server parameter from the control panel ends in « Failed to set settings »...

However :

# ps awx | grep cups
 2163 ? Ss 0:00 /usr/sbin/cups-browsed
 9416 ? Ss 0:00 /usr/sbin/cupsd -F
 9419 ? S 0:00 /usr/lib/cups/notifier/dbus dbus://

Problem solved (for me). This was an apparmor issue, and "sudo aa-complain cupsd" allowed me to work around it.

I had some disk space and filesystem constraints that forced me to symlink :

/var/spool/ -> /alt_var/spool/
/var/cache/ -> /alt_var/cache/

And it seems that in this situation, apparmor prevented CUPS from accessing the files under /alt_var/...

Closing as Invalid.

Changed in cups (Ubuntu):
status: New → Invalid
To post a comment you must log in.
This report contains Public information  Edit
Everyone can see this information.

Other bug subscribers