usb printer works intermittently after upgrade to Precise

Bug #1160638 reported by Hal Thorne on 2013-03-26
18
This bug affects 3 people
Affects Status Importance Assigned to Milestone
cups (Ubuntu)
Undecided
Unassigned

Bug Description

I have a Canon MF4150 mono laser printer...was in use on Oneric with no problems. Testing Precise (12.04) on another machine before cutting over & found printing problems with this printer. Tried to research the issue but have not found a fix.

When first powered up, the printer works fine initially. After a few jobs, it stops working. It appears that after the last successful job, the printer is left in a hung state...visible evidence is the "Processing Data" indicator on the printer remains on...forever. In normal operation, this indicator goes off immediately after the last page of the job is completed. Once in thsi state, the printer never prints again until power is cycled.

However, while in this state, Cups still appears to send print jobs, but nothing actually prints. The cups log indicates that cups is sending data to the printer in a sequence of transfers (8192 bytes each). So cups apparently thinks the printer is accepting the job. I've compared the log sequence for jobs that print and jobs that don't and I can find no difference in the information reported in the cups log (at full debug level logging).

The problem is unlikely to be related to drivers since the printer is operating in raw mode (the machine is a samba server for Windows printing clients).

Have tried uni-directional constraint suggested in various places. This printer does not work at all if this option is applied.

I have tried blacklisting the usblp module. This does not solver the problem.

Since it does not happen every time, it seems related to the sequence or timing of usb transactions. Were there significant changes in usb behavior that would have affected raw printer handling between Oneric and Precise?

Need to move forward from Oneric...printer testing is my last issue. Help would be greatly appreciated.

ProblemType: Bug
DistroRelease: Ubuntu 12.04
Package: cups 1.5.3-0ubuntu6
ProcVersionSignature: Ubuntu 3.2.0-39.62-generic-pae 3.2.39
Uname: Linux 3.2.0-39-generic-pae i686
NonfreeKernelModules: fglrx
ApportVersion: 2.0.1-0ubuntu17.1
Architecture: i386
Date: Tue Mar 26 19:05:11 2013
InstallationMedia: Ubuntu 12.04 LTS "Precise Pangolin" - Release i386 (20120423)
Lpstat:
 device for Canon_iP6000D: usb://Canon/iP6000D?serial=1020CF
 device for Canon_MF4100_Series: usb://Canon/MF4100%20Series?serial=SDF690291911B&interface=1
 device for Canon_MF4150_Linux: cnusb:/dev/usb/lp1
MarkForUpload: True
Papersize: letter
PpdFiles: Canon_MF4150_Linux: Canon MF4100 Series UFRII LT ver.2.5
ProcEnviron:
 LANGUAGE=en_US:en
 TERM=xterm
 PATH=(custom, no user)
 LANG=en_US.UTF-8
 SHELL=/bin/bash
ProcKernelCmdLine: BOOT_IMAGE=/boot/vmlinuz-3.2.0-39-generic-pae root=UUID=350ae1ab-5bf6-44d2-b966-a72404d9a30c ro quiet splash vt.handoff=7
SourcePackage: cups
UpgradeStatus: No upgrade log present (probably fresh install)
dmi.bios.date: 07/15/2009
dmi.bios.vendor: Intel Corp.
dmi.bios.version: DPP3510J.86A.0572.2009.0715.2346
dmi.board.asset.tag: Base Board Asset Tag
dmi.board.name: DG33FB
dmi.board.vendor: Intel Corporation
dmi.board.version: AAD81072-306
dmi.chassis.type: 3
dmi.modalias: dmi:bvnIntelCorp.:bvrDPP3510J.86A.0572.2009.0715.2346:bd07/15/2009:svn:pn:pvr:rvnIntelCorporation:rnDG33FB:rvrAAD81072-306:cvn:ct3:cvr:
mtime.conffile..etc.cups.cupsd.conf: 2013-03-24T23:56:10.278670

Hal Thorne (hal-thorne) wrote :
Till Kamppeter (till-kamppeter) wrote :

Can you boot a Raring (13.04, daily build) live CD and try to print using this system? If this does not work, still in the live system, follow the instructions of the section "USB printer does not print or prints garbage" on https://wiki.ubuntu.com/DebuggingPrintingProblems. Thanks.

Changed in cups (Ubuntu):
status: New → Incomplete
Hal Thorne (hal-thorne) wrote :

Thanks Tim...it took me a while to reconfigure samba in Raring. However, in the end I found that my problem was corrected by the printer debugging information you referenced.

The two printers I was having trouble with were Canon models "ImageClass MF4150" and "Pixma iP6000D". After testing, my conclusions are as follows:

MF4150 requires usb-no-reattach=true, but does not require usb-unidir-default=true

iP6000D requires usb-unidir-default=true, but does not require usb-no-reattach=true

Blacklisting the usblp kernel module does not appear to be necessary for either of these printers.

You may wish to consider updating the quirks list for these devices.
MF4150 ID 04a9:26a3
iP6000D ID 04a9:1095

The above conclusions were verified in both Precise and Raring.

Thank you sincerely for your help.

Changed in cups (Ubuntu):
status: Incomplete → In Progress
Launchpad Janitor (janitor) wrote :

This bug was fixed in the package cups - 1.6.2-1ubuntu4

---------------
cups (1.6.2-1ubuntu4) raring; urgency=low

  * debian/local/apparmor-profile: Allow "audit_write" capability.
    (LP: #1157318).
  * debian/patches/usb-backend-epson-stylus-photo-750.patch,
    debian/patches/usb-backend-more-quirk-rules.patch: Added quirk rules for
    five additional printers: Lexmark e250d (LP: #1084164), Canon PIXMA iP6000D
    (LP: #1160638), Canon MF4150 (LP: #1160638), Brother HL-1450
    (LP: #1000253), Epson Stylus Color 670 (LP: #872483), joined the quirk rule
    patches.
 -- Till Kamppeter <email address hidden> Fri, 12 Apr 2013 08:31:01 +0200

Changed in cups (Ubuntu):
status: In Progress → Fix Released
sordna (sordna) wrote :

Not sure if this helps, but on my 64-bit ubuntu machine I was never able to print to my MF4150 printer, I could only scan with xsane. I tried many times over the years, with various ubuntu versions, and only recently, on Ubuntu 13.04 and after upgrading the Canon drivers to v2.70 I was able to print. I don't know if the cups update alone, or the driver update fixed the problem, but in any case I am very happy and thankful I am able to print after years of trying ! I upgraded to Saucy 13.10 and am still able to print and share the printer.

sordna (sordna) wrote :

Can someone verify if they are able to print to the Canon MF4150 printer with Trusty (14.04) ?
I tried the live CD, installed the canon drivers (tried both 2.70 and 2.80), restarted cupsd, printer is detected and added fine, but it does not print, even though there are no errors. Scanning (xsane) works, but printing does not.

I'm scared to uprade my 13.10 installation because I don't want to lose ability to print.

Till Kamppeter (till-kamppeter) wrote :

It is possible that on 14.04 a TIFF library is missing for the Canon drivers. See bug 1312103. Please check.

sordna (sordna) wrote :

Hmm looks like 1312103 is a duplicate of 1271714 now (tiff3 is disappearing from debian soon)

In any case, I installed 14.04 32-bit on an old laptop, as well as the v2.80 canon drivers and it printed fine.
So I'm hoping that when I upgrade by 64-bit desktop, it will work, although nothing is certain. The strange thing is the 64-bit live CD could not print.

sordna (sordna) wrote :

I did some more testing. The 32-bit trusty live cd can print, the 64-bit live cd cannot.
In both cases I installed the canon 2.80 drivers (Linux_UFRII_PrinterDriver_V280_us_EN.tar.gz), and used the 32 bit and 64 bit deb files respectively from it, after installing the necessary dependencies of course (apt-get install libglade2-0).

The same drivers (v2.80, 64bit) work on my 64-bit Saucy installation. So, something's miss with 64-bit trusty as far as this printer is concerned.

I tried both style printer paths:
usb://Canon/MF4100%20Series?serial=SDF84010xxxxx&interface=1
and
cnusb:/dev/usb/lp1

- Both device paths work on 32 bit trusty 14.04
- The longer usb:// path works on 64 bit saucy 13.10
- Nothing works on 64-bit trusty 14.04 (even though when adding printer, it detects them and chooses the right driver just fine)

No error shows up when I try to print, I just see" Idle - Sending data to printer" but the printer stays completely idle and unresponsive.

Can someone look into this?

Generally, this is a problem of the Canon driver. Canon must take care that their drivers work in up-to-date Linux distributions. So I highly recommend that you contact Canon about the problem.

I have three thermal receipt printers connected to Xubuntu 14.04 with Model Generic / Text only driver when print command three jobs, one for each printer, sometimes one or two printers stops are left with the job without printing, and the queue print says that the printer is turned off or disconnected.

If I send a new print job to the printer that has been standing prints the job that had been printed and the new, but the new print was incomplete.

This is used in a restaurant so that these errors can not happen.

And I hope you can help me with this problem.

CUPS Version: cups 1.7.2-0ubuntu1 amd64

To post a comment you must log in.
This report contains Public information  Edit
Everyone can see this information.

Other bug subscribers

Related questions