Cups overwrites config with no backup

Bug #1157972 reported by SpmP on 2013-03-20
10
This bug affects 2 people
Affects Status Importance Assigned to Milestone
cups (Ubuntu)
Undecided
Unassigned

Bug Description

Ubuntu 13.10,
 Upon update to cups version 1.6.1-2 all config was overwritten with no backup.
Especially printers.conf
ppd's remain in the ppd directory.
---
ApportVersion: 2.9.2-0ubuntu2
Architecture: i386
CupsErrorLog:
 W [06/Apr/2013:09:46:27 +1300] Please move "SystemGroup lpadmin" on line 16 of /etc/cups/cupsd.conf to the /etc/cups/cups-files.conf file; this will become an error in a future release.
 W [06/Apr/2013:09:46:29 +1300] CreateProfile failed: org.freedesktop.ColorManager.AlreadyExists:profile id '515-Gray..' already exists
 W [06/Apr/2013:09:46:29 +1300] CreateProfile failed: org.freedesktop.ColorManager.AlreadyExists:profile id '515-CMYK..' already exists
DistroRelease: Ubuntu 13.04
InstallationDate: Installed on 2012-03-21 (380 days ago)
InstallationMedia: Ubuntu 12.04 LTS "Precise Pangolin" - Alpha i386 (20120316)
Lpstat:
 device for 515: lpd://132.181.28.17/lp
 device for Kyocera: ipp://minihaha.local:631/printers/Kyocera
MachineType: ASUSTeK Computer INC. 1005HA
MarkForUpload: True
Package: cups 1.6.2-1ubuntu2
PackageArchitecture: i386
Papersize: a4
PpdFiles:
 515: Ricoh Aficio MP C2800 PS
 Deskjet-1050-J410-series-2: HP Deskjet 1050 j410 Series, hpcups 3.13.2
 Deskjet-1050-J410-series: HP Deskjet 1050 j410 Series, hpcups 3.13.2
 Hewlett-Packard-HP-Color-LaserJet-2600n: HP Color LaserJet 2600n Foomatic/foo2hp (recommended)
ProcCmdline: BOOT_IMAGE=/boot/vmlinuz-3.8.0-13-generic root=UUID=06eaa6ac-5983-4556-8779-4b53527661e9 ro quiet splash vt.handoff=7
ProcKernelCmdLine: BOOT_IMAGE=/boot/vmlinuz-3.8.0-13-generic root=UUID=06eaa6ac-5983-4556-8779-4b53527661e9 ro quiet splash vt.handoff=7
ProcVersionSignature: Ubuntu 3.8.0-13.23-generic 3.8.3
Tags: raring
Uname: Linux 3.8.0-13-generic i686
UpgradeStatus: No upgrade log present (probably fresh install)
UserGroups: adm cdrom dip kismet lpadmin plugdev sambashare src sudo
dmi.bios.date: 06/18/2009
dmi.bios.vendor: American Megatrends Inc.
dmi.bios.version: 0601
dmi.board.asset.tag: To Be Filled By O.E.M.
dmi.board.name: 1005HA
dmi.board.vendor: ASUSTeK Computer INC.
dmi.board.version: x.xx
dmi.chassis.asset.tag: 0x00000000
dmi.chassis.type: 10
dmi.chassis.vendor: ASUSTeK Computer INC.
dmi.chassis.version: x.x
dmi.modalias: dmi:bvnAmericanMegatrendsInc.:bvr0601:bd06/18/2009:svnASUSTeKComputerINC.:pn1005HA:pvrx.x:rvnASUSTeKComputerINC.:rn1005HA:rvrx.xx:cvnASUSTeKComputerINC.:ct10:cvrx.x:
dmi.product.name: 1005HA
dmi.product.version: x.x
dmi.sys.vendor: ASUSTeK Computer INC.

Thank you for taking the time to report this bug and helping to make Ubuntu better. Please execute the following command, as it will automatically gather debugging information, in a terminal:
apport-collect 1157972
When reporting bugs in the future please use apport by using 'ubuntu-bug' and the name of the package affected. You can learn more about this functionality at https://wiki.ubuntu.com/ReportingBugs.

I presume you refer to Ubuntu 13.04. I also experienced this bug so I can confirm it.

Launchpad Janitor (janitor) wrote :

Status changed to 'Confirmed' because the bug affects multiple users.

Changed in cups (Ubuntu):
status: New → Confirmed

apport information

tags: added: apport-collected raring
description: updated

apport information

apport information

apport information

apport information

apport information

apport information

apport information

apport information

apport information

apport information

apport information

apport information

apport information

Launchpad Janitor (janitor) wrote :

This bug was fixed in the package cups - 1.7.0~rc1-0ubuntu4

---------------
cups (1.7.0~rc1-0ubuntu4) saucy; urgency=low

  * debian/patches/cups-1.6.4-changes.patch: Merged latest fixes from upstream,
    taken from CUPS 1.6.4, as there is no public repository of CUPS any more
    and due to Apple policies the next 1.7.x release, 1.7.0 final, happens
    only with the next release of Mac OS X. Fixes:
     - Removed some duplicate page size definitions for some ISO sizes that were
       causing problems
     - The IPP backend did not add the "last-document" attribute
     - Added a SyncOnClose directive to cups-files.conf to force cupsd to
       call fsync before closing any configuration/state files it writes
       (LP: #1157972, Red Hat bug #984883).
     - Added USB quirk rule for Lexmark E238
     - Closed server connections were still not always detected
     - The libusb-based USB backend now loads its list of quirks from files
       in /usr/share/cups/usb instead of using a hardcoded table, this
       makes spotting and fixing USB problems much easier.
     - The scheduler did not properly register ICC color profiles with
       colord
  * debian/patches/usb-backend-more-quirk-rules.patch,
    debian/patches/handle-server-terminating-connection.patch,
    debian/patches/colord-add-profile-fix.patch: Removed, included upstream.
  * debian/patches/pidfile.patch,
    debian/patches/rootbackends-worldreadable.patch,
    debian/patches/airprint-support.patch,
    debian/patches/do-not-broadcast-with-hostnames.patch,
    debian/patches/mention-rfc2911-in-ipptoolfile-for-clarity.patch,
    debian/patches/add-ipp-backend-of-cups-1.4.patch,
    debian/patches/confdirperms.patch,
    debian/patches/show-compile-command-lines.patch,
    debian/patches/log-debug-history-nearly-unlimited.patch: Refreshed with
    quilt.
  * debian/local/apparmor-profile: Silenced AppArmor noise in syslog
    (LP: #1229766).
  * debian/local/cupsd-sync-files-on-close.patch: Activate CUPS daemon
    syncing files when closing, so that config files (like printers.conf)
    do not mysteriously disappear (LP: #1157972, Red Hat bug #984883).
  * debian/cups-server-common.install: Install /usr/share/cups/usb/ with the
    USB backend quirk rules file.
 -- Till Kamppeter <email address hidden> Tue, 24 Sep 2013 22:15:01 +0200

Changed in cups (Ubuntu):
status: Confirmed → Fix Released
To post a comment you must log in.
This report contains Public information  Edit
Everyone can see this information.

Other bug subscribers