AirPrint doesn't work on iOS 6 device

Bug #1054495 reported by ginalfa on 2012-09-22
60
This bug affects 9 people
Affects Status Importance Assigned to Milestone
cups (Debian)
Fix Released
Unknown
cups (Ubuntu)
Medium
Till Kamppeter
Precise
High
Till Kamppeter

Bug Description

After iOS 6 update on my iPad2 device Airprin doesn't work on my ubuntu 12,04 "precise" machine.
On my iPhone with iOS 5.1.1 still works fine.

I dont know if any attachement is required for this issue.
Sorry...

[IMPACT]

Everyone with iOS 6 on his iPhone/iPad/iPod Touch, independent whether iOS 6 was installed from the beginning or by an update, is not able to print from his iOS device any more, as there are changes in the AirPrint implementation. Due to Apple's updates this affects Apple hardware of the last three years.

[TESTCASE]

Print from an Appler iOS device with iOS 6 or newer. The print queues of your shared printers on your Precise machine do not appear. After applying the fixed package the queues will appear and printing will work.

[Regression Potential]

The changes are very simple (see attached debdiff) and so there are no regressions expected.

ginalfa (ginalfa) wrote :

it seems that Apple changed airprint output format from PDF to URF.
This format is not supported and CUPS shared printers aren't recognized by iOS6 devices.

http://ubuntuforums.org/showthread.php?t=2060594

Till Kamppeter (till-kamppeter) wrote :

It is not so bad, iOS 6 sstill sends the print jobs in PDF and JPG as before, but it requires CUPS at least to pretend that it supports image/urf and the "URF" text record field of the broadcasted Bonjour service cannot be "none" any more. I have updated the AirPrint support patch for CUPS to take this into account. The fix will appear in the next Quantal package of CUPS.

I will also look into an SRU for Precise.

Changed in cups (Ubuntu):
status: New → In Progress
importance: Undecided → Medium
milestone: none → ubuntu-12.10
assignee: nobody → Till Kamppeter (till-kamppeter)
Changed in cups (Ubuntu):
status: In Progress → Fix Committed
Launchpad Janitor (janitor) wrote :

This bug was fixed in the package cups - 1.6.1-0ubuntu7

---------------
cups (1.6.1-0ubuntu7) quantal; urgency=low

  * debian/patches/airprint-support.patch: Added support for iOS 6 clients
    (LP: #1054495).
  * debian/patches/usb-backend-more-quirk-rules.patch: Added more quirk rules:
    Canon MP500 (LP: #1032456), MP560 (CUPS STR #4155).
  * debian/patches/filter-out-all-control-characters-from-the-1284-device-id.patch:
    Do not only filter newline characters out of device IDs but any
    non-printable character (CUPS STR #4124).
  * debian/patches/ipp-backend-did-not-specify-the-compression-used.patch:
    The IPP backend did not specify the compression used (CUPS STR #4181).
  * debian/patches/work-around-some-broken-ipp-printers.patch: Work around
    some broken IPP printers (CUPS STR #4190). Also catch late authentication
    issues so the backend doesn't just spin on a print request that will never
    succeed.
 -- Till Kamppeter <email address hidden> Mon, 24 Sep 2012 11:48:30 +0200

Changed in cups (Ubuntu):
status: Fix Committed → Fix Released
James Gifford (jamesgifford) wrote :

What would it take to get this in a SRU for Precise?

Clint Byrum (clint-fewbar) wrote :

Task opened for Precise. Its really up to Till if its worth the time to backport the fix. This is definitely the kind of hardware enablement fix that we tend to push for in LTS releases though.

Launchpad Janitor (janitor) wrote :

Status changed to 'Confirmed' because the bug affects multiple users.

Changed in cups (Ubuntu Precise):
status: New → Confirmed
maclenin (maclenin) wrote :

Just adding my name to the hat as another 12.04 / Precise user affected by the iO6 "airprint" bug....

crud (cainscou) wrote :

Would also like to see this ported back to precise. Thank you for the great work.

JCFreeman (jcfreeman) wrote :

Bug #1054495 was reported on 22 Sept 2012 and seems to have been fairly quickly accepted, diagnosed and fixed for Quantal (12.10).
The same issue affects Precise (12.04) to the same extent.
Precise is an LTS release and it will probably have more users with Quantal so I am puzzled by the hesitancy in porting the fix to Precise. Unless of course it is to get a the fix out into the field to prove its robustness. If this is the case why not say so ?
For me, Ubuntu knocks the spots off the other OSs, especially Windows and the depth & breadth of software available is wonderful. That is works so well alongside & with Mac and Windows is also great - I can't avoid them in the workplace.

So - please keep up the good work but please could we have back the capability of printing from our iPads & IPhones !!!

As a workaround, see my fork of airprint-generate. It worked on my 12.04 64-bit installation. all the files you need are. Ow included in the git repo.

https://github.com/cainscou/airprint-generate

On Nov 19, 2012, at 12:08 AM, JCFreeman <email address hidden> wrote:

> Bug #1054495 was reported on 22 Sept 2012 and seems to have been fairly quickly accepted, diagnosed and fixed for Quantal (12.10).
> The same issue affects Precise (12.04) to the same extent.
> Precise is an LTS release and it will probably have more users with Quantal so I am puzzled by the hesitancy in porting the fix to Precise. Unless of course it is to get a the fix out into the field to prove its robustness. If this is the case why not say so ?
> For me, Ubuntu knocks the spots off the other OSs, especially Windows and the depth & breadth of software available is wonderful. That is works so well alongside & with Mac and Windows is also great - I can't avoid them in the workplace.
>
> So - please keep up the good work but please could we have back the
> capability of printing from our iPads & IPhones !!!
>
> --
> You received this bug notification because you are subscribed to the bug
> report.
> https://bugs.launchpad.net/bugs/1054495
>
> Title:
> AirPrint doesn't work on iOS 6 device
>
> Status in “cups” package in Ubuntu:
> Fix Released
> Status in “cups” source package in Precise:
> Confirmed
>
> Bug description:
> After iOS 6 update on my iPad2 device Airprin doesn't work on my ubuntu 12,04 "precise" machine.
> On my iPhone with iOS 5.1.1 still works fine.
>
> I dont know if any attachement is required for this issue.
> Sorry...
>
> To manage notifications about this bug go to:
> https://bugs.launchpad.net/ubuntu/+source/cups/+bug/1054495/+subscriptions

Changed in cups (Ubuntu Precise):
status: Confirmed → In Progress
importance: Undecided → High
assignee: nobody → Till Kamppeter (till-kamppeter)
milestone: none → precise-updates

Uploaded fixed cups package to precise-proposed, waiting for approval. As soon as the package gets available, please test it to see whether it solves the problem and has no regressions. As soon as the package gets available instructions for testing it will get posted here. Note that your feedback on testing the packlage is required for getting the package into the official updates for Precise.

SRU team: debdiff attached.

description: updated
Adam Conrad (adconrad) wrote :

Hello ginalfa, or anyone else affected,

Accepted cups into precise-proposed. The package will build now and be available at http://launchpad.net/ubuntu/+source/cups/1.5.3-0ubuntu5 in a few hours, and then in the -proposed repository.

Please help us by testing this new package. See https://wiki.ubuntu.com/Testing/EnableProposed for documentation how to enable and use -proposed. Your feedback will aid us getting this update out to other Ubuntu users.

If this package fixes the bug for you, please change the bug tag from verification-needed to verification-done. If it does not, change the tag to verification-failed. In either case, details of your testing will help us make a better decision.

Further information regarding the verification process can be found at https://wiki.ubuntu.com/QATeam/PerformingSRUVerification . Thank you in advance!

tags: added: verification-needed
Changed in cups (Ubuntu Precise):
status: In Progress → Fix Committed
Arthur Tan (artgtan) wrote :

Printing works again in iOS 6 and 12.04 now. Thank you!

tags: added: verification-done
removed: verification-needed
Marc Deslauriers (mdeslaur) wrote :

Unfortunately, a security update for cups was released that supersedes the update in -proposed.

The changes in -proposed need to get merged with the security update, and re-uploaded.

Uploaded new version of the fixed cups package, merged with the security update, to precise-proposed, waiting for approval. As soon as the package gets available, please test also this package to see whether it solves the problem and has no regressions. As soon as the package gets available a comment will get posted here. Note that your feedback on testing the package is required for getting the package into the official updates for Precise.

SRU team: new debdiff attached.

Changed in cups (Ubuntu Precise):
status: Fix Committed → In Progress
tags: removed: verification-done

Hello,

Sorry for the confusion but what is the CUPS version number that
should land in Precise Proposed that incorporates the Airprint fix and
the latest security update?

I currently have cups 1.5.3-0ubuntu5.1 and iOS Airprint does NOT work.

Thanks!

On Wed, Dec 5, 2012 at 12:33 PM, Till Kamppeter
<email address hidden> wrote:
> Uploaded new version of the fixed cups package, merged with the security
> update, to precise-proposed, waiting for approval. As soon as the
> package gets available, please test also this package to see whether it
> solves the problem and has no regressions. As soon as the package gets
> available a comment will get posted here. Note that your feedback on
> testing the package is required for getting the package into the
> official updates for Precise.
>
> SRU team: new debdiff attached.
>
> ** Patch added: "cups_1.5.3-0ubuntu5.1_1.5.3-0ubuntu6.debdiff"
> https://bugs.launchpad.net/ubuntu/+source/cups/+bug/1054495/+attachment/3452486/+files/cups_1.5.3-0ubuntu5.1_1.5.3-0ubuntu6.debdiff
>
> ** Changed in: cups (Ubuntu Precise)
> Status: Fix Committed => In Progress
>
> ** Tags removed: verification-done
>
> --
> You received this bug notification because you are subscribed to the bug
> report.
> https://bugs.launchpad.net/bugs/1054495
>
> Title:
> AirPrint doesn't work on iOS 6 device
>
> Status in “cups” package in Ubuntu:
> Fix Released
> Status in “cups” source package in Precise:
> In Progress
>
> Bug description:
> After iOS 6 update on my iPad2 device Airprin doesn't work on my ubuntu 12,04 "precise" machine.
> On my iPhone with iOS 5.1.1 still works fine.
>
> I dont know if any attachement is required for this issue.
> Sorry...
>
> [IMPACT]
>
> Everyone with iOS 6 on his iPhone/iPad/iPod Touch, independent whether
> iOS 6 was installed from the beginning or by an update, is not able to
> print from his iOS device any more, as there are changes in the
> AirPrint implementation. Due to Apple's updates this affects Apple
> hardware of the last three years.
>
> [TESTCASE]
>
> Print from an Appler iOS device with iOS 6 or newer. The print queues
> of your shared printers on your Precise machine do not appear. After
> applying the fixed package the queues will appear and printing will
> work.
>
> [Regression Potential]
>
> The changes are very simple (see attached debdiff) and so there are no
> regressions expected.
>
> To manage notifications about this bug go to:
> https://bugs.launchpad.net/ubuntu/+source/cups/+bug/1054495/+subscriptions

It is CUPS 1.5.3-0ubuntu6. The SRU team did not yet approve the package in the queue.

Arthur Tan (artgtan) wrote :

Thanks Till. I will test it when it is released.

On Wed, Dec 12, 2012 at 1:37 PM, Till Kamppeter
<email address hidden> wrote:
> It is CUPS 1.5.3-0ubuntu6. The SRU team did not yet approve the package
> in the queue.
>
> --
> You received this bug notification because you are subscribed to the bug
> report.
> https://bugs.launchpad.net/bugs/1054495
>
> Title:
> AirPrint doesn't work on iOS 6 device
>
> Status in “cups” package in Ubuntu:
> Fix Released
> Status in “cups” source package in Precise:
> In Progress
>
> Bug description:
> After iOS 6 update on my iPad2 device Airprin doesn't work on my ubuntu 12,04 "precise" machine.
> On my iPhone with iOS 5.1.1 still works fine.
>
> I dont know if any attachement is required for this issue.
> Sorry...
>
> [IMPACT]
>
> Everyone with iOS 6 on his iPhone/iPad/iPod Touch, independent whether
> iOS 6 was installed from the beginning or by an update, is not able to
> print from his iOS device any more, as there are changes in the
> AirPrint implementation. Due to Apple's updates this affects Apple
> hardware of the last three years.
>
> [TESTCASE]
>
> Print from an Appler iOS device with iOS 6 or newer. The print queues
> of your shared printers on your Precise machine do not appear. After
> applying the fixed package the queues will appear and printing will
> work.
>
> [Regression Potential]
>
> The changes are very simple (see attached debdiff) and so there are no
> regressions expected.
>
> To manage notifications about this bug go to:
> https://bugs.launchpad.net/ubuntu/+source/cups/+bug/1054495/+subscriptions

Hello ginalfa, or anyone else affected,

Accepted cups into precise-proposed. The package will build now and be available at http://launchpad.net/ubuntu/+source/cups/1.5.3-0ubuntu6 in a few hours, and then in the -proposed repository.

Please help us by testing this new package. See https://wiki.ubuntu.com/Testing/EnableProposed for documentation how to enable and use -proposed. Your feedback will aid us getting this update out to other Ubuntu users.

If this package fixes the bug for you, please add a comment to this bug, mentioning the version of the package you tested, and change the tag from verification-needed to verification-done. If it does not fix the bug for you, please add a comment stating that, and change the tag to verification-failed. In either case, details of your testing will help us make a better decision.

Further information regarding the verification process can be found at https://wiki.ubuntu.com/QATeam/PerformingSRUVerification . Thank you in advance!

Changed in cups (Ubuntu Precise):
status: In Progress → Fix Committed
tags: added: verification-needed
JCFreeman (jcfreeman) wrote :

just tested with iPhone 4S on IOS6
The list of printers now displays instantly.
I was able to select & use a different printer to the previous one I used.
I then tested with a different printer again - I even got a status message back about low paper supply !
I conclude it now works properly.
Mnay thanks Till Kamppeter and all others involved in fixing this.

Thank you very much for testing. I have marked the fix as verified now.

tags: added: verification-done
removed: verification-needed
Launchpad Janitor (janitor) wrote :

This bug was fixed in the package cups - 1.5.3-0ubuntu6

---------------
cups (1.5.3-0ubuntu6) precise-proposed; urgency=low

  * debian/patches/airprint-support.patch: Made AirPrint support also working
    for iOS 6 (LP: #1054495).
 -- Till Kamppeter <email address hidden> Wed, 5 Dec 2012 21:21:21 +0100

Changed in cups (Ubuntu Precise):
status: Fix Committed → Fix Released

The verification of this Stable Release Update has completed successfully and the package has now been released to -updates. Subsequently, the Ubuntu Stable Release Updates Team is being unsubscribed and will not receive messages about this bug report. In the event that you encounter a regression using the package from -updates please report a new bug using ubuntu-bug and tag the bug report regression-update so we can easily find any regresssions.

Changed in cups (Debian):
status: Unknown → New
Changed in cups (Debian):
status: New → Fix Released
To post a comment you must log in.
This report contains Public information  Edit
Everyone can see this information.

Duplicates of this bug

Other bug subscribers

Remote bug watches

Bug watches keep track of this bug in other bug trackers.