cupsd crashed with SIGSEGV in dnssdBuildTxtRecord()

Bug #1046982 reported by Chad Miller on 2012-09-06
18
This bug affects 2 people
Affects Status Importance Assigned to Milestone
cups (Ubuntu)
High
Till Kamppeter

Bug Description

While printing a single page of a PDF from evince, shrunk to fit page.

ProblemType: Crash
DistroRelease: Ubuntu 12.10
Package: cups 1.6.1-0ubuntu5
ProcVersionSignature: Ubuntu 3.5.0-13.14-generic 3.5.3
Uname: Linux 3.5.0-13-generic i686
ApportVersion: 2.5.1-0ubuntu4
Architecture: i386
CrashCounter: 1
Date: Thu Sep 6 14:33:53 2012
ExecutablePath: /usr/sbin/cupsd
Lpstat:
 p11-kit: duplicate configured module: gnome-keyring.module: /usr/lib/i386-linux-gnu/pkcs11/gnome-keyring-pkcs11.so
 device for laserprinter: usb://Samsung/SCX-4200%20Series?serial=8T61BACPA11988D.&interface=1
MachineType: MSI MS-7673
Papersize: letter
PpdFiles: laserprinter: Samsung SCX-4200 Series
ProcAttrCurrent: /usr/sbin/cupsd (enforce)
ProcCmdline: BOOT_IMAGE=/boot/vmlinuz-3.5.0-13-generic root=UUID=a486553e-b828-49e5-a1f7-c023a10decb1 ro splash quiet quiet splash vt.handoff=7
ProcEnviron:
 PATH=(custom, no user)
 TERM=linux
ProcKernelCmdLine: BOOT_IMAGE=/boot/vmlinuz-3.5.0-13-generic root=UUID=a486553e-b828-49e5-a1f7-c023a10decb1 ro splash quiet quiet splash vt.handoff=7
SegvAnalysis:
 Segfault happened at: 0xb73b70d5 <__strstr_sse42+37>: movzbl (%eax),%edx
 PC (0xb73b70d5) ok
 source "(%eax)" (0x00000000) not located in a known VMA region (needed readable region)!
 destination "%edx" ok
SegvReason: reading NULL VMA
Signal: 11
SourcePackage: cups
StacktraceTop:
 ?? ()
 ?? ()
 ?? ()
 ?? ()
 main ()
Title: cupsd crashed with SIGSEGV in main()
UpgradeStatus: Upgraded to quantal on 2010-09-09 (727 days ago)
UserGroups:

dmi.bios.date: 03/31/2011
dmi.bios.vendor: American Megatrends Inc.
dmi.bios.version: V1.10
dmi.board.asset.tag: To be filled by O.E.M.
dmi.board.name: P67A-C43 (MS-7673)
dmi.board.vendor: MSI
dmi.board.version: 1.0
dmi.chassis.asset.tag: To Be Filled By O.E.M.
dmi.chassis.type: 3
dmi.chassis.vendor: MSI
dmi.chassis.version: 1.0
dmi.modalias: dmi:bvnAmericanMegatrendsInc.:bvrV1.10:bd03/31/2011:svnMSI:pnMS-7673:pvr1.0:rvnMSI:rnP67A-C43(MS-7673):rvr1.0:cvnMSI:ct3:cvr1.0:
dmi.product.name: MS-7673
dmi.product.version: 1.0
dmi.sys.vendor: MSI
mtime.conffile..etc.cups.cupsd.conf: 2012-09-04T16:01:23.378261

Chad Miller (cmiller) wrote :
Chad Miller (cmiller) wrote :

Note nondefault cupsd.conf !

StacktraceTop:
 dnssdBuildTxtRecord (p=p@entry=0xb831a628, for_lpd=for_lpd@entry=0) at dirsvc.c:577
 dnssdRegisterPrinter (p=p@entry=0xb831a628) at dirsvc.c:1229
 cupsdRegisterPrinter (p=0xb831a628) at dirsvc.c:163
 cupsdStartBrowsing () at dirsvc.c:288
 cupsdStartServer () at server.c:64

Changed in cups (Ubuntu):
importance: Undecided → Medium
summary: - cupsd crashed with SIGSEGV in main()
+ cupsd crashed with SIGSEGV in dnssdBuildTxtRecord()
tags: removed: need-i386-retrace
visibility: private → public
Launchpad Janitor (janitor) wrote :

Status changed to 'Confirmed' because the bug affects multiple users.

Changed in cups (Ubuntu):
status: New → Confirmed
Till Kamppeter (till-kamppeter) wrote :

Reported to CUPS upstream as http://www.cups.org/str.php?L4183/

Changed in cups (Ubuntu):
milestone: none → ubuntu-12.10
assignee: nobody → Till Kamppeter (till-kamppeter)
importance: Medium → High
status: Confirmed → Fix Committed
Launchpad Janitor (janitor) wrote :

This bug was fixed in the package cups - 1.6.1-0ubuntu9

---------------
cups (1.6.1-0ubuntu9) quantal; urgency=low

  [ Till Kamppeter ]
  * debian/patches/prevent-crash-due-to-null-host-name-or-fqdn-from-avahi.patch:
    Prevent crash due to NULL host name or FQDN from Avahi (CUPS STR #4183,
    CUPS STR #4180, LP: #1046982, LP: #1034045).
  * debian/patches/fix-crash-on-shutdown-caused-by-broken-avahi-config.patch:
    Fix crash on shutdown caused by broken Avahi config (CUPS STR #4192,
    LP: #1036974).
  * debian/patches/ipp-backend-abort-the-outer-loop-if-we-get-a-failure-from-send-document.patch,
    debian/patches/ipp-backend-could-get-stuck-in-an-endless-loop-on-certain-network-errors.patch:
    Prevent IPP backend from falling into an infinite loop in certain
    situations (CUPS STR #4194).
  * debian/patches/airprint-support.patch: Refreshed with quilt.

  [ Didier Raboud ]
  * Make sure unowned obsolete backends are removed on configure.
    (Closes: #683754)
 -- Till Kamppeter <email address hidden> Mon, 1 Oct 2012 12:27:30 +0200

Changed in cups (Ubuntu):
status: Fix Committed → Fix Released
To post a comment you must log in.
This report contains Public information  Edit
Everyone can see this information.

Duplicates of this bug

Other bug subscribers