cupsd crashed with SIGABRT in __assert_fail_base()

Bug #1041013 reported by Jason Warner on 2012-08-24
24
This bug affects 4 people
Affects Status Importance Assigned to Milestone
cups (Ubuntu)
High
Till Kamppeter

Bug Description

crash on startup

ProblemType: Crash
DistroRelease: Ubuntu 12.10
Package: cups 1.6.1-0ubuntu3
ProcVersionSignature: Ubuntu 3.5.0-11.11-generic 3.5.2
Uname: Linux 3.5.0-11-generic x86_64
ApportVersion: 2.5.1-0ubuntu1
Architecture: amd64
CupsErrorLog: E [24/Aug/2012:11:57:38 +0930] Unable to communicate with avahi-daemon: Daemon not running
Date: Fri Aug 24 11:57:39 2012
ExecutablePath: /usr/sbin/cupsd
InstallationMedia: Ubuntu 11.10 "Oneiric Ocelot" - Beta amd64 (20110919)
Lpstat:
 p11-kit: duplicate configured module: gnome-keyring.module: /usr/lib/x86_64-linux-gnu/pkcs11/gnome-keyring-pkcs11.so
 device for psc-2400-series: dnssd://hp2410%20%40%20idub._ipp._tcp.local/cups
Lsusb:
 Bus 001 Device 002: ID 8087:0024 Intel Corp. Integrated Rate Matching Hub
 Bus 002 Device 002: ID 8087:0024 Intel Corp. Integrated Rate Matching Hub
 Bus 001 Device 001: ID 1d6b:0002 Linux Foundation 2.0 root hub
 Bus 002 Device 001: ID 1d6b:0002 Linux Foundation 2.0 root hub
 Bus 001 Device 003: ID 04f2:b217 Chicony Electronics Co., Ltd Lenovo Integrated Camera (0.3MP)
MachineType: LENOVO 4286CTO
Papersize: a4
ProcAttrCurrent: /usr/sbin/cupsd (enforce)
ProcCmdline: /usr/sbin/cupsd -F
ProcEnviron:
 PATH=(custom, no user)
 TERM=linux
ProcKernelCmdLine: BOOT_IMAGE=/boot/vmlinuz-3.5.0-11-generic root=UUID=705894e9-4493-41b0-8b0a-26944457902d ro quiet splash vt.handoff=7
Signal: 6
SourcePackage: cups
StacktraceTop:
 raise () from /lib/x86_64-linux-gnu/libc.so.6
 abort () from /lib/x86_64-linux-gnu/libc.so.6
 ?? () from /lib/x86_64-linux-gnu/libc.so.6
 __assert_fail () from /lib/x86_64-linux-gnu/libc.so.6
 avahi_client_get_host_name () from /usr/lib/x86_64-linux-gnu/libavahi-client.so.3
Title: cupsd crashed with SIGABRT in raise()
UpgradeStatus: Upgraded to quantal on 2012-07-23 (31 days ago)
UserGroups:

dmi.bios.date: 12/01/2011
dmi.bios.vendor: LENOVO
dmi.bios.version: 8DET56WW (1.26 )
dmi.board.asset.tag: Not Available
dmi.board.name: 4286CTO
dmi.board.vendor: LENOVO
dmi.board.version: Not Available
dmi.chassis.asset.tag: No Asset Information
dmi.chassis.type: 10
dmi.chassis.vendor: LENOVO
dmi.chassis.version: Not Available
dmi.modalias: dmi:bvnLENOVO:bvr8DET56WW(1.26):bd12/01/2011:svnLENOVO:pn4286CTO:pvrThinkPadX220:rvnLENOVO:rn4286CTO:rvrNotAvailable:cvnLENOVO:ct10:cvrNotAvailable:
dmi.product.name: 4286CTO
dmi.product.version: ThinkPad X220
dmi.sys.vendor: LENOVO
mtime.conffile..etc.cups.cupsd.conf: 2012-08-09T17:12:59.866966

Jason Warner (jasoncwarner) wrote :
visibility: private → public

StacktraceTop:
 __assert_fail_base (fmt=<optimized out>, assertion=0x7f51d4057da9 "client", file=0x7f51d4057da0 "client.c", line=<optimized out>, function=<optimized out>) at assert.c:94
 __GI___assert_fail (assertion=0x7f51d4057da9 "client", file=0x7f51d4057da0 "client.c", line=757, function=0x7f51d4058410 "avahi_client_get_host_name") at assert.c:103
 avahi_client_get_host_name () from /tmp/tmpnLMNmP/usr/lib/x86_64-linux-gnu/libavahi-client.so.3
 cupsdUpdateDNSSDName () at dirsvc.c:460
 cupsdStartBrowsing () at dirsvc.c:266

Changed in cups (Ubuntu):
importance: Undecided → Medium
summary: - cupsd crashed with SIGABRT in raise()
+ cupsd crashed with SIGABRT in __assert_fail_base()
tags: removed: need-amd64-retrace
Launchpad Janitor (janitor) wrote :

Status changed to 'Confirmed' because the bug affects multiple users.

Changed in cups (Ubuntu):
status: New → Confirmed
Till Kamppeter (till-kamppeter) wrote :

Please update your system to get cups_1.6.1-0ubuntu9 which fixes several crash bugs. Do you still get the crash?

Changed in cups (Ubuntu):
status: Confirmed → Incomplete
Till Kamppeter (till-kamppeter) wrote :

Problem occurred also with 1.6.1-0ubuntu9.

Till Kamppeter (till-kamppeter) wrote :

Problem reported upstream as https://www.cups.org/str.php?L4200.

Changed in cups (Ubuntu):
status: Incomplete → Confirmed
importance: Medium → High
milestone: none → ubuntu-12.10
assignee: nobody → Till Kamppeter (till-kamppeter)

Sorry, apport triggered a false alarm trying to upload an old bug report.

According to the original stack trace this bug should be fixed in 1.6.1-0ubuntu9.

Seems that I have found the problem now:

DNSSDClient seems to need to get NULL_checked before the avahi_client_get_host_name() call in line 463 of scheduler/dirsvc.c.

Changed in cups (Ubuntu):
status: Confirmed → Triaged

Bug fixed upstream, fix will be included in the next CUPS package in Quantal.

Fix committed in cups 1.6.1-0ubuntu10 in quantal-proposed. Note that the upload also contains an FFe, bug 1061063 and bug 1061069.

Changed in cups (Ubuntu):
status: Triaged → Fix Committed

The package is now accepted into quantal-proposed. Please test it and report back whether the crash goes away.

Launchpad Janitor (janitor) wrote :

This bug was fixed in the package cups - 1.6.1-0ubuntu10

---------------
cups (1.6.1-0ubuntu10) quantal-proposed; urgency=low

  * debian/patches/forward-port-cups-1-5-x-cups-browsing.patch: Re-introduced
    CUPS Browsing/Broadcasting for automatic discovery of shared CUPS printers
    on the local network. We will keep this for the Quantal cycle until we
    get automatic discovery of Bonjour-broadcasted printers, which most
    probably needs to be implemented in the application's print dialogs. This
    will only be possible to be done in Quantal+1 (13.04). The patch is large
    but all code added worked very well in many generations of CUPS and the
    code added back in smoothly without need of alterations of the existing
    code (LP: #1061063, LP: #1061069).
  * debian/rules: Set "./configure" arguments
    "--with-local_protocols='CUPS dnssd' --with-remote_protocols='CUPS dnssd'"
    to make the re-introduction of CUPS Browsing/Broadcasting work correctly.
  * debian/cups.postinst: Do not remove the "Browse..." keywords from cupsd.conf
    any more as we have re-introduced the Browsing/Broadcasting functionality.
  * debian/patches/fix-another-spot-where-avahi-crashes-cupsd-because-it-does-not-handle-null-values-from-its-own-apis.patch:
    Fix another spot where Avahi crashes cupsd because it does not handle NULL
    values returned by its own APIs (CUPS STR #4200, LP: #1041013).
  * debian/patches/ipp-backend-did-not-send-cancel-request-to-printers-when-a-job-was-canceled-and-printer-did-not-support-create-job.patch:
    The IPP backend did not send a cancel request to printers when a job was
    canceled and the printer did not support Create-Job. This is to improve the
    "ipp" backend as much as possible to reduce the ned of the "ipp14" backend
    ("ipp" backend of CUPS 1.4.x added to the Debian/Ubuntu package as fallback
    in case of regressions of the current "ipp" backend).
 -- Till Kamppeter <email address hidden> Fri, 5 Oct 2012 20:56:30 +0200

Changed in cups (Ubuntu):
status: Fix Committed → Fix Released
To post a comment you must log in.
This report contains Public information  Edit
Everyone can see this information.

Other bug subscribers