Cups broken after daily update: 631 - Cannot assign requested address

Bug #1006927 reported by roots on 2012-05-31
26
This bug affects 5 people
Affects Status Importance Assigned to Milestone
cups (Ubuntu)
Undecided
Unassigned

Bug Description

After todays software update, Cups printing seems to be bugged:

I'm running Ubuntu 12.04 and have been happily printing on my Canon Pixma IP2700 until today using cups & Canon printer drivers, details see below. However, printing is broken now and it appears to have been happening after todays update.

/var/log/cups/error_log says
E [31/May/2012:15:31:23 +0200] Unable to bind socket for address [v1.::1]:631 - Cannot assign requested address.

Up to now, I've been using cnijfilter-ip2700series-3.30-1-i386-deb. To debug, I purged all cups & Canon drivers, then reinstalled cups with Driver: Canon PIXUS iP2700 - CUPS+Gutenprint v5.2.8-pre1. Test print went fine, as well as another 2 prints from LibreOffice, after that no more success, even after reboot / printer power off etc.
Tried to install Canon drivers again, but install.sh says no printer connected, at the same moment /var/log/cups/error_log is getting another of the above error messages.

lsusb shows the printer. Printing is working fine from within a virtualboxed Windows.

Any suggestions welcome.

OS: Ubuntu 12.04 LTS
Cups:
  Installed: 1.5.3-0ubuntu1
  Candidate: 1.5.3-0ubuntu1
Printer/Driver:
Canon PIXUS iP2700 - CUPS+Gutenprint v5.2.8-pre1
cnijfilter-ip2700series-3.30-1-i386-deb

Launchpad Janitor (janitor) wrote :

Status changed to 'Confirmed' because the bug affects multiple users.

Changed in cups (Ubuntu):
status: New → Confirmed
Changed in cups (Ubuntu):
status: Confirmed → New
Changed in cups (Ubuntu):
status: New → Confirmed
Rolf Leggewie (r0lf) wrote :

"/var/log/cups/error_log says
E [31/May/2012:15:31:23 +0200] Unable to bind socket for address [v1.::1]:631 - Cannot assign requested address."

There seems to be an error related to IPv6 here. I ran into this issue trying to set "Listen *:631" on a wheezy box. Apparently cups somehow incorrectly thinks this includes IPv6 addresses even when the box itself speaks only IPv4.

To post a comment you must log in.
This report contains Public information  Edit
Everyone can see this information.

Other bug subscribers