cups-pdf chokes on non-ascii characters in filenames

Bug #432736 reported by Rolf Leggewie on 2009-09-18
16
This bug affects 2 people
Affects Status Importance Assigned to Milestone
Ubuntu Japanese Kaizen Project
Undecided
Unassigned
cups-pdf (Ubuntu)
Low
Unassigned

Bug Description

Binary package hint: cups-pdf

Japanese characters in the filename of an OpenOffice.org document are replaced by underscores. The title in the metadata is gibberish. I am running up-to-date karmic.

日本語版: bug 190609 (discussion in Japanese related to this bug)

Martin-Éric Racine (q-funk) wrote :

Something tells me that the culprit might be Ghostscript, which is used by CUPS-PDF to generate the PDF document. Somehow, it must be doing some stupid font substitution using a font that lacks the CJK character range.

Martin-Éric Racine (q-funk) wrote :

Does installing installing gs-cjk-resource and cmap-adobe-* packages solve this issue?

Martin-Éric Racine (q-funk) wrote :

i also forgot to ask, was this working fine on Jaunty?

Rolf Leggewie (r0lf) wrote :

Martin-Éric Racine wrote:
> Does installing installing gs-cjk-resource and cmap-adobe-* packages
> solve this issue?

no, it doesn't and I wasn't really expecting it to since as I found out later the error happens with German Umlauts as well. I suppose any kind of non-ascii chars may trigger this issue.

I believe the error in Jaunty may have been different, yet similar. I have a file here dated July 5th that has a filename 244ppchen.pdf when it should have been Schnäppchen.pdf.

Martin-Eric, please be aware that the problem is in the filename, not the text in the PDF itself.

summary: - cups-pdf chokes on Japanese characters
+ cups-pdf chokes on non-ascii characters

Here is a test-case. Go to my blog at http://blog.leggewie.org/ which has an Umlaut in the title. Print that to PDF, the 'ö' character will be replaced by '_'

summary: - cups-pdf chokes on non-ascii characters
+ cups-pdf chokes on non-ascii characters in filenames
Rolf Leggewie (r0lf) wrote :

a Japanese user reported the same problem. Setting state to confirmed.

Changed in cups-pdf (Ubuntu):
importance: Undecided → Low
status: New → Confirmed
Rolf Leggewie (r0lf) on 2010-05-06
description: updated
Rolf Leggewie (r0lf) on 2010-05-06
Changed in ubuntu-jp-improvement:
status: New → Confirmed
Martin-Éric Racine (q-funk) wrote :

According to the upstream author, this could be fixed by editing cups-pdf.conf to enable the "DecodeHexStrings" option. Can you confirm whether this works for you?

Changed in cups-pdf (Ubuntu):
status: Confirmed → Incomplete
Launchpad Janitor (janitor) wrote :

This bug was fixed in the package cups-pdf - 2.6.1-4

---------------
cups-pdf (2.6.1-4) unstable; urgency=low

  * Migrated to source format 3.0 (quilt).
    + [debian/control]: Build-Depends on dpkg-dev (>= 1.14.17~).
    - [debian/control]: drop the Build-Depends on quilt.
    - [debian/rules]: drop the patchsys-quilt.mk CDBS include.
    - [debian/README.source]: deleted.
  * Enabled non-ASCII filenames via the DecodeHexStrings option (LP: #432736).
 -- Martin-Eric Racine <email address hidden> Tue, 29 Nov 2011 09:55:58 +0200

Changed in cups-pdf (Ubuntu):
status: Incomplete → Fix Released
Martin-Éric Racine (q-funk) wrote :

It should also be noted that the upstream homepage (http://www.cups-pdf.de) has instructions in German on how to guarantee proper display of accented characters whenever printing from a Windows client.

Changed in ubuntu-jp-improvement:
status: Confirmed → Fix Released
To post a comment you must log in.
This report contains Public information  Edit
Everyone can see this information.

Duplicates of this bug

Other bug subscribers