package cups-pdf 2.4.6-4ubuntu2 failed to install/upgrade:

Bug #387112 reported by thierman on 2009-06-14
242
This bug affects 20 people
Affects Status Importance Assigned to Milestone
cups-pdf (Ubuntu)
Undecided
Unassigned
Hardy
Undecided
Unassigned
Intrepid
Undecided
Unassigned
Jaunty
Undecided
Unassigned
debconf (Ubuntu)
Undecided
Unassigned
Hardy
Undecided
Unassigned
Intrepid
Undecided
Unassigned
Jaunty
Undecided
Unassigned
update-manager (Ubuntu)
Medium
Michael Vogt
Hardy
Undecided
Unassigned
Intrepid
Undecided
Unassigned
Jaunty
Undecided
Unassigned

Bug Description

Binary package hint: cups-pdf

Cups failed to install siteing dependacy problems preventing configuration
root@thierman-desktop:/etc/dhcp3# lsb_release -rd
Description: Ubuntu 8.04.2
Release: 8.04

root@thierman-desktop:/var/log# tail dpkg.log
2009-06-14 10:57:07 status half-configured libspeexdsp1 1.2~beta4-2
2009-06-14 10:57:07 status installed libspeexdsp1 1.2~beta4-2
2009-06-14 10:57:07 configure libopal-2.2 2.2.11~dfsg1-4ubuntu1 2.2.11~dfsg1-4ubuntu1
2009-06-14 10:57:07 status unpacked libopal-2.2 2.2.11~dfsg1-4ubuntu1
2009-06-14 10:57:07 status half-configured libopal-2.2 2.2.11~dfsg1-4ubuntu1
2009-06-14 10:57:07 status installed libopal-2.2 2.2.11~dfsg1-4ubuntu1
2009-06-14 10:57:07 configure libebackend1.2-0 2.24.3-0ubuntu1 2.24.3-0ubuntu1
2009-06-14 10:57:07 status unpacked libebackend1.2-0 2.24.3-0ubuntu1
2009-06-14 10:57:07 status half-configured libebackend1.2-0 2.24.3-0ubuntu1
2009-06-14 10:57:07 status installed libebackend1.2-0 2.24.3-0ubuntu1

Output from term.log:

Setting up libebackend1.2-0 (2.24.3-0ubuntu1) ...
dpkg: dependency problems prevent configuration of libedata-book1.2-2:
 libedata-book1.2-2 depends on libebook1.2-9 (>= 2.24.3); however:
  Package libebook1.2-9 is not configured yet.
 libedata-book1.2-2 depends on libgnome2-0 (>= 2.17.3); however:
  Package libgnome2-0 is not configured yet.
dpkg: error processing libedata-book1.2-2 (--configure):
dpkg: dependency problems prevent configuration of libedata-cal1.2-6:
 libedata-cal1.2-6 depends on libecal1.2-7 (>= 2.24.3); however:
  Package libecal1.2-7 is not configured yet.
 libedata-cal1.2-6 depends on libgnome2-0 (>= 2.17.3); however:
dpkg: error processing libedata-cal1.2-6 (--configure):
dpkg: too many errors, stopping
dpkg: ../../src/packages.c:265: process_queue: Assertion `!queue.length' failed.
Traceback (most recent call last):
  File "/usr/lib/python2.5/logging/__init__.py", line 753, in emit
    self.flush()
  File "/usr/lib/python2.5/logging/__init__.py", line 731, in flush
    self.stream.flush()
IOError: [Errno 9] Bad file descriptor
  Package libecal1.2-7 is not configured yet.
 libedata-cal1.2-6 depends on libgnome2-0 (>= 2.17.3); however:
dpkg: error processing libedata-book1.2-2 (--configure):
dpkg: dependency problems prevent configuration of libedata-cal1.2-6:
 libedata-cal1.2-6 depends on libecal1.2-7 (>= 2.24.3); however:
 libedata-book1.2-2 depends on libgnome2-0 (>= 2.17.3); however:
  Package libebook1.2-9 is not configured yet.
 libedata-book1.2-2 depends on libebook1.2-9 (>= 2.24.3); however:
dpkg: dependency problems prevent configuration of libedata-book1.2-2:
Setting up libebackend1.2-0 (2.24.3-0ubuntu1) ...
Setting up libopal-2.2 (2.2.11~dfsg1-4ubuntu1) ...
Setting up libspeexdsp1 (1.2~beta4-2) ...
Setting up libpt-1.10.10 (1.10.10-2ubuntu3) ...
Setting up libpt-1.10.10-plugins-v4l2 (1.10.10-2ubuntu3) ...
Setting up libpt-1.10.10-plugins-v4l (1.10.10-2ubuntu3) ...
Setting up libpt-1.10.10-plugins-alsa (1.10.10-2ubuntu3) ...
dpkg: error processing libgnomevfs2-extra (--configure):
  Package libgnomevfs2-0 is not configured yet.
 libgnomevfs2-extra depends on libgnomevfs2-0 (>= 1:2.17.90); however:
dpkg: dependency problems prevent configuration of libgnomevfs2-extra:
Setting up libxfont1 (1:1.3.3-1ubuntu1) ...
Setting up libpciaccess0 (0.10.3-1) ...
Setting up xserver-common (2:1.5.2-2ubuntu3.1) ...
Setting up aspell (0.60.6-1) ...
Updating OpenOffice.org's dictionary list... done.
mon.el ...
Installing new version of config file /etc/emacs/site-start.d/50dictionaries-com
mon.el ...
Setting up dictionaries-common (0.98.9ubuntu1) ...
Setting up libfcgi-perl (0.67-2.1) ...
dpkg: error processing libgnome2-perl (--configure):
  Package libgnome2-vfs-perl is not configured yet.
 libgnome2-perl depends on libgnome2-vfs-perl (>= 1.00); however:
 libgnome2-perl depends on libgnomevfs2-0 (>= 1:2.17.90); however:
  Package libgnomeui-0 is not configured yet.
 libgnome2-perl depends on libgnomeui-0 (>= 2.22.0); however:
  Package libgnome2-0 is not configured yet.
 libgnome2-perl depends on libgnome2-0 (>= 2.17.3); however:
  Package libbonoboui2-0 is not configured yet.
dpkg: dependency problems prevent configuration of libgnome2-perl:
 libgnome2-perl depends on libbonoboui2-0 (>= 2.15.1); however:
Setting up libnet-ssleay-perl (1.35-1ubuntu1) ...
Setting up libevent-perl (1.11-1) ...
Replacing config file /etc/perl/XML/SAX/ParserDetails.ini with new version
update-perl-sax-parsers: Updating overall Perl SAX parser modules info file...
ity 50...
update-perl-sax-parsers: Registering Perl SAX parser XML::LibXML::SAX with prior
ity 50...
th priority 50...
Installing new version of config file /etc/emacs/site-start.d/50dictionaries-com
update-perl-sax-parsers: Registering Perl SAX parser XML::LibXML::SAX::Parser wi
th priority 50...
Setting up libxml-libxml-perl (1.66-1build2) ...
ority 10...
update-perl-sax-parsers: Registering Perl SAX parser XML::SAX::PurePerl with pri
ority 10...
riority 50...
update-perl-sax-parsers: Unregistering Perl SAX parser XML::SAX::PurePerl with p
riority 50...
Migrating the Perl SAX parser information directory.
Setting up libxml-sax-perl (0.16+dfsg-3) ...
Setting up libfile-rsyncp-perl (0.68-1.1build2) ...
Setting up libgnome2-canvas-perl (1.002-1+b1ubuntu3) ...
Setting up libossp-uuid-perl (1.5.1-1.1ubuntu2) ...
Setting up libossp-uuid15 (1.5.1-1.1ubuntu2) ...
 libedata-cal1.2-6 depends on libecal1.2-7 (>= 2.24.3); however:
  Package libecal1.2-7 is not configured yet.
 libedata-cal1.2-6 depends on libgnome2-0 (>= 2.17.3); however:
  Package libgnome2-0 is not configured yet.
dpkg: error processing libedata-cal1.2-6 (--configure):
 dependency problems - leaving unconfigured
dpkg: too many errors, stopping
dpkg: ../../src/packages.c:265: process_queue: Assertion `!queue.length' failed.
Traceback (most recent call last):
  File "/usr/lib/python2.5/logging/__init__.py", line 753, in emit
    self.flush()
  File "/usr/lib/python2.5/logging/__init__.py", line 731, in flush
    self.stream.flush()
IOError: [Errno 9] Bad file descriptor
Traceback (most recent call last):
  File "/usr/lib/python2.5/logging/__init__.py", line 753, in emit
    self.flush()
  File "/usr/lib/python2.5/logging/__init__.py", line 731, in flush
    self.stream.flush()
IOError: [Errno 9] Bad file descriptor
Traceback (most recent call last):
  File "/usr/lib/python2.5/logging/__init__.py", line 753, in emit
    self.flush()
  File "/usr/lib/python2.5/logging/__init__.py", line 731, in flush
dpkg: error processing libedata-book1.2-2 (--configure):
dpkg: dependency problems prevent configuration of libedata-cal1.2-6:
  Package libebook1.2-9 is not configured yet.
 libedata-book1.2-2 depends on libgnome2-0 (>= 2.17.3); however:
dpkg: dependency problems prevent configuration of libedata-book1.2-2:
 libedata-book1.2-2 depends on libebook1.2-9 (>= 2.24.3); however:
Setting up libopal-2.2 (2.2.11~dfsg1-4ubuntu1) ...
Setting up libebackend1.2-0 (2.24.3-0ubuntu1) ...
Setting up libspeexdsp1 (1.2~beta4-2) ...
Setting up libpt-1.10.10-plugins-v4l (1.10.10-2ubuntu3) ...
Setting up libpt-1.10.10-plugins-v4l2 (1.10.10-2ubuntu3) ...
Setting up libpt-1.10.10 (1.10.10-2ubuntu3) ...
dpkg: error processing libgnomevfs2-extra (--configure):
Setting up libpt-1.10.10-plugins-alsa (1.10.10-2ubuntu3) ...
dpkg: dependency problems prevent configuration of libgnomevfs2-extra:
 libgnomevfs2-extra depends on libgnomevfs2-0 (>= 1:2.17.90); however:
  Package libgnomevfs2-0 is not configured yet.
Setting up libxfont1 (1:1.3.3-1ubuntu1) ...
Setting up xserver-common (2:1.5.2-2ubuntu3.1) ...
Setting up libpciaccess0 (0.10.3-1) ...
Updating OpenOffice.org's dictionary list... done.
Setting up aspell (0.60.6-1) ...
Setting up dictionaries-common (0.98.9ubuntu1) ...
Installing new version of config file /etc/emacs/site-start.d/50dictionaries-com
mon.el ...
dpkg: error processing libgnome2-perl (--configure):
Setting up libfcgi-perl (0.67-2.1) ...
 libgnome2-perl depends on libgnome2-vfs-perl (>= 1.00); however:
  Package libgnome2-vfs-perl is not configured yet.
 libgnome2-perl depends on libgnomeui-0 (>= 2.22.0); however:
  Package libgnomeui-0 is not configured yet.
 libgnome2-perl depends on libgnomevfs2-0 (>= 1:2.17.90); however:
dpkg: error processing libgnomevfs2-extra (--configure):
Setting up libpt-1.10.10-plugins-alsa (1.10.10-2ubuntu3) ...
Setting up libpt-1.10.10-plugins-v4l (1.10.10-2ubuntu3) ...
Setting up libpt-1.10.10-plugins-v4l2 (1.10.10-2ubuntu3) ...
Setting up libpt-1.10.10 (1.10.10-2ubuntu3) ...
Setting up libspeexdsp1 (1.2~beta4-2) ...
Setting up libopal-2.2 (2.2.11~dfsg1-4ubuntu1) ...
Setting up libebackend1.2-0 (2.24.3-0ubuntu1) ...
dpkg: dependency problems prevent configuration of libedata-book1.2-2:
 libedata-book1.2-2 depends on libebook1.2-9 (>= 2.24.3); however:
  Package libebook1.2-9 is not configured yet.
 libedata-book1.2-2 depends on libgnome2-0 (>= 2.17.3); however:
  Package libgnome2-0 is not configured yet.
dpkg: error processing libedata-book1.2-2 (--configure):
dpkg: dependency problems prevent configuration of libedata-cal1.2-6:
 libedata-cal1.2-6 depends on libecal1.2-7 (>= 2.24.3); however:
  Package libecal1.2-7 is not configured yet.
 libedata-cal1.2-6 depends on libgnome2-0 (>= 2.17.3); however:
dpkg: dependency problems prevent configuration of libgnomevfs2-extra:
 libgnomevfs2-extra depends on libgnomevfs2-0 (>= 1:2.17.90); however:
  Package libgnomevfs2-0 is not configured yet.
Setting up libxfont1 (1:1.3.3-1ubuntu1) ...
Setting up xserver-common (2:1.5.2-2ubuntu3.1) ...
Setting up libpciaccess0 (0.10.3-1) ...
  Package libebook1.2-9 is not configured yet.
 libedata-book1.2-2 depends on libgnome2-0 (>= 2.17.3); however:
  Package libgnome2-0 is not configured yet.
dpkg: error processing libedata-book1.2-2 (--configure):
dpkg: dependency problems prevent configuration of libedata-cal1.2-6:
 libedata-cal1.2-6 depends on libecal1.2-7 (>= 2.24.3); however:
  Package libecal1.2-7 is not configured yet.
 libedata-cal1.2-6 depends on libgnome2-0 (>= 2.17.3); however:
dpkg: error processing libedata-cal1.2-6 (--configure):
dpkg: too many errors, stopping
dpkg: ../../src/packages.c:265: process_queue: Assertion `!queue.length' failed.
Traceback (most recent call last):
  File "/usr/lib/python2.5/logging/__init__.py", line 753, in emit
    self.flush()
  File "/usr/lib/python2.5/logging/__init__.py", line 731, in flush
    self.stream.flush()
IOError: [Errno 9] Bad file descriptor
dpkg: dependency problems prevent configuration of libedata-book1.2-2:
 libedata-book1.2-2 depends on libebook1.2-9 (>= 2.24.3); however:
Setting up libopal-2.2 (2.2.11~dfsg1-4ubuntu1) ...
Setting up libebackend1.2-0 (2.24.3-0ubuntu1) ...
Setting up libspeexdsp1 (1.2~beta4-2) ...
Setting up libpt-1.10.10-plugins-v4l (1.10.10-2ubuntu3) ...
Setting up libpt-1.10.10-plugins-v4l2 (1.10.10-2ubuntu3) ...
Setting up libpt-1.10.10 (1.10.10-2ubuntu3) ...
dpkg: error processing libgnomevfs2-extra (--configure):
Setting up libpt-1.10.10-plugins-alsa (1.10.10-2ubuntu3) ...
dpkg: dependency problems prevent configuration of libgnomevfs2-extra:
 libgnomevfs2-extra depends on libgnomevfs2-0 (>= 1:2.17.90); however:
  Package libgnomevfs2-0 is not configured yet.
 libedata-cal1.2-6 depends on libecal1.2-7 (>= 2.24.3); however:
  Package libecal1.2-7 is not configured yet.
 libedata-cal1.2-6 depends on libgnome2-0 (>= 2.17.3); however:
dpkg: error processing libedata-cal1.2-6 (--configure):
dpkg: too many errors, stopping
dpkg: ../../src/packages.c:265: process_queue: Assertion `!queue.length' failed.
Traceback (most recent call last):
  File "/usr/lib/python2.5/logging/__init__.py", line 753, in emit
    self.flush()
  File "/usr/lib/python2.5/logging/__init__.py", line 731, in flush
Setting up libspeexdsp1 (1.2~beta4-2) ...
Setting up libpt-1.10.10-plugins-v4l (1.10.10-2ubuntu3) ...
Setting up libpt-1.10.10-plugins-v4l2 (1.10.10-2ubuntu3) ...
Setting up libpt-1.10.10 (1.10.10-2ubuntu3) ...
dpkg: error processing libgnomevfs2-extra (--configure):
Setting up libpt-1.10.10-plugins-alsa (1.10.10-2ubuntu3) ...
dpkg: error processing libedata-cal1.2-6 (--configure):
dpkg: too many errors, stopping
dpkg: ../../src/packages.c:265: process_queue: Assertion `!queue.length' failed.
Traceback (most recent call last):
Setting up libpt-1.10.10-plugins-v4l (1.10.10-2ubuntu3) ...
Setting up libpt-1.10.10-plugins-v4l2 (1.10.10-2ubuntu3) ...
Setting up libpt-1.10.10 (1.10.10-2ubuntu3) ...

ProblemType: Package
Architecture: i386
DistroRelease: Ubuntu 8.04
ErrorMessage:
 ErrorMessage: pre-dependency problem - not installing cups-pdf
Package: cups-pdf 2.4.6-4ubuntu2
SourcePackage: cups-pdf
Title: package cups-pdf 2.4.6-4ubuntu2 failed to install/upgrade:
Uname: Linux 2.6.24-24-generic i686

thierman (thierman) wrote :
Michael Vogt (mvo) wrote :

Here is what is causing the error:

Unpacking replacement libpam0g ...
Setting up libpam0g (1.0.1-4ubuntu5.5) ...
Checking for services that may need to be restarted...Checking init scripts...
debconf: Unable to load Debconf::Element::Gnome::String. Failed because: Can't locate I18N/Langinfo.pm in @INC (@INC contains: /etc/perl /usr/local/lib/perl/5.8.8 /usr/local/share/perl/5.8.8 /usr/lib/perl5 /usr/share/perl5 /usr/lib/perl/5.8 /usr/share/perl/5.8 /usr/local/lib/site_perl .) at /usr/share/perl5/Debconf/Element/Gnome.pm line 7, <GEN1> line 4.
BEGIN failed--compilation aborted at /usr/share/perl5/Debconf/Element/Gnome.pm line 7, <GEN1> line 4.
Compilation failed in require at (eval 23) line 3, <GEN1> line 4.
        ...propagated at /usr/share/perl/5.8/base.pm line 84, <GEN1> line 4.
BEGIN failed--compilation aborted at /usr/share/perl5/Debconf/Element/Gnome/String.pm line 10, <GEN1> line 4.
Compilation failed in require at (eval 22) line 2, <GEN1> line 4.
BEGIN failed--compilation aborted at (eval 22) line 2, <GEN1> line 4.

Can't locate object method "new" via package "Debconf::Element::Gnome::String" at /usr/share/perl5/Debconf/FrontEnd.pm line 68, <GEN1> line 4.
/usr/share/debconf/confmodule: line 42: printf: write error: Broken pipe
/usr/share/debconf/confmodule: line 42: printf: write error: Broken pipe
dpkg: error processing libpam0g (--configure):
 subprocess post-installation script returned error exit status 2

It seems to be a problem with the gnome frontend of debconf crashing.

affects: update-manager (Ubuntu) → debconf (Ubuntu)
Changed in debconf (Ubuntu):
status: New → Confirmed
Colin Watson (cjwatson) wrote :

This is pretty odd; Michael, I'd appreciate your further thoughts if you have a chance. The reason Debconf::Element::Gnome::String fails to load is that perl was just upgraded from 5.8 to 5.10, and so all the modules it contains moved to a different directory, but perl-base hasn't yet been upgraded so @INC still points to 5.8. Moving I18N::Langinfo to perl-base might help, although since we're still using the old perl-base that won't make any difference on its own since we don't have a time machine.

Now, as far as I can tell, Debconf::Element::Gnome doesn't actually use the symbols it imports from I18N::Langinfo! Thus, there's an obvious workaround of removing this 'use' statement from Debconf::Element::Gnome, and I'll look into that. However, we're still using the old debconf at this point in the upgrade. Is there anything that can be done about that?

Michael Vogt (mvo) wrote :

a workaround is to patch out the "use I18N::Langinfo" if its not used when the upgrade starts. I will add code for this to update-manager.

Changed in update-manager (Ubuntu):
milestone: none → karmic-alpha-6
importance: Undecided → Medium
assignee: nobody → Michael Vogt (mvo)
Changed in cups-pdf (Ubuntu):
status: New → Invalid
Changed in update-manager (Ubuntu):
status: New → Won't Fix
status: Won't Fix → Triaged
Michael Vogt (mvo) on 2009-09-15
Changed in update-manager (Ubuntu):
status: Triaged → Fix Committed
Launchpad Janitor (janitor) wrote :

This bug was fixed in the package update-manager - 1:0.125.2

---------------
update-manager (1:0.125.2) karmic; urgency=low

  [ Michael Vogt ]
  * DistUpgrade/DistUpgradeCache.py:
    - add check for 5Mb safety buffer in /tmp, this ensures that
      dkms can run and ensure we do not run when /tmp is mounted
      in overflow mode (LP: #427035)
  * data/glade/UpdateManager.ui:
    - remove dialog title for the battery warning and fix button
      order (thanks to Matthew Paul Thomas)
  * data/glade/UpdateManager.ui:
    - fix duplicated accelerator keys (LP: #425817)
  * UpdateManager/UpdateManager.py:
    - close app when ESC is pressed in the battery warning
  * UpdateManager/UpdateManager.py:
    - ensure that the changelog always matches the currently selected
      pkg by fixing race during download (LP: #424918)
  * UpdateManager/backend/InstallBackendAptdaemon.py:
    - do not hang when cancel is clicked (LP: #426718)
  * add sed patch facility and patch the gnome debconf frontend
    before the upgrade starts so that it can not crash when
    perl moves from 5.8.0 to 5.10.0 (LP: #387112)
  * data/glade/UpdateManager.ui:
    - use bigger default width (LP: #418201)

  [ Brian Murray ]
  * typo fixes (thanks to Brian Murray, LP: #423409)

 -- Michael Vogt <email address hidden> Tue, 15 Sep 2009 10:50:24 +0200

Changed in update-manager (Ubuntu):
status: Fix Committed → Fix Released
Launchpad Janitor (janitor) wrote :

This bug was fixed in the package debconf - 1.5.27ubuntu2

---------------
debconf (1.5.27ubuntu2) karmic; urgency=low

  * Backport from trunk:
    - Remove unused 'use I18N::Langinfo' from Debconf::Element::Gnome
      (LP: #387112).

 -- Colin Watson <email address hidden> Fri, 02 Oct 2009 10:11:27 +0100

Changed in debconf (Ubuntu):
status: Confirmed → Fix Released
Colin Watson (cjwatson) on 2010-02-04
Changed in cups-pdf (Ubuntu Hardy):
status: New → Invalid
Changed in cups-pdf (Ubuntu Intrepid):
status: New → Invalid
Changed in cups-pdf (Ubuntu Jaunty):
status: New → Invalid
Colin Watson (cjwatson) wrote :

We should SRU the debconf change to assist upgrades from hardy/intrepid/jaunty. It might not hurt to SRU the corresponding update-manager changes to intrepid/jaunty as well. (Do we need it in karmic?)

Changed in update-manager (Ubuntu Hardy):
status: New → Invalid
Steve Langasek (vorlon) wrote :

The window when it's useful to SRU this for hardy is shrinking; Colin, can you take care of this in debconf or should I?

Alex Valavanis (valavanisalex) wrote :

Intrepid Ibex reached end-of-life on 30 April 2010 so I am closing the report. The bug has been fixed in newer releases of Ubuntu.

Changed in debconf (Ubuntu Intrepid):
status: New → Invalid
Changed in update-manager (Ubuntu Intrepid):
status: New → Invalid
Download full text (15.2 KiB)

Hi,
I didn't have the issue till I tried to install 10.04 LTS - Lucid Lynx. It all installed except for ubuntustudio-audio v0.07 and it keeps failing on the update of it now. It says it has a broken package. My audio still works OK.

Error E: /var/cache/apt/archives/ubuntustudio-audio_0.70_i386.deb: subprocess new pre-removal script returned error exit status 1

ImportError: No module named changesettings

Then the package fails to install.

Thanks,
Tom

> Date: Fri, 7 May 2010 23:40:24 +0000
> From: <email address hidden>
> To: <email address hidden>
> Subject: [Bug 387112] Re: package cups-pdf 2.4.6-4ubuntu2 failed to install/upgrade:
>
> Intrepid Ibex reached end-of-life on 30 April 2010 so I am closing the
> report. The bug has been fixed in newer releases of Ubuntu.
>
> ** Changed in: debconf (Ubuntu Intrepid)
> Status: New => Invalid
>
> ** Changed in: update-manager (Ubuntu Intrepid)
> Status: New => Invalid
>
> --
> package cups-pdf 2.4.6-4ubuntu2 failed to install/upgrade:
> https://bugs.launchpad.net/bugs/387112
> You received this bug notification because you are a direct subscriber
> of a duplicate bug.
>
> Status in “cups-pdf” package in Ubuntu: Invalid
> Status in “debconf” package in Ubuntu: Fix Released
> Status in “update-manager” package in Ubuntu: Fix Released
> Status in “cups-pdf” source package in Hardy: Invalid
> Status in “debconf” source package in Hardy: New
> Status in “update-manager” source package in Hardy: Invalid
> Status in “cups-pdf” source package in Intrepid: Invalid
> Status in “debconf” source package in Intrepid: Invalid
> Status in “update-manager” source package in Intrepid: Invalid
> Status in “cups-pdf” source package in Jaunty: Invalid
> Status in “debconf” source package in Jaunty: New
> Status in “update-manager” source package in Jaunty: New
>
> Bug description:
> Binary package hint: cups-pdf
>
> Cups failed to install siteing dependacy problems preventing configuration
> root@thierman-desktop:/etc/dhcp3# lsb_release -rd
> Description: Ubuntu 8.04.2
> Release: 8.04
>
> root@thierman-desktop:/var/log# tail dpkg.log
> 2009-06-14 10:57:07 status half-configured libspeexdsp1 1.2~beta4-2
> 2009-06-14 10:57:07 status installed libspeexdsp1 1.2~beta4-2
> 2009-06-14 10:57:07 configure libopal-2.2 2.2.11~dfsg1-4ubuntu1 2.2.11~dfsg1-4ubuntu1
> 2009-06-14 10:57:07 status unpacked libopal-2.2 2.2.11~dfsg1-4ubuntu1
> 2009-06-14 10:57:07 status half-configured libopal-2.2 2.2.11~dfsg1-4ubuntu1
> 2009-06-14 10:57:07 status installed libopal-2.2 2.2.11~dfsg1-4ubuntu1
> 2009-06-14 10:57:07 configure libebackend1.2-0 2.24.3-0ubuntu1 2.24.3-0ubuntu1
> 2009-06-14 10:57:07 status unpacked libebackend1.2-0 2.24.3-0ubuntu1
> 2009-06-14 10:57:07 status half-configured libebackend1.2-0 2.24.3-0ubuntu1
> 2009-06-14 10:57:07 status installed libebackend1.2-0 2.24.3-0ubuntu1
>
> Output from term.log:
>
> Setting up libebackend1.2-0 (2.24.3-0ubuntu1) ...
> dpkg: dependency problems prevent configuration of libedata-book1.2-2:
> libedata-book1.2-2 depends on libebook1.2-9 (>= 2.24.3); however:
> Package libebook1.2-9 is not configured yet.
> libedata-book1.2-2 depends on libgnom...

I'm closing the task for Jaunty which has reached EOL.

Changed in debconf (Ubuntu Jaunty):
status: New → Won't Fix
Changed in update-manager (Ubuntu Jaunty):
status: New → Won't Fix
Rolf Leggewie (r0lf) wrote :

Hardy has seen the end of its life and is no longer receiving any updates. Marking the Hardy task for this ticket as "Won't Fix".

Changed in debconf (Ubuntu Hardy):
status: New → Won't Fix
To post a comment you must log in.