/usr/share/ppd/cups-pdf/PostscriptColor.ppd disappeared but postinst still uses it

Bug #241701 reported by Colin Watson on 2008-06-20
2
Affects Status Importance Assigned to Milestone
cups-pdf (Ubuntu)
High
Unassigned

Bug Description

Binary package hint: cups-pdf

On a fresh install from an Intrepid daily CD image:

Setting up cups-pdf (2.4.7-3ubuntu1) ...
grep: /etc/cups/printers.conf: No such file or directory
cp: cannot stat `/usr/share/ppd/cups-pdf/PostscriptColor.ppd': No such file or directory
dpkg: error processing cups-pdf (--configure):
 subprocess post-installation script returned error exit status 1

The cp error causes installations to fail; and indeed http://launchpadlibrarian.net/15190844/cups-pdf_2.4.6-4ubuntu2_2.4.7-3ubuntu1.diff.gz shows that PostscriptColor.ppd has gone away. The postinst still mentions it in two places, though.

Related branches

Colin Watson (cjwatson) on 2008-06-20
Changed in cups-pdf:
importance: Undecided → High
milestone: none → intrepid-alpha-1
Martin-Éric Racine (q-funk) wrote :

The file was renamed to CUPS-PDF.PPD by upstream, a while ago. You can find the original file in the source tarball's "extra" directory.

Ubuntu needs to upgrade its postinst and postrm to match.

Debian doesn't have this issue, because they don't attempt to automatically add the PDF queue to CUPS.

Launchpad Janitor (janitor) wrote :

This bug was fixed in the package cups-pdf - 2.4.8-1ubuntu1

---------------
cups-pdf (2.4.8-1ubuntu1) intrepid; urgency=low

  * Merge from debian unstable, remaining changes:
    - debian/postinst, debian/prerm: Let PDF print queue being created
      automatically when installing the package and being removed
      automatically when uninstalling the package.
  * debian/postinst: Updated PPD file name to the new one used by the
    upstream package (LP: #241701). Updated the name of t5he CUPS startup
    script to "cups".

cups-pdf (2.4.8-1) unstable; urgency=low

  * New upstream release (Closes: #472631).

cups-pdf (2.4.7-4) unstable; urgency=low

  * Dropped references to gs-esp and cupsys in Depends and Recommends,
    now that the CUPS renaming is done, on time for Lenny.

 -- Till Kamppeter <email address hidden> Mon, 23 Jun 2008 15:42:30 +0200

Changed in cups-pdf:
status: New → Fix Released
To post a comment you must log in.
This report contains Public information  Edit
Everyone can see this information.

Other bug subscribers