9.26~dfsg+0-0ubuntu0.18.04.9 breaks cups printing of pdf

Bug #1828401 reported by supremesyntax
56
This bug affects 13 people
Affects Status Importance Assigned to Milestone
cups-filters (Ubuntu)
Fix Released
High
Unassigned
Xenial
Fix Released
High
Marc Deslauriers
Bionic
Fix Released
High
Marc Deslauriers
Cosmic
Fix Released
High
Marc Deslauriers

Bug Description

Distributor ID: Ubuntu
Description: Ubuntu 18.04.2 LTS
Release: 18.04
Codename: bionic

PROBLEM:
9.26~dfsg+0-0ubuntu0.18.04.9 breaks printing pdf on cups

error in cups logs:

...
D [09/May/2019:13:44:33 +0200] [Job 68] GPL Ghostscript 9.26: Unrecoverable error, exit code 1
D [09/May/2019:13:44:33 +0200] [Job 68] Process is dying with \"Unable to determine number of pages, page count: -1
D [09/May/2019:13:44:33 +0200] [Job 68] \", exit stat 3
...

details of this bug here: https://bugs.archlinux.org/task/62251

POSSIBLE SOLUTION:
release an update of cups-filters to 1.22.5

WORKAROUND:
downgrade ghostscript to 9.22~dfsg+1-0ubuntu1

sudo apt install ghostscript=9.22~dfsg+1-0ubuntu1 libgs9=9.22~dfsg+1-0ubuntu1 libgs9-common=9.22~dfsg+1-0ubuntu1 ghostscript-x=9.22~dfsg+1-0ubuntu1

Revision history for this message
Jay (jayram1989) wrote :

It's affected for me also. Downgrading to previous version fixing the issue. Please provide fix in the next release? When can we expect the next fix release?

Revision history for this message
Launchpad Janitor (janitor) wrote :

Status changed to 'Confirmed' because the bug affects multiple users.

Changed in ghostscript (Ubuntu):
status: New → Confirmed
Revision history for this message
DJ Molny (djmolny) wrote :

The workaround in the original post fixed the problem. Many thanks to supremesyntax!

Revision history for this message
Jay (jayram1989) wrote :

Please fix this problem asap, we have more than 100 people using 18.02 LTS. Please treat this as high priority.

affects: ghostscript (Ubuntu) → cups-filters (Ubuntu)
Changed in cups-filters (Ubuntu):
importance: Undecided → High
status: Confirmed → Fix Released
Changed in cups-filters (Ubuntu Bionic):
importance: Undecided → High
status: New → Triaged
Revision history for this message
Marc Deslauriers (mdeslaur) wrote :

I will release updates for this regression today.

Changed in cups-filters (Ubuntu Cosmic):
status: New → In Progress
Changed in cups-filters (Ubuntu Bionic):
status: Triaged → In Progress
Changed in cups-filters (Ubuntu Cosmic):
importance: Undecided → High
Changed in cups-filters (Ubuntu Bionic):
assignee: nobody → Marc Deslauriers (mdeslaur)
Changed in cups-filters (Ubuntu Cosmic):
assignee: nobody → Marc Deslauriers (mdeslaur)
Changed in cups-filters (Ubuntu Xenial):
status: New → In Progress
importance: Undecided → High
assignee: nobody → Marc Deslauriers (mdeslaur)
Revision history for this message
Reinhard (reinhard-fink) wrote :

Thanks a lot for error report and fast and working WORKAROUND!

In school we have our most important exams, so blocking printers produce a lot of bad mood, especially, if the whole house runs under Linux.

For my automatic updates I had to add --allow-downgrades to the workaround.

>>apt-get -y --allow-downgrades install ...

Thanks!

Revision history for this message
Launchpad Janitor (janitor) wrote :

This bug was fixed in the package cups-filters - 1.20.2-0ubuntu3.1

---------------
cups-filters (1.20.2-0ubuntu3.1) bionic-security; urgency=medium

  * Fix PDF printing regression caused by latest Ghostscript security
    updates (LP: #1828401)
    - debian/patches/lp1828401.patch: don't use undocumented Ghostscript
      function in filter/foomatic-rip/pdf.c.

 -- Marc Deslauriers <email address hidden> Thu, 09 May 2019 10:48:58 -0400

Changed in cups-filters (Ubuntu Bionic):
status: In Progress → Fix Released
Revision history for this message
Launchpad Janitor (janitor) wrote :

This bug was fixed in the package cups-filters - 1.8.3-2ubuntu3.5

---------------
cups-filters (1.8.3-2ubuntu3.5) xenial-security; urgency=medium

  * Fix PDF printing regression caused by latest Ghostscript security
    updates (LP: #1828401)
    - debian/patches/lp1828401.patch: don't use undocumented Ghostscript
      function in filter/foomatic-rip/pdf.c.

 -- Marc Deslauriers <email address hidden> Thu, 09 May 2019 10:49:44 -0400

Changed in cups-filters (Ubuntu Xenial):
status: In Progress → Fix Released
Revision history for this message
Launchpad Janitor (janitor) wrote :

This bug was fixed in the package cups-filters - 1.21.3-1ubuntu0.1

---------------
cups-filters (1.21.3-1ubuntu0.1) cosmic-security; urgency=medium

  * Fix PDF printing regression caused by latest Ghostscript security
    updates (LP: #1828401)
    - debian/patches/lp1828401.patch: don't use undocumented Ghostscript
      function in filter/foomatic-rip/pdf.c.

 -- Marc Deslauriers <email address hidden> Thu, 09 May 2019 10:45:25 -0400

Changed in cups-filters (Ubuntu Cosmic):
status: In Progress → Fix Released
Revision history for this message
Matt Walters (matt.walters) wrote :

Cups 1.20.2 resolved the issue on Bionic for me. Thank you.

Revision history for this message
supremesyntax (supremesyntax) wrote :

Thanks guys!

To post a comment you must log in.
This report contains Public information  
Everyone can see this information.

Duplicates of this bug

Other bug subscribers