PWG Raster printing on IPP Everywhere printers not working correctly

Bug #1637583 reported by Till Kamppeter on 2016-10-28
8
This bug affects 1 person
Affects Status Importance Assigned to Milestone
cups-filters (Ubuntu)
High
Unassigned
Yakkety
High
Unassigned
ghostscript (Ubuntu)
High
Unassigned
Yakkety
High
Unassigned

Bug Description

Printers conforming to the new IPP Everywhere standard (of the Printing Working Group, PWG, http://www.pwg.org/) are starting to come onto the market. These printers are capable to inform the clients computers about all their capabilities (paper sizes, resolutions, finishers, ...) via IPP and understand known standard page description languages (always PWG Raster, but can also understand PostScript, PDF, JPEG, and/or PCL). So no drivers for these printers are needed. With CUPS, cups-filters, and one of Ghostscript, Poppler, or MuPDF they are fully supported.

Yakkety is intended to support them, but getting my hands on an IPP Everywhere printer (which takes PWG Raster as inpout format) I have found some issues:

- CUPS selects a filter chain using MuPDF but MuPDF is not installed by default.

- In contrary to CUPS Raster, PWG Raster contains a full page bitmap of the page, including the unprintable margins. Margins in the header are set to zero.

- Filter chains could send CUPS Raster instead of PWG Raster.

- Printed pages are not logged in /var/log/cups/page_log.

All these issued are fixed in cups-filters 1.11.5 and in a patch to Ghostscript (already upstream).

This bug report is for an SRU for Yakkety to fix the issues also there.

[Impact]

With "CreateIPPPrinterQueues Yes" set in /etc/cups/cups-browsed.conf IPP Everywhere printers are discovered in the network and automatically set up but they only print if mutool (package mupdf-tools) is installed. This leaves users with non-working print queues.

[Testcase]

Set "CreateIPPPrinterQueues Yes" in /etc/cups/cups-browsed.conf and restart cups-browsed. If an IPP Everywhere printer is in the network, it will be detected but you cannot print on the auto-generated queue. After installing the mupdf-tools package printing works.

With the fixed cups-filters and Ghostscript installed mupdf-tools is not needed. Jobs get filtered via Ghostscript and printing on the IPP Everywhere printer works.

[Regression Potential]

Small, as changes in the filter chain only happen if PWG Raster is involved and this happens only with IPP Everywhere printers. Only the output of PWG Raster and not of any other format is modified.

description: updated
Changed in cups-filters (Ubuntu):
importance: Undecided → High
Changed in cups-filters (Ubuntu Yakkety):
importance: Undecided → High
Changed in ghostscript (Ubuntu):
importance: Undecided → High
Changed in ghostscript (Ubuntu Yakkety):
importance: Undecided → High
Launchpad Janitor (janitor) wrote :

This bug was fixed in the package ghostscript - 9.19~dfsg+1-0ubuntu7

---------------
ghostscript (9.19~dfsg+1-0ubuntu7) zesty; urgency=medium

  * debian/patches/020161028~0726780_gdevcups-pwgraster-bitmap-always-without-margins.patch:
    "cups" output device: When creating PWG Raster output, always output
    the bitmap of the full page, ignoring any unprintable margins suggested
    by the PPD file (LP: #1637583).

 -- Till Kamppeter <email address hidden> Fri, 28 Oct 2016 16:00:00 -0200

Changed in ghostscript (Ubuntu):
status: New → Fix Released
Till Kamppeter (till-kamppeter) wrote :

Fixed upstream in cups-filters 1.11.6 which is in Zesty now.

Changed in cups-filters (Ubuntu):
status: New → Fix Released
Till Kamppeter (till-kamppeter) wrote :

Uploaded fixed packages of cups-filters and ghostscript to yakkety-proposed.

Changed in cups-filters (Ubuntu Yakkety):
status: New → In Progress
Changed in ghostscript (Ubuntu Yakkety):
status: New → In Progress
Till Kamppeter (till-kamppeter) wrote :

SRU team: debdiff for cups-filters attached.

Till Kamppeter (till-kamppeter) wrote :

SRU team: debdiff for ghostscript attached.

Till Kamppeter (till-kamppeter) wrote :

debdiff for cups-filters updated.

Hello Till, or anyone else affected,

Accepted ghostscript into yakkety-proposed. The package will build now and be available at https://launchpad.net/ubuntu/+source/ghostscript/9.19~dfsg+1-0ubuntu6.1 in a few hours, and then in the -proposed repository.

Please help us by testing this new package. See https://wiki.ubuntu.com/Testing/EnableProposed for documentation how to enable and use -proposed. Your feedback will aid us getting this update out to other Ubuntu users.

If this package fixes the bug for you, please add a comment to this bug, mentioning the version of the package you tested, and change the tag from verification-needed to verification-done. If it does not fix the bug for you, please add a comment stating that, and change the tag to verification-failed. In either case, details of your testing will help us make a better decision.

Further information regarding the verification process can be found at https://wiki.ubuntu.com/QATeam/PerformingSRUVerification . Thank you in advance!

Changed in ghostscript (Ubuntu Yakkety):
status: In Progress → Fix Committed
tags: added: verification-needed
Brian Murray (brian-murray) wrote :

Hello Till, or anyone else affected,

Accepted cups-filters into yakkety-proposed. The package will build now and be available at https://launchpad.net/ubuntu/+source/cups-filters/1.11.4-0ubuntu2.1 in a few hours, and then in the -proposed repository.

Please help us by testing this new package. See https://wiki.ubuntu.com/Testing/EnableProposed for documentation how to enable and use -proposed. Your feedback will aid us getting this update out to other Ubuntu users.

If this package fixes the bug for you, please add a comment to this bug, mentioning the version of the package you tested, and change the tag from verification-needed to verification-done. If it does not fix the bug for you, please add a comment stating that, and change the tag to verification-failed. In either case, details of your testing will help us make a better decision.

Further information regarding the verification process can be found at https://wiki.ubuntu.com/QATeam/PerformingSRUVerification . Thank you in advance!

Changed in cups-filters (Ubuntu Yakkety):
status: In Progress → Fix Committed
tags: added: verification-done
removed: verification-needed
Till Kamppeter (till-kamppeter) wrote :

Installed and tested the cups-filters and ghostscript packages from yakkety-proposed. Printed several jobs on different (emulated) IPP Everywhere printers (PWG-Raster-only, PDF, color, bw, ...). All print without using mutool (using Ghostscript instead). Outcoming files are correct (borderless PWG Raster or PDF). cups-browsed auto-creates the appropriate print queues when an IPP Everywhere printer is present in the local network.

Everything working as intended. SRU verified.

Page logging in /var/log/cups/page_log works also correctly.

The verification of the Stable Release Update for cups-filters has completed successfully and the package has now been released to -updates. Subsequently, the Ubuntu Stable Release Updates Team is being unsubscribed and will not receive messages about this bug report. In the event that you encounter a regression using the package from -updates please report a new bug using ubuntu-bug and tag the bug report regression-update so we can easily find any regressions.

Launchpad Janitor (janitor) wrote :

This bug was fixed in the package ghostscript - 9.19~dfsg+1-0ubuntu6.1

---------------
ghostscript (9.19~dfsg+1-0ubuntu6.1) yakkety-proposed; urgency=medium

  * debian/patches/020161028~0726780_gdevcups-pwgraster-bitmap-always-without-margins.patch:
    "cups" output device: When creating PWG Raster output, always output
    the bitmap of the full page, ignoring any unprintable margins suggested
    by the PPD file (LP: #1637583).

 -- Till Kamppeter <email address hidden> Mon, 14 Nov 2016 17:37:00 -0200

Changed in ghostscript (Ubuntu Yakkety):
status: Fix Committed → Fix Released
Launchpad Janitor (janitor) wrote :

This bug was fixed in the package cups-filters - 1.11.4-0ubuntu2.1

---------------
cups-filters (1.11.4-0ubuntu2.1) yakkety-proposed; urgency=medium

  * cups-browsed, gstoraster, pdftoraster: Assorted fixes to make IPP
    Everywhere printers correctly working (LP: #1637583):
    - MIME conversion rules for PWG Raster output using gstoraster and
      pdftoraster.
    - Let gstoraster and pdftoraster output PWG Raster instead of CUPS
      Raster for IPP Everywhere printers.
    - Let pdftoraster generate correct PWG Raster (full page bitmaps
      without removal of unprintable borders).
    - Let pdftopdf log the pages of PWG Raster jobs in page_log.
    - Let cups-browsed also auto-create queues only for IPP Everywhere
      printers and not for legacy IPP printers.

 -- Till Kamppeter <email address hidden> Mon, 14 Nov 2016 19:00:00 -0200

Changed in cups-filters (Ubuntu Yakkety):
status: Fix Committed → Fix Released
To post a comment you must log in.
This report contains Public information  Edit
Everyone can see this information.

Other bug subscribers