Unable to print to Konica Minolta bizhub C253 printer (and other Konica Minolta, Minolta, Brother, and old HP LaserJet)

Bug #1326295 reported by Adam Niedling on 2014-06-04
14
This bug affects 2 people
Affects Status Importance Assigned to Milestone
cups-filters (Ubuntu)
Undecided
Unassigned
Trusty
Undecided
Unassigned

Bug Description

This bug was already fixed in Ubuntu 13.10 but it is broken again in 14.04. The printer freezes right after I try to print something.
The original report is bug #1053443.

[Impact]
Several PostScript printers do not work with the PostScript generated by Ghostscript but do not have problems with the PostScript from Poppler. In 14.04 the auto-switching to Poppler for these cases is missing, making printers from Brother, Minolta, Konica Minolta, and old HP LaserJets misbehave. Some Konica Minolta even crash and need to get turned off and turned on again.

[Test Case]
Print on any Brother, Minolta, Konica Minolta, or old HP LaserJet with Ubuntu 14.04. This will not work as always Ghostscript is used to generate PostScript. The proposed package re-activates the switching mechanism to use Poppler for these printers, so you will be able to print.

[Regression Potential]
None, as we had the switching mechanism already in 13.10.

ProblemType: Bug
DistroRelease: Ubuntu 14.04
Package: cups-filters 1.0.52-0ubuntu1.1
ProcVersionSignature: Ubuntu 3.13.0-27.50-generic 3.13.11
Uname: Linux 3.13.0-27-generic x86_64
ApportVersion: 2.14.1-0ubuntu3.2
Architecture: amd64
Date: Wed Jun 4 10:54:55 2014
InstallationDate: Installed on 2013-07-22 (316 days ago)
InstallationMedia: Ubuntu 13.04 "Raring Ringtail" - Release amd64 (20130424)
Lpstat:
 device for KONICA-MINOLTA-C353-Series: dnssd://KONICA%20MINOLTA%20bizhub%20C253(5D%3A9C%3A78)._pdl-datastream._tcp.local/
 device for Samsung-ML-1640-Series: usb://Samsung/ML-1640%20Series?serial=144QBACQC10705R.
 device for windows_printer: winp://NIEDLING-5A803D/print
MachineType: Acer V5-171
Papersize: a4
PpdFiles:
 Samsung-ML-1640-Series: Samsung ML-1640, 2.0.0
 KONICA-MINOLTA-C353-Series: KONICA MINOLTA C353 Series PS(P)
 windows_printer: Acrobat Distiller 3011.104
 adist5: Acrobat Distiller 3011.104
ProcEnviron:
 LANGUAGE=hu
 TERM=xterm
 PATH=(custom, no user)
 LANG=hu_HU.UTF-8
 SHELL=/bin/bash
ProcKernelCmdLine: BOOT_IMAGE=/vmlinuz-3.13.0-27-generic root=/dev/mapper/ubuntu--vg-root ro quiet splash vt.handoff=7
SourcePackage: cups-filters
UpgradeStatus: Upgraded to trusty on 2014-05-07 (27 days ago)
dmi.bios.date: 03/22/2013
dmi.bios.vendor: Acer
dmi.bios.version: V2.17
dmi.board.asset.tag: Type2 - Board Asset Tag
dmi.board.name: Mimic
dmi.board.vendor: Acer
dmi.board.version: Type2 - Board Version
dmi.chassis.type: 10
dmi.chassis.vendor: Acer
dmi.chassis.version: V2.17
dmi.modalias: dmi:bvnAcer:bvrV2.17:bd03/22/2013:svnAcer:pnV5-171:pvrV2.17:rvnAcer:rnMimic:rvrType2-BoardVersion:cvnAcer:ct10:cvrV2.17:
dmi.product.name: V5-171
dmi.product.version: V2.17
dmi.sys.vendor: Acer

Adam Niedling (krychek) wrote :
Adam Niedling (krychek) wrote :

This workaround fixes the problem:
lpadmin -p <printer> -o pdftops-renderer-default=pdftops

Changed in cups-filters (Ubuntu):
status: New → Fix Committed
Changed in cups-filters (Ubuntu Trusty):
status: New → Triaged
description: updated
summary: - Unable to print to Konica Minolta bizhub C253 printer
+ Unable to print to Konica Minolta bizhub C253 printer (and other Konica
+ Minolta, Minolta, Brother, and old HP LaserJet)
Till Kamppeter (till-kamppeter) wrote :

Uploaded fixed package to trusty-proposed (cups-filters 1.0.52-0ubuntu1.2). Please stand by until the package gets approved and available for testing. Then instructions for testing will posted here. Please test then and report your results here as this is required for the proposed fix to get an official update.

Thanks in advance.

To the SRU team: debdiff attached.

Changed in cups-filters (Ubuntu Trusty):
status: Triaged → In Progress
Till Kamppeter (till-kamppeter) wrote :

To the SRU team: The fix for Utopic is currently being uploaded to Debian and will be auto-synced into Ubvuntu.

Hello Adam, or anyone else affected,

Accepted cups-filters into trusty-proposed. The package will build now and be available at http://launchpad.net/ubuntu/+source/cups-filters/1.0.52-0ubuntu1.2 in a few hours, and then in the -proposed repository.

Please help us by testing this new package. See https://wiki.ubuntu.com/Testing/EnableProposed for documentation how to enable and use -proposed. Your feedback will aid us getting this update out to other Ubuntu users.

If this package fixes the bug for you, please add a comment to this bug, mentioning the version of the package you tested, and change the tag from verification-needed to verification-done. If it does not fix the bug for you, please add a comment stating that, and change the tag to verification-failed. In either case, details of your testing will help us make a better decision.

Further information regarding the verification process can be found at https://wiki.ubuntu.com/QATeam/PerformingSRUVerification . Thank you in advance!

Changed in cups-filters (Ubuntu Trusty):
status: In Progress → Fix Committed
tags: added: verification-needed
Adam Niedling (krychek) wrote :

I did the testing following the instructions step by step and the problem is fixed by the new version of cups-filters. Great!

cups-filters 1.0.52-0ubuntu1.2

tags: added: verification-done
removed: verification-needed
Launchpad Janitor (janitor) wrote :

This bug was fixed in the package cups-filters - 1.0.53-2

---------------
cups-filters (1.0.53-2) unstable; urgency=medium

  * Re-added ./configure option "--with-pdftops=hybrid" to activate the hybrid
    rendering mode
    (LP: #238129, #293832, #1072915, #1053443, #1097105, #1205898, #1326295)

 -- Till Kamppeter <email address hidden> Wed, 4 Jun 2014 12:08:06 +0200

Changed in cups-filters (Ubuntu):
status: Fix Committed → Fix Released
Serhiy Yakovyn (syakovyn) wrote :

The bug fixed for me too

Dzintars Rajevs (dzy-8) wrote :

I did the testing too and now Konica Minolta C253 actually prints the documents instead of blank pages.
Tested package: cups-filters 1.0.52-0ubuntu1.2

Launchpad Janitor (janitor) wrote :

This bug was fixed in the package cups-filters - 1.0.52-0ubuntu1.2

---------------
cups-filters (1.0.52-0ubuntu1.2) trusty-proposed; urgency=low

  * Re-added ./configure option "--with-pdftops=hybrid" to activate
    the hybrid rendering mode (LP: #1326295).
 -- Till Kamppeter <email address hidden> Wed, 4 Jun 2014 12:08:06 +0200

Changed in cups-filters (Ubuntu Trusty):
status: Fix Committed → Fix Released

The verification of the Stable Release Update for cups-filters has completed successfully and the package has now been released to -updates. Subsequently, the Ubuntu Stable Release Updates Team is being unsubscribed and will not receive messages about this bug report. In the event that you encounter a regression using the package from -updates please report a new bug using ubuntu-bug and tag the bug report regression-update so we can easily find any regresssions.

Adam Niedling (krychek) wrote :

Fastest bugfix ever! Thanks!

To post a comment you must log in.
This report contains Public information  Edit
Everyone can see this information.

Other bug subscribers