Ubuntu

FTBFS: scons: *** [_csnd.so] Implicit dependency `/usr/lib/libpython2.7.a' not found, needed by target `_csnd.so'.

Reported by Andreas Moog on 2012-02-16
20
This bug affects 2 people
Affects Status Importance Assigned to Milestone
csound (Ubuntu)
High
Unassigned
Precise
High
Unassigned
python2.7 (Ubuntu)
High
Unassigned
Precise
High
Unassigned
python3.2 (Ubuntu)
High
Unassigned
Precise
High
Unassigned

Bug Description

csound FTBFS in current precise, probably due to multiarch related changes:

i686-linux-gnu-g++ -o libcsnd.so.5.2 -Wl,--as-needed -Wl,-as-needed -Wl,-Bdynamic -Wl,-as-needed -Wl,-Bdynamic -Wl,-rpath-link,interfaces -shared -Wl,-soname=libcsnd.so.5.2 -L. interfaces/CppSound.os interfaces/CsoundFile.os interfaces/Soundfile.os interfaces/csPerfThread.os interfaces/cs_glue.os interfaces/filebuilding.os -L. -L. -L/usr/local/lib -L. -L. -L. -lstdc++ -lutil libcsound64.so.5.2 -lsndfile -lsndfile -lpthread -lpthread -lgomp -lm -lasound -llo -lsndfile -ldl -lm -lpthread
scons: *** [_csnd.so] Implicit dependency `/usr/lib/libpython2.7.a' not found, needed by target `_csnd.so'.
scons: building terminated because of errors.
make: *** [debian/stamp-scons-build] Error 2
dpkg-buildpackage: error: debian/rules build gave error exit status 2

Full log: https://launchpadlibrarian.net/91946325/buildlog_ubuntu-precise-i386.csound_1%3A5.14.2~dfsg-2_FAILEDTOBUILD.txt.gz

Andreas Moog (amoog) wrote :

Actually, this looks like a bug in python2.7-dev, which ships broken symlinks.

Changed in csound (Ubuntu):
status: In Progress → Confirmed
assignee: Andreas Moog (amoog) → nobody
Changed in python2.7 (Ubuntu):
importance: Undecided → High
status: New → Confirmed
IRIE Shinsuke (irie) wrote :

python3.2-dev has the same bug.

Andreas Moog (amoog) on 2012-03-03
Changed in python3.2 (Ubuntu Precise):
importance: Undecided → High
Matthias Klose (doko) wrote :

csound should be fixed to use python2.7-config

Matthias Klose (doko) wrote :

fixed in precise

Changed in python2.7 (Ubuntu Precise):
status: Confirmed → Fix Released
Changed in python3.2 (Ubuntu Precise):
status: New → Fix Released
Changed in csound (Ubuntu Precise):
status: Confirmed → Invalid
Marcus Liebhardt (murcsack) wrote :

Actually, I still have this bug with python3.2, i.e. a missing symlink from libpython3.2mu.so -> libpython3.2mu.so.1. Installing python3.2-dev adds this missing link. Is this supposed to work that way?

Marcus Liebhardt (murcsack) wrote :

Never mind. I just learned, that this is intended to be like that. Sorry for the noise.

To post a comment you must log in.
This report contains Public information  Edit
Everyone can see this information.

Duplicates of this bug

Other bug subscribers