crystalspace 1.4.0+dfsg-4ubuntu2 fails to build with cegui-mk2 0.7.5-7

Bug #903121 reported by James Page on 2011-12-12
12
This bug affects 2 people
Affects Status Importance Assigned to Milestone
crystalspace (Debian)
Fix Released
Unknown
crystalspace (Ubuntu)
Medium
Unassigned

Bug Description

During the rebuild of packages depending on libcegui-mk2-dev to support
the transition from 0.6.2 to 0.7.5, crystalspace FTBFS with the newer
version of cegui-mk2 due to the changes in the API. This new version is
also in Debian unstable and testing.

Please see the attached build log for more details.

James Page (james-page) on 2011-12-12
Changed in crystalspace (Ubuntu):
importance: Undecided → Medium
Changed in crystalspace (Debian):
status: Unknown → New
Philip Wyett (philwyett) wrote :

Hi,

Thank you for raising this issue.

The crystalspace 1.4.x series will not be updated to support the latest cegui 0.7.5.

We have a 2.0beta1 now released which does support the latest cegui and does build with both debian and ubuntu (1). The final release for crystalspace 2.0 is scheduled for Feb 2012. Timed specifically to be ready prior to major distributions 6 month releases.

(1) New simple 'example' scripts for debian and ubuntu builds for the 2.0 series, now reside in the archive. Look under in the folder 'scripts/packaging/deb'.

Regards

Phil Wyett - CS Dev Team and Release Manager

Barry Warsaw (barry) wrote :

We'll have to decide what to do about this in Precise, because this ftbfs is causing libcegui-mk2-1 to be held in NBS (not built from source). Now that we're in beta freeze for 12.04, we'll need an feature freeze exception in order to update to the 2.0 series. Philip, would you be willing to start that process?

https://wiki.ubuntu.com/FreezeExceptionProcess

I can sponsor the upload when/if it gets approved.

Philip Wyett (philwyett) wrote :

Hi Barry,

To follow the 2.0 release cycle. For now I would use the stable 2.0 SVN tree until the next release which will be RC 1 is made. To do this use the svn tree at:

  https://crystal.svn.sourceforge.net/svnroot/crystal/CS/branches/release/V2.0

Release plans are at:

  http://trac.crystalspace3d.org/trac/CS/wiki/Version20Plan

I will start the exception process shortly.

Philip Wyett (philwyett) wrote :

Dear release team,

Could you consider and exception to allow version 2.0 of Crystal Space into the next release?

The update to 2.0 is required due to:

  - 1.4 series is an old release. Years old.
  - 1.4 series does not support the latest cegui (see comments above).
  - The Crystal Space project will not port to support the latest cegui in 1.4, due to API changes etc. in such an old releases series.
    (see comments above).
  - 2.0 supports the latest cegui.
  - 2.0 is more stable than 1.4.
  - 2.0 has more features.
  - 2.0 fully supports ARM builds.

A fully tested 2.0 in ubuntu will have no direct impact on the overall OS.

Please ask if any other additional info is required.

Martin Pitt (pitti) wrote :

Thanks Philip! This seems appropriate to me, and as we already have the newer cegui library anyway, updating to a supported and recent release sounds fine. Especially since the alternative would be to just drop crystalspace from precise.

I guess you want to update it in Debian, and then we'll just sync it over?

Changed in crystalspace (Ubuntu):
status: New → Confirmed
Changed in crystalspace (Ubuntu):
status: Confirmed → Triaged
Martin Pitt (pitti) wrote :

For the record, I removed the current crystalspace from precise. We can sync it back if we'll ever get a newer version in Debian that works.

Stefano Rivera (stefanor) wrote :

Unsubscribing the release team. There is nothing for us to do here, and this was an FFe for the last release.

Changed in crystalspace (Debian):
status: New → Fix Released
Logan Rosen (logan) wrote :

Looks like this was fixed with the 2.0 upload. Closing.

Changed in crystalspace (Ubuntu):
status: Triaged → Fix Released
To post a comment you must log in.
This report contains Public information  Edit
Everyone can see this information.

Other bug subscribers

Remote bug watches

Bug watches keep track of this bug in other bug trackers.