udevsettle and init-functions missing from initramfs

Bug #272301 reported by Brian Murray on 2008-09-19
8
Affects Status Importance Assigned to Milestone
cryptsetup (Ubuntu)
Low
Dustin Kirkland 

Bug Description

Binary package hint: initramfs-tools

1) Ubuntu 8.10
2) 0.92bubuntu13
3) After installing an Intrepid server with a encrypted root partition I saw the messages in the attached screenshot when booting up.

Briefly:

cryptroot: line 355: log_begin_msg: not found
cryptroot: line 355: log_end_msg: not found

/sbin/udevsettle: not found

Brian Murray (brian-murray) wrote :
Brian Murray (brian-murray) wrote :

Bug 247153 might be related to this also.

Changed in initramfs-tools:
importance: Undecided → Low
Dustin Kirkland  (kirkland) wrote :

Patch attached. Tested, fixes the error messages on LVM+crypt boot. Requesting sponsorship.

:-Dustin

Changed in initramfs-tools:
assignee: nobody → kirkland
status: New → In Progress
Reinhard Tartler (siretart) wrote :

looking at it, importing it to the bzr branch.

Launchpad Janitor (janitor) wrote :

This bug was fixed in the package cryptsetup - 2:1.0.6-6ubuntu2

---------------
cryptsetup (2:1.0.6-6ubuntu2) intrepid; urgency=low

  * Fixes for (LP: #272301)
  * debian/initramfs/cryptroot-script: must source /scripts/functions to get
    the log_*_msg() functions
  * 04_fix_udevsettle_call.patch: fix path to binary for udevsettle

 -- Dustin Kirkland <email address hidden> Fri, 19 Sep 2008 18:03:28 -0500

Changed in cryptsetup:
status: In Progress → Fix Released
To post a comment you must log in.
This report contains Public information  Edit
Everyone can see this information.

Other bug subscribers

Bug attachments