/scripts/local-top/cryptroot: 319: log_begin_msg: not found

Bug #237723 reported by Colin Josey on 2008-06-05
4
Affects Status Importance Assigned to Milestone
cryptsetup (Ubuntu)
Medium
Unassigned
initramfs-tools (Ubuntu)
Undecided
Unassigned

Bug Description

Binary package hint: cryptsetup

Ubuntu Version: 8.10
Package Version: Current and up to date (I am assuming 2:1.0.6-1ubuntu3, as the system won't boot)
Expected Result: The system would ask for the password and unlock the drive, in which LVM would access the drives and boot.
Actual Result: The system shows the usplash screen for a few seconds, the bar not loading, in which the system will automatically crash. Booting without the splash states that it cannot find the boot script in local-top, as far as I can recall.

Things tested: using an older initramfs will boot, but the home folder refuses to mount.
Analysis of the process of installing it independently caused me to think backing up /etc/initramfs-tools and replacing it with another version of the file based in /usr something of the same name that held the same folder structures with included scripts in local-top involving cryptsetup, and the system didn't complain about a loss of a script, but it did say the drive took too long to respond and dropped out into a busybox shell.

Colin Josey (storm99999) wrote :

Additionally, http://ubuntuforums.org/showthread.php?t=819059, a developer states that it most likely involves the lsb-helper scripts.

Reinhard Tartler (siretart) wrote :

could you please provide the output of an 'update-initramfs' run? do any error messages happen during regeneration?
Perhaps you could attach the broken initramfs to this bug?

Changed in cryptsetup:
status: New → Incomplete
Colin Josey (storm99999) wrote :

update-initramfs never shows an error message any time it's used. Unfortunately, I no longer have the initramfs in question as a critical error forced a reinstallation. I can attempt to reupdate to intrepid if necessary.

Kjell Braden (afflux) wrote :

Colin, I had a similar problem: my usplash bar bounced and nothing happend. Booting without usplash showed me the following error message:

/scripts/local-top/cryptroot: /scripts/local-top/cryptroot: 319: log_begin_msg: not found

Is this the same message you saw?

Colin Josey (storm99999) wrote :

Yes, I believe that was exactly the error message, down to the letter.

Kjell Braden (afflux) wrote :

Then I've got the same issues. update-initramfs does not print any further information. I'm using 2:1.0.6-1ubuntu3.

Changed in cryptsetup:
importance: Undecided → Medium
status: Incomplete → Confirmed
Changed in cryptsetup:
status: Confirmed → Fix Committed
Launchpad Janitor (janitor) wrote :

This bug was fixed in the package cryptsetup - 2:1.0.6-2ubuntu1

---------------
cryptsetup (2:1.0.6-2ubuntu1) intrepid; urgency=low

  * Merge new debian version. Remaining changes:
    - Add XSBC-Vcs-Bzr tag to indicate that this package is managed using
      bzr on launchpad.
    - debian/rules: cryptsetup is linked dynamically against libgcrypt and
      libgpg-error.
    - cryptdisks.functions: stop usplash on user input. LP #62751
    - Parse comments in lines not starting with '#', LP #185380
    - If the encrypted source device hasn't shown up yet, give it a
      little while to deal with removable devices. LP #164044
  * Depend on race-free version of libdevmapper, thus making udevsettle
    call from cryptsetup binary unnecessary. Dropping patch
    debian/patches/06_run_udevsettle.patch
  * remove patch from LP #73862, loading optimized modules has been solved
    in debian in another way.
  * cryptdisk.functions: remove spurious call to load_optimized_module.
    LP: #239946
  * bugfix: make regex work if keyfile has extended attributes. LP: #231339.
  * remove patch in cryptdisks.functions for rexecing the script itself for
    ensuring that a tty is always available. (See LP #58794.) According to
    Scott, this is not necessary anymore.

cryptsetup (2:1.0.6-2) unstable; urgency=low

  [ Jonas Meurer ]
  * Taken from ubuntu:
    - debian/scripts/luksformat: Use 256 bit key size by default. (LP: #78508)
    - debian/patches/02_manpage.patch: Clarify default key sizes (128 for
      luksFormat and 256 for create) in cryptsetup.8. (side-note in LP #78508)
  * Use 'shred -uz' instead of 'rm -r' to remove a tempfile that contains a
    key in gen-ssl-key example script.

  [ David Härdeman ]
  * Misc bugfixes to askpass, make sure it is installed to the correct
    location and is built using pedantic mode.
  * Change the initramfs script to use askpass to prompt for
    passphrases, this should hopefully fix #382375 and #465902 once it
    is enabled in the init scripts as well.
  * Add a keyscript called passdev which allows a keyfile to be
    retrieved from a device which is first mounted, mainly useful to get
    keyfiles off USB devices etc.
  * Unbreak MODULES=dep booting (closes: #478268)
  * Relax checks for suspend devices a bit (closes: #477658)
  * Convert man pages to docbook.

cryptsetup (2:1.0.6-1ubuntu4) intrepid; urgency=low

  [ Kjell Braden ]
  * Fix configuration parsing (LP: #239808)

  [ Reinhard Tartler ]
  * cryptroot-script: use 'echo' instead of 'log_begin_msg' (LP: #237723)

 -- Reinhard Tartler <email address hidden> Sat, 14 Jun 2008 23:28:51 +0200

Changed in cryptsetup:
status: Fix Committed → Fix Released
Colin Josey (storm99999) wrote :

As cryptsetup fixed the problem, it is invalid to claim that initramfs-tools is at fault.

Changed in initramfs-tools:
status: New → Invalid
mklemm (mirko-cm-klemm) wrote :

I think, the problem is actually in the documentation of initramfs-tools:

the examples and explanations in the initramfs-tools man pages forget to state that you have to source "./scripts/functions" for the various functions to work.
Looking into distribution-provided initramfs scripts however reveals a line saying

. ./scripts/functions

that should make the functions work

To post a comment you must log in.
This report contains Public information  Edit
Everyone can see this information.

Other bug subscribers