cryptsetup-initramfs: error message is displayed at initramfs stage when cryptsetup is not included to the initrd

Bug #1796438 reported by vmware-gos-Yuhua on 2018-10-06
50
This bug affects 8 people
Affects Status Importance Assigned to Milestone
cryptsetup (Debian)
Fix Released
Unknown
cryptsetup (Ubuntu)
Undecided
Unassigned

Bug Description

In ubuntu 18.10, error message is displayed at initramfs stage when cryptsetup is not included to the initrd.

<email address hidden>:~$ sudo update-initramfs -u
[sudo] password for vmware:
update-initramfs: Generating /boot/initrd.img-4.18.0-8-generic
cryptsetup: WARNING: The initramfs image may not contain cryptsetup binaries
    nor crypto modules. If that's on purpose, you may want to uninstall the
    'cryptsetup-initramfs' package in order to disable the cryptsetup initramfs
    integration and avoid this warning.
rmdir: failed to remove '/var/tmp/mkinitramfs_mxUIaj/var/cache/ldconfig': No such file or directory
vmware@ubuntu-1810:~$

There is a bug in Debian:
https://bugs.debian.org/cgi-bin/bugreport.cgi?bug=901830

vmware-gos-Yuhua (yhzou) on 2018-10-06
affects: cloud-init (Ubuntu) → initramfs-tools (Ubuntu)
Timo Aaltonen (tjaalton) on 2018-10-09
affects: initramfs-tools (Ubuntu) → cryptsetup (Ubuntu)
Launchpad Janitor (janitor) wrote :

Status changed to 'Confirmed' because the bug affects multiple users.

Changed in cryptsetup (Ubuntu):
status: New → Confirmed
vmware-gos-Yuhua (yhzou) wrote :

This issue disappear in ubuntu-18.10-server-amd64.iso and ubuntu-18.10-desktop-amd64.iso,
but it still exists in ubuntu-18.10-live-server-amd64.iso

Gordon Lack (gordon-lack) wrote :

NO.
The issue is still there in 18.10.

Processing triggers for initramfs-tools (0.131ubuntu15) ...
update-initramfs: Generating /boot/initrd.img-4.18.0-13-generic
cryptsetup: WARNING: The initramfs image may not contain cryptsetup binaries nor crypto modules. If that's on purpose, you may want to uninstall the 'cryptsetup-initramfs' package in order to disable the cryptsetup initramfs integration and avoid this warning.

[gmllaptop]: cat /etc/os-release
NAME="Ubuntu"
VERSION="18.10 (Cosmic Cuttlefish)"
ID=ubuntu
ID_LIKE=debian
PRETTY_NAME="Ubuntu 18.10"
VERSION_ID="18.10"
HOME_URL="https://www.ubuntu.com/"
SUPPORT_URL="https://help.ubuntu.com/"
BUG_REPORT_URL="https://bugs.launchpad.net/ubuntu/"
PRIVACY_POLICY_URL="https://www.ubuntu.com/legal/terms-and-policies/privacy-policy"
VERSION_CODENAME=cosmic
UBUNTU_CODENAME=cosmic

Gordon Lack (gordon-lack) wrote :

NOTE that mlst of the problem is the use of "may not", which means "is not allowed to".

"might not" ("appears not to") is probably intended.

Simply saying "This initramfs image does not contain cryptsetup binaries nor crypto modules." would be even clearer.

As written it gives the impression that you are erroneously trying to put cryptsetup code into initramfs when that is actually not allowed. It's that which worries people.

wrapperband (drajdoyle) wrote :

Note : Still getting this message on sudo apt upgrade

   update-initramfs: Generating /boot/initrd.img-4.18.0-16-generic
     cryptsetup: WARNING: The initramfs image may not contain cryptsetup binaries
     nor crypto modules. If that's on purpose, you may want to uninstall the
     'cryptsetup-initramfs' package in order to disable the cryptsetup initramfs
     integration and avoid this warning.

  ubuntu 18.10
     kernel 4.18.0-16-generic

Changed in cryptsetup (Debian):
status: Unknown → Fix Released
vmware-gos-Yuhua (yhzou) wrote :

Note : Still getting this message on ubuntu-19.04-live-server

  $update-initramfs -u

     update-initramfs: Generating /boot/initrd.img-5.0.0-13-generic
     cryptsetup: WARNING: The initramfs image may not contain cryptsetup binaries
     nor crypto modules. If that's on purpose, you may want to uninstall the
     'cryptsetup-initramfs' package in order to disable the cryptsetup initramfs
     integration and avoid this warning.

os: ubuntu 19.04 live server
kernel: 5.0.0-13-generic

Joseph Egry (zaxxonii) wrote :

Confirmed this is still happening in 5.0.0-17

update-initramfs: Generating /boot/initrd.img-5.0.0-17-generic
cryptsetup: WARNING: The initramfs image may not contain cryptsetup binaries
    nor crypto modules. If that's on purpose, you may want to uninstall the
    'cryptsetup-initramfs' package in order to disable the cryptsetup initramfs
    integration and avoid this warning.

vmware-gos-Yuhua (yhzou) wrote :

No this issue in ubuntu-19.10-live-server-amd64.iso daily build Aug-2019 with initrd.img-5.2.0-10-generic.
kernel: 5.2.0-10-generic

To post a comment you must log in.
This report contains Public information  Edit
Everyone can see this information.

Other bug subscribers

Remote bug watches

Bug watches keep track of this bug in other bug trackers.