Backspace/delete problem at boot-time entering hard disk encryption password

Bug #175282 reported by David Ward on 2007-12-10
10
Affects Status Importance Assigned to Milestone
cryptsetup (Ubuntu)
Medium
Unassigned

Bug Description

Binary package hint: cryptsetup

I have encrypted my hard disk using the option for doing so in the installer on the alternate install CD. When I enter my password at boot-time at the "sda5_crypt" prompt, the backspace key does not delete previously entered characters (and the delete key does not work either). As the installer suggested, I am using a long passphrase for encryption, so this often gets quite annoying when I make a mistake at the end of entering the password and have to press "Enter" to start over.

Omar Shami (bigfox) wrote :

I have noticed the same problem.

However, if you disable the Ubuntu splash screen, the text based password prompt will allow backspace to function at the password prompt.

Colin Watson (cjwatson) wrote :

Confirmed by duplicate.

Changed in cryptsetup:
importance: Undecided → Medium
status: New → Confirmed
AusIV (linux-ausiv) wrote :

It seems to me this is a problem with the way input is collected by the usplash_outfifo, rather than being a problem with cryptsetup itself.

Don't know what to do about it, but I'm sure it will help to start looking in the right place.

Reinhard Tartler (siretart) wrote :

backspace works for me properly in hardy, but not in gutsy.

I think this bug can be closed.

David Ward (dpward) wrote :

Also fixed for me in Hardy. Closing.

Changed in cryptsetup:
status: Confirmed → Fix Released
To post a comment you must log in.
This report contains Public information  Edit
Everyone can see this information.

Duplicates of this bug

Other bug subscribers