Manual page typos

Bug #164181 reported by era on 2007-11-20
8
Affects Status Importance Assigned to Milestone
cryptsetup (Debian)
Fix Released
Unknown
cryptsetup (Ubuntu)
Low
Unassigned

Bug Description

Binary package hint: cryptsetup

/usr/share/man/man5/crypttab.5.gz:
s/eg./e.g./g
s/ie./i.e.
s/dvd/DVD
s/inidicated/indicated
s/nondefault/non-default
s/mountpoints/mount points

Also the lines in this file are incredibly long, but I guess that's a fault of the software which generated it, and it's not meant to be edited anyway.

/usr/share/man/man8/cryptsetup.8.gz:
s/Maintainance/Maintenance
s/underlaying/underlying
s/backend/back-end
s/calculcation/calculation
s/evertime/every time/g
s/ist stripped/is stripped
s/Mathematic/Mathematics
s/suddely/suddenly
s/COMPATABILITY/COMPATIBILITY

The wording of this manual page could also need some care and loving but this is just a quick aspell check.

era (era) wrote :

Also s/This options/this option/ in cryptsetup (duh, that was the typo which caused me to run aspell on it in the first place).

Changed in cryptsetup:
importance: Undecided → Low
Bruno Barrera Yever (bbyever) wrote :

Man page typos fixed

Changed in cryptsetup:
status: New → In Progress
Changed in cryptsetup:
assignee: nobody → bbyever
status: In Progress → New
status: New → In Progress
Bruno Barrera Yever (bbyever) wrote :

nevermind, the patch was not working.

Bruno Barrera Yever (bbyever) wrote :

Here's the patch fixing the typos

Changed in cryptsetup:
status: In Progress → Confirmed
status: Confirmed → Fix Committed
era (era) wrote :

> +@@ -31,7 +31,7 @@
> + .PP
> > + \fIresize\fR <name>
> + .IP
> +-resizes an active mapping <name>. <options> must include \-\-size
> ++re sizes an active mapping <name>. <options> must include \-\-size

"re sizes"? That's a bit odd, don't you think?

> +@@ -127,16 +127,14 @@
> + .B "\-\-version"
> + Show the version.
> +
> +-.SH NOTES ON PASSWORD PROCESSING
> +-\fIFrom a file descriptor or a terminal\fR: Password processing is new-line sensitive, meaning the reading > will stop after encountering \\n. It will processed the read material (without newline) with the default hash or > the hash given by \-\-hash. After hashing it will be cropped to the key size given by \-s.
> ++.SH NOTES ON PASSWORD PROCESSING FOR REGULAR MAPPINGS
> ++\fIFrom a file descriptor or a terminal\fR: Password processing is new-line sensitive, meaning the reading > will stop after encountering \\n. It will processed

"It will process", I guess?

> +-If \-\-key-file=- is used for reading the key from stdin, no trailing newline ist stripped from the input.
> Without that option, cryptsetup strips trailing newlines from stdin input.

Was the blanket removal of this line intentional? (Killed one typo, it did :-)

> +diff -urNad cryptsetup-1.0.5~/man/cryptsetup.8~ cryptsetup-1.0.5/man/cryptsetup.8~
> +--- cryptsetup-1.0.5~/man/cryptsetup.8~ 1969-12-31 18:00:00.000000000 -0600
> ++++ cryptsetup-1.0.5/man/cryptsetup.8~ 2008-03-22 14:18:38.000000000 -0600

This part should probably not be included in the diff.

I don't see the diffs against usr/share/man/man5/crypttab.5.gz which were also included in my original report. Also the s/This options/This option which I reported as a follow-up is missing.

Bruno Barrera Yever (bbyever) wrote :

fixed that. sorry this was my first bug fixed and my first patch ever.

era (era) wrote :

You still have the Emacs backup files in the diff. Other than that, this looks great now. Thanks for your effort!

Cesare Tirabassi (norsetto) wrote :

Few comments, please get going as you are doing fine!

1 - We are patching the release version, which is hardy. Please use the right distribution in the changelog.
2 - No need to have two patches to fix the same problem, one should be sufficient.
3 - Add a description to your DPATCH patches (the line(s) with ## DP: No description.).
4 - Remove your backup file from the tree before debuilding the package (or remove it manually from the debdiff).
5 - Set the bug status to confirmed and assigned to nobody when the patch is ready.
6 - Since this package is in main you should subscribe ubuntu-main-sponsors, not ubuntu-universe-sponsors.

Thanks for your work!

Changed in cryptsetup:
status: Fix Committed → Incomplete
Changed in cryptsetup:
status: Incomplete → In Progress

here's a new patch fixing the typos and everything ^^

Changed in cryptsetup:
assignee: bbyever → nobody
status: In Progress → Confirmed
Daniel Holbach (dholbach) wrote :

Reinhard: can you please take a look at it?

era (era) wrote :

I'm not Reinhard, but all of the items from Cesare's list except #3 (which is a triviality anyhow) seem to be addressed.

Haven't re-verified the actual patch tho.

Cesare Tirabassi (norsetto) wrote :

@Bruno,

still just a couple of minor remarks:

1. Try to improve your changelog so that it is clear what does what/where/why. In this case it could be good to say:

* debian/patches:
  - add 07typos_fix.dpatch: Fix typos in man pages. (LP: #164181)

2. In DPATCH you should fill the header information. For instance, your email is <email address hidden> not bruno@bruno-desktop. Also, see where it says: ##DP: No description. ? We use that field to describe what the patch does and why, and eventually where is coming from. In this case is your patch, so just add a description (like ##DP: Fixes some typos in upstream's man pages).

If you have doubts, ask your mentor or on IRC (#ubuntu-motu).

Keep it up!

Bruno Barrera Yever (bbyever) wrote :

ok i fixed the changelog and the dpatch info.

Cesare Tirabassi (norsetto) wrote :

Looks cool. Be careful that the changelog entries should not exceed 80 columns!

Launchpad Janitor (janitor) wrote :

This bug was fixed in the package cryptsetup - 2:1.0.5-2ubuntu12

---------------
cryptsetup (2:1.0.5-2ubuntu12) hardy; urgency=low

  * added debian/patches/07_typos_fix.dpatch: fixed typos in man pages. (LP: #164181)

 -- Bruno Barrera Yever <email address hidden> Mon, 07 Apr 2008 18:43:05 -0500

Changed in cryptsetup:
status: Confirmed → Fix Released
Changed in cryptsetup:
status: Unknown → New
Changed in cryptsetup:
status: New → Fix Committed
Changed in cryptsetup:
status: Fix Committed → Fix Released
To post a comment you must log in.
This report contains Public information  Edit
Everyone can see this information.

Other bug subscribers

Remote bug watches

Bug watches keep track of this bug in other bug trackers.