[UVFe] upgrade to new upstream 1.0.5

Bug #138295 reported by Reinhard Tartler on 2007-09-08
2
Affects Status Importance Assigned to Milestone
cryptsetup (Ubuntu)
Undecided
Unassigned

Bug Description

Binary package hint: cryptsetup

we currently ship a subversion snapshot of cryptsetup. Debian has recently upgraded from svn29 to the latest release, and the changes are really minimal. I'd suggest that we sync to that version, and revise our current patches against the pacakge.

Reinhard Tartler (siretart) wrote :

Diffstat of changes

Reinhard Tartler (siretart) wrote :

the majority of changes are due to autotool and co changes. The actual changes to the upstream source are in one file (and is trivial). I'm attaching the diff.

Reinhard Tartler (siretart) wrote :

I've done the (re) merge using jelmer's bzr-rebase plugin. I'm attaching the resulting debdiff here.

Reinhard Tartler (siretart) wrote :

for completeness, I'm attaching the buildlog for completeness.

Scott Kitterman (kitterman) wrote :

Ack from me. Makes a lot of sense.

Chuck Short (zulcss) wrote :

Ack from me

Changed in cryptsetup:
status: New → Confirmed
Reinhard Tartler (siretart) wrote :

cryptsetup (2:1.0.5-1ubuntu1) gutsy; urgency=low

  * Merge new debian version. Remaining changes:
    - cryptsetup is linked dynamically against libgcrypt and libgpg-error.
      This will break systems where /usr is a separate encrypted filesystem
      but not have other bad consequences (in particular, systems with
      encrypted root are still fine). The upsides include better
      security supportability and smaller packages.
    - libcryptsetup.so et al removed from the binary packages. They have
      no stable ABI and are not suitable for use by other packages, and
      were in violation of library policies etc. They're not needed since
      the cryptsetup executable statically contains the relevant parts of
      libcryptsetup.
    - cryptdisks.functions: remove #!/bin/bash as it isn't a script
      by itself; it's only sourced by other scripts. This gets rid
      of the lintian warning `script-not-executable' for this file.
    - stop usplash on user input. LP #62751
    - Always output and read from the console. LP #58794.
  * Add XSBC-Vcs-Bzr tag to indicate that this package is managed using
    bzr on launchpad.
  * UVF exception request granted by Scott Kitterman and Chuck Short
    LP: #138295

cryptsetup (2:1.0.5-1) unstable; urgency=low

  [ Jonas Meurer ]
  * New upstream release, nearly identical to svn snapshot svn29.
  * Fix watch file to use cryptsetup instead of cryptsetup-luks.
  * Add 01_crypt_luksFormat_libcryptsetup.dpatch - rename luksInit to
    luksFormat in libcryptsetup.h.
  * Merge some ubuntu changes:
    - make luksformat check if filesystem is already mounted to prevent a
      strange error message.
    - modprobe dm-mod in cryptsetup.functions.
    - wait for udev to be settled in initramfs script.

  [ David Härdeman ]
  * Allow other crypto devices to be setup even if one fails.
    (closes: #423100)
  * Remove an incorrect warning in postinst.

 -- Reinhard Tartler <email address hidden> Sat, 08 Sep 2007 19:04:54 +0200

Changed in cryptsetup:
status: Confirmed → Fix Released
To post a comment you must log in.
This report contains Public information  Edit
Everyone can see this information.

Other bug subscribers