Wrong password full disk encryption on trusty lubuntu i386 prints a message of a font that doesn't render correctly

Bug #1256723 reported by Lyn Perrine on 2013-12-02
6
This bug affects 1 person
Affects Status Importance Assigned to Milestone
cryptsetup (Ubuntu)
Undecided
Unassigned

Bug Description

In a virtualbox virtual machine in testing the i386 alternate iso to set up encyrption you go to when first boot to enter password

apt-cache policy cryptsetup
cryptsetup:
  Installed: 2:1.6.1-1ubuntu1
  Candidate: 2:1.6.1-1ubuntu1
  Version table:
 *** 2:1.6.1-1ubuntu1 0
        500 http://us.archive.ubuntu.com/ubuntu/ trusty/main i386 Packages
        100 /var/lib/dpkg/status

Is the hardware information of the virtual machine
http://paste.openstack.org/show/54263

I expected an error message about wrong password to be printed. Instead I got a bunch of boxes and the font not being found. After I put in the correct password the virtual machine booted with full disk encrytion.

ProblemType: Bug
DistroRelease: Ubuntu 14.04
Package: cryptsetup 2:1.6.1-1ubuntu1
ProcVersionSignature: Ubuntu 3.12.0-4.12-generic 3.12.1
Uname: Linux 3.12.0-4-generic i686
ApportVersion: 2.12.7-0ubuntu1
Architecture: i386
CurrentDesktop: LXDE
Date: Sun Dec 1 15:44:37 2013
InstallationDate: Installed on 2013-12-01 (0 days ago)
InstallationMedia: Lubuntu 14.04 "Trusty Tahr" - Alpha i386 (20131201)
SourcePackage: cryptsetup
UpgradeStatus: No upgrade log present (probably fresh install)
crypttab: sda5_crypt UUID=66a9e44e-2506-4456-a0a0-a0c0cee14c53 none luks

Lyn Perrine (walterorlin) wrote :
Ubuntu QA Website (ubuntuqa) wrote :

This bug has been reported on the Ubuntu ISO testing tracker.

A list of all reports related to this bug can be found here:
http://iso.qa.ubuntu.com/qatracker/reports/bugs/1256723

tags: added: iso-testing
Steve Langasek (vorlon) wrote :

Does the problem of missing fonts happen only when a wrong passphrase is given? Or is the passphrase prompt also corrupted?

What language is your system configured for?

Is the encrypted filesystem the root filesystem, or a non-root filesystem?

Changed in cryptsetup (Ubuntu):
status: New → Incomplete
Steve Langasek (vorlon) wrote :

Also, what version of the libfreetype6 package do you have installed? (There has been a recent update to a new upstream version of this library, which may have some impact.)

Lyn Perrine (walterorlin) wrote :

libfreetype6 version is 2.5.1 lubuntu
The encrypted filesystem is the root filesystem.
System is configured for Enlish US.

I should add I first encountered this when restarting after installing the virtual machine.

I could get the VM to boot from not being started fine.

Steve Langasek (vorlon) wrote :

Ok. How about the first question:

> Does the problem of missing fonts happen only
> when a wrong passphrase is given? Or is the
> passphrase prompt also corrupted?

Lyn Perrine (walterorlin) wrote :

The passphrase prompt seems to be corrupted only when rebooting with correct or incorrect passphrase.

Steve Langasek (vorlon) wrote :

I don't understand what you mean by "only when rebooting". When else would you see the passphrase prompt, *except* when rebooting?

Lyn Perrine (walterorlin) wrote :

Only when I select reboot in the prompt on the shutdown menu and when first rebooting after installation.

Launchpad Janitor (janitor) wrote :

[Expired for cryptsetup (Ubuntu) because there has been no activity for 60 days.]

Changed in cryptsetup (Ubuntu):
status: Incomplete → Expired
To post a comment you must log in.
This report contains Public information  Edit
Everyone can see this information.

Other bug subscribers