xubuntu 13.10 can't enter password

Bug #1235836 reported by Robert Cress on 2013-10-06
24
This bug affects 5 people
Affects Status Importance Assigned to Milestone
cryptsetup (Ubuntu)
Undecided
Unassigned

Bug Description

I installed the October 4th version of the Xubuntu 13.10 daily build. I checked the boxes for both encrypting the hard drive and securing my user data. After installation and boot, it prompted me for the security phrase. However, the field was not selected and I was not able to use the keyboard. No characters were entered into the box when I typed, so I was not able to get to the desktop. Rebooting gave the same result. I reinstalled Xubuntu, but without the encryption options. This time, everything worked perfectly.

Thank you for taking the time to report this bug and helping to make Ubuntu better. It seems that your bug report is not filed about a specific source package though, rather it is just filed against Ubuntu in general. It is important that bug reports be filed about source packages so that people interested in the package can find the bugs about it. You can find some hints about determining what package your bug might be about at https://wiki.ubuntu.com/Bugs/FindRightPackage. You might also ask for help in the #ubuntu-bugs irc channel on Freenode.

To change the source package that this bug is filed about visit https://bugs.launchpad.net/ubuntu/+bug/1235836/+editstatus and add the package name in the text box next to the word Package.

[This is an automated message. I apologize if it reached you inappropriately; please just reply to this message indicating so.]

tags: added: bot-comment
affects: ubuntu → cryptsetup (Ubuntu)
Launchpad Janitor (janitor) wrote :

Status changed to 'Confirmed' because the bug affects multiple users.

Changed in cryptsetup (Ubuntu):
status: New → Confirmed
Robert Cress (robertwcress) wrote :

Elfy, this is at a similar bug, not I am not sure if they are the same. My problem is that the encrypted drive is detected, but it doesn't let me input the password. I get the graphical splash screen, which is very similar to the Xubuntu 13.04 splash screen, but it completely ignores my keyboard and I have to do a hard reboot.

I don't get a message that the partition isn't ready; everything seems to load perfectly, I just can't type the password.

Thank you to whomever changed the affected package to cryptsetup.

Steve Langasek (vorlon) wrote :

This is not reproducible here with Ubuntu 13.10. Do you get a response to any keys on the keyboard at all - for instance, does anything happen if you hit 'Esc'? When you say you have to 'hard reboot', is that using Ctrl+Alt+Del or do you really have to hit the power button? What happens if you boot without the 'splash' option on the kernel commandline?

Changed in cryptsetup (Ubuntu):
status: Confirmed → Incomplete
Bas (bfromthehill) wrote :

I Have the same problem as Robert Cress.
To me it seems that the keyboard is switched off.
I use a USB-keyboard.
Using GRUB the keyboard is fully functional. However as soon as Xubuntu boots it appears to be switched off as none of the led indicators on my keyboard don't work either.
Booting in save mode (command-line) results in the same problem: No keyboard and I cannot enter the password.
It makes no difference if I reboot using ctr-alt-del or if I use the power switch.

To post a comment you must log in.
This report contains Public information  Edit
Everyone can see this information.

Other bug subscribers